SOLVED: Linux Mint Mate installed. Timeshift asking for root subvolume (@).

jjconstr

Silver Member
Silver Supporter
Credits
611
Hello all,

Mint looks ok to me, though seems best to use it as little as possible until we have a snapshot. Upon installing, a 4 GB swap partition was recommended, but no selection appeared to me.

I selected recommended btrfs snapshot volume, but Timeshift asks for rsync.

Timeshift said selected partition is not a system disk.

Fourth attempted screenshot was rejected. It showed the external snapshot partition empty. Where would yesterday's snapshot be saved?

What do you think?


500 GBHDD 2020-05-28 08-28-48.png

Yesterday:
Timeshift 2020-05-27 20-52-52.png

Switched to rsync. Didn't think a snapshot was taken since storage partition was unacceptable to Timeshift:
Timeshift 2020-05-28 09-23-54.png
 


jjconstr

Silver Member
Silver Supporter
Credits
611
Hello All,

Timeshift says it made a Snapshot yesterday, the 27th. My external 1T SSD, Linux partition ( one with no root subvolume (@) has nothing in it. I manually made another snapshot today, successfully. Still nothing in SSD.

Here are screenshots of My Timeshift settings. If you see any problems, please let me know. After taking the shots, I changed Location to Toshiba SSD. Will try another shot with that setting to see if error messages result.

Snapshot location 2020-05-28 11-29-02.png



Snapahot Users 2020-05-28 11-30-15.png


Snapshot Filters 2020-05-28 11-31-44.png
 

jjconstr

Silver Member
Silver Supporter
Credits
611
Hi Again,

A new snapshot worked fine with the Location changed to Linux partition in Toshiba external SSD. The 'Type' of snapshot was rsync, but under 'Location', it was identified as btrfs. Is that a problem and if so, how is it corrected?

Am I using too many screenshots?

Do I now trust the Timeshift Snapshots? Go ahead and customize, run updates, etc?

Snapshot Type 2020-05-28 12-07-32.png


Snapshot Location 2020-05-28 12-08-07.png
 
Last edited:

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
4,882
Jerry, I'll start taking a look at this next 24 hours, been busy.

Cheers and

Avagudweegend, all

Wizard
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
4,882
Evening Jerry :)

The Timeshift snapshot taken Wednesday is on /dev/sda5, that is, your Linux root partition, where your operating system is. The WD 500GB drive.

In your Ubuntu, open your File Manager and if you are not in Home by default, navigate to Home.

There will be a half dozen folders shown eg Pictures, Downloads, Videos, Documents &c.

Then click and hold the Control button, and tap the h key, that is described as Ctrl-H

Then you will see what is really in your Home folder.

In amongst them will be a folder described as

.timeshift

(note the dot)

That's where your first snapshot is.

The first screenshot of your Timeshift Location indicates that /dev/sda5 is of a size of 103 GB, with 87 GB free. Included in that use space is formatting of maybe 1 GB, with maybe 7.5 GB being used for the System, and the screenshot taken by Timeshift taking up a similar amount, that is, the math works.:)

When you changed the location for storage of snapshots to the Toshiba, Timeshift took the shot, but it does not like it because you have the Toshiba formatted to the b-tree files system, that is BTRFS. It should be formatted to EXT4, like your Ubuntu install is on.

Is there a reason for this formatting?

Wiz
 

jjconstr

Silver Member
Silver Supporter
Credits
611
Hello Wiz,

Timeshift is in my home folder under subfolder File System. In it are many folders and files, but no Snapshots. I searched for .timeshift and Timeshift. As you can see in the attached Screenie: Home Folder/File System/Timeshift/Snapshots/2020-05-27_22-00-01/Localhost/Timeshift(empty). Further down the tree, snapshot folders are listed, none containing any snapshots, some repeating the files and folders in Local Host folder, which contains many folders like bin, boot, cdrom...and timeshift(empty).

Looking in external drive, which blinks continuously while snapshots are supposedly being made to it, (I've done several), a similar folder tree exists with Timeshift, Local Host(bin, boot, cdrom,timeshift), Snapshots, etc, with no snapshots contained. 'Show hidden folders' is turned on.

The reason for btrfs formatting is, that is the formatting I understood instructions to select. Later I wasn't able to change it.

Timeshift search 2020-05-30 11-42-26.png


It's your call,

Jerry
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
4,882
Jerry

Can you go to Terminal, and give us the output for (my comments are preceded by a #)

Code:
sudo timeshift --list --snapshot-device /dev/sda5

# and

sudo timeshift --list --snapshot-device /dev/sdc2
Copy and paste the output into your reply pane here. You can do so with the toolbar, right of the smiley face, 3 dots and a down button choose Code.

Thanks

Wiz

BTW also

The reason for btrfs formatting is, that is the formatting I understood instructions to select. Later I wasn't able to change it.
Can you tell us where those instructions were?
 

jjconstr

Silver Member
Silver Supporter
Credits
611
Wiz,
As to those instructions, see my first post in this thread. See the second screenie with the red shield with the X. That may be it. I'll look some more. I have been recently into linuxmint.com instructions.
jerry
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
4,882
Jerry with that screenshot above that you posted

Location-truncated.png


... on the right-hand side of the line with /dev/sdc2 on the Toshiba, the text is truncated (cut off) - Linux Mint T something - is that Linux Mint Tricia or Linux Mint Timeshift?

If that 200 GB partition is where you want to store your Timeshift snapshots from now on, then we want to reformat that drive from BTRFS to EXT4.

Cheers

Wizard
 

jjconstr

Silver Member
Silver Supporter
Credits
611
Quote
on the right-hand side of the line with /dev/sdc2 on the Toshiba, the text is truncated (cut off) - Linux Mint T something - is that Linux Mint Tricia or Linux Mint Timeshift?

Wiz, it says timeshift. Will we be able to reformat just the 200GB partition? There is a lot of data on the other partition of that external drive.

Thanks,
jerry
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
4,882
Yes, Jerry, we can do that.

Is the other data in NTFS, that is Windows, format?

Chris
 

jjconstr

Silver Member
Silver Supporter
Credits
611
Clicking Computer, and safely remove, error says external drive cant be stopped. Clicking mount, it says it cant be mounted, though I had just made a couple screenies of it and the light is on. The ext. drive doesnt show in the tree at left.

Also, the the computer view shows a name for the drives listed, but nothing else.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
4,882
I make it 1:45 AM Panhandle time, so I trust you are catching zzz's.

At Terminal, report please on the following:

Code:
apt-cache policy gparted
Code:
Mine looks like this on Ubuntu 18.04 MATE

Code:
[email protected]:~$ apt-cache policy gparted
gparted:
  Installed: 0.30.0-3ubuntu2
  Candidate: 0.30.0-3ubuntu2
  Version table:
*** 0.30.0-3ubuntu2 500
        500 http://mirror.aarnet.edu.au/pub/ubuntu/archive bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     0.30.0-3ubuntu1 500
        500 http://mirror.aarnet.edu.au/pub/ubuntu/archive bionic/main amd64 Packages
If yours has nothing (none) beside Installed:

Code:
sudo apt-get -y install gparted
Once GParted is installed, we'll start using it in preference to GNOME Disks that you are currently using - GParted is way better.

Out for my evening

Wizard
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
4,882
Cool! We will be focusing on the Toshiba, that is /dev/sdc, but you can get to know GParted better at your own time.

Entry for GParted will be in Menu, likely under System Tools, or else start to type in

gparted

and it will complete. Launch it and take a look (requires password).

There will be a part at the top where partitions are represented graphically, with separator lines between the partitions. Below that will be a larger pane, that contains text entries for the same partitions.

The initial view is of your hard drive, and there will likely be an icon at the left of the line for /dev/sda5, your root partition where the Linux OS is installed. Depending on the Distro used, that/those icons can look like a telephone handset with punch buttons, a padlock, a key, or other, and it means the partition is mounted an in use. A partition must be unmounted before you can manipulate it. As a safeguard, that cannot be done for /dev/sda5 when you are in your Ubuntu install, it would have to be done from elsewhere.

But we can work on /dev/sdc, the Toshiba.

Near top right-hand side is mention of /dev/sda, and a small "down elevator" button. Click that and it will show other drives. Click the one for /dev/sdc and you will see the Toshiba contents, including the 200 GB partition /dev/sdc2 which you wish to use for Timeshift snapshot storage, but is currently in BTRFS.

I need to give my arm a rest, so take a screenshot of /dev/sdc in GParted and post it up here, and we can go from there.

Cheers

Wizard
 

jjconstr

Silver Member
Silver Supporter
Credits
611
Wiz,

Don't seem to have a dev/sdc. Partitions in Gparted are:
dev/sda1, dev/sda2, dev/sda3, which are ntfs.
And dev/sda4, which is extended,
and dev/sda5 which is ext4.
Lastly, unallocated, which is 1.02 MIB.

External drive is plugged in.
Gparted was reopened a couple times and refreshed with no change.

Computer shows external in line items, but trying to mount brings; unable to mount.

Disks shows external 1T hard drive /dev/sdc. double clicking it in tree, results in graphic and details showing 800GB ntfs/exFAT/HPFS partition /dev/sdc1,
and 200GB Linux mint timeshift partition 2 -btrfs-/dev/sdc2.
Neither External Drive Partition is mounted.
Also, at the top, discription includes Master Boot Record.

I unplug and replug external drive after closing Gparted, Disks, and Computer. Then open Computer. Now External shows in tree and dev/sdc1 and dev/sdc2 show in line items and dev/sdc1 is mounted.

Gparted run by itself, still doesn't show the external drive.

Disks show the external drive as before.

Computer allows 'safely removing drive'. When mounted dev/sdc1 is removed, dev/sdc2 is also removed. without removing dev/sdc1, trying to mount dev/sdc2 brings:
Error mounting /dev/sdc2 at media/jerry/Linux Mint Timeshift: mount(2) system call failed: File exists.

I tried to install Gparted before, after not finding it installed. I clicked install, and it went to removing. Guess it was there already. I let it run and it never did finish. Stayed on 'Removing' all night. Cancelled it. Gparted opened normally.

Torn rotator cuff?

Thanks,
jerry
 


Members online


Latest posts

Top