Solus 3 - Installs fine, shows in update-grub but not on Grub Menu

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
2,030
OK break out the popcorn and laugh it up ... Wizard is stymied.

I am one of several trying to help @Horizon here

https://www.linux.org/threads/windows-applications-alternatives.16003/

On fairly rare occasions, I do not have a Distro in my stable or fleet, and so I will install it to better understand the environment of the user.

In this first instance, I downloaded, burned and installed Solus 3 MATE. It installed fine, I rebooted, having removed the Live stick as directed, no Solus.

The primary Distro (top of my leaderboard) currently, is Ubuntu 16.04.3 ‘Xenial Xerus’ LTS Unity. Solus did not appear in its Grub Menu.

I let the timer (10 seconds) elapse, entered Ubuntu and ran sudo update-grub (actually, I usually run sudo grub-mkconfig -o /boot/grub/grub.cfg, but same difference), Solus featured in the output.

I rebooted again, no Solus entry, no joy.

I checked with @Horizon on what DE she was using, it was GNOME, and so, not to be deterred, I downloaded and installed Solus 3 GNOME – same result.

On this occasion, after failing from Ubuntu, I skipped down to a Linux Mint, ran its update-grub and captured the result below.




Screenshot 1 - Output of Grub status


You can see the entries for Solus, with GNOME at /dev/sda25, and MATE at /dev/sda29.

I have taken a screenshot of the Toshiba’s State of The Nation with GParted from my Debian 9.3 ‘Stretch’ Cinnamon, because its resolution allows for capture of the full picture.

Insert screenshot Toshi-20180131-SOTN-ExDebian.png here



Screenshot 2 - GParted shot of current partition structure on test unit


Again, you can see the Solus’es, which I have labelled, one highlighted, the other with the cursor beside it.

My specs for the Toshiba Satellite lappie are as shown below, in the Spoiler

[email protected]:~$ inxi -Fxs

System: Host: debian9dot3Cinn Kernel: 4.9.0-4-amd64 x86_64 (64 bit gcc: 6.3.0)

Desktop: Cinnamon 3.2.7 (Gtk 3.22.11-1)

Distro: Debian GNU/Linux 9 (stretch)

Machine: Device: laptop System: TOSHIBA product: Satellite S70t-A v: PSKNEA-04G034

Mobo: Type2 - Board Vendor Name1 model: Type2 - Board Product Name1 v: Type2 - Board Version

UEFI: Insyde v: 1.60 date: 04/18/2014

Battery BAT1: charge: 41.1 Wh 100.0% condition: 41.1/45.0 Wh (91%)

model: Panasonic PA5109U-1BRS status: Full

CPU: Quad core Intel Core i7-4700MQ (-HT-MCP-) cache: 6144 KB

flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 19157

clock speeds: max: 3400 MHz 1: 2400 MHz 2: 996 MHz 3: 895 MHz

4: 2401 MHz 5: 949 MHz 6: 2400 MHz 7: 914 MHz 8: 900 MHz

Graphics: Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller

bus-ID: 00:02.0

Card-2: NVIDIA GK208M [GeForce GT 740M] bus-ID: 01:00.0

Display Server: X.Org 1.19.2 drivers: modesetting,nouveau (unloaded: fbdev,vesa)

Resolution: [email protected]

GLX Renderer: Mesa DRI Intel Haswell Mobile

GLX Version: 3.0 Mesa 13.0.6 Direct Rendering: Yes

Audio: Card-1 Intel 8 Series/C220 Series High Definition Audio Controller

driver: snd_hda_intel bus-ID: 00:1b.0

Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller

driver: snd_hda_intel bus-ID: 00:03.0

Sound: Advanced Linux Sound Architecture v: k4.9.0-4-amd64

Network: Card-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter

driver: ath9k bus-ID: 0d:00.0

IF: wlp13s0 state: up mac: a4:db:30:2c:2d:75

Card-2: Qualcomm Atheros AR8161 Gigabit Ethernet

driver: alx port: 3000 bus-ID: 0e:00.0

IF: enp14s0 state: down mac: 08:9e:01:e7:f7:0a

Drives: HDD Total Size: 1000.2GB (7.9% used)

ID-1: /dev/sda model: TOSHIBA_MQ01ABD1 size: 1000.2GB

Partition: ID-1: / size: 20G used: 8.1G (44%) fs: ext4 dev: /dev/sda9

Sensors: System Temperatures: cpu: 59.0C mobo: N/A gpu: 51.0

Fan Speeds (in rpm): cpu: N/A

Info: Processes: 199 Uptime: 48 min Memory: 828.1/7911.4MB

Init: systemd runlevel: 5 Gcc sys: 6.3.0

Client: Shell (bash 4.4.121) inxi: 2.3.5

[email protected]:~$


A cursory search on System Requirements for Solus (which is apparently a popular gaming platform) revealed as follows:

Here are the The Solus Project system requirements (minimum)
  • CPU: Info

  • CPU SPEED: Dual Core 2.0 GHz+

  • RAM: 4 GB

  • OS: Windows 7 64 bit and newer

  • VIDEO CARD: DirectX10 Compatible 3D Card - Minimum GeForce 460 or equivalent - Integrated graphics (Intel) may not work well and have not been tested. For use with Intel integrated graphics please run the game in DirectX10 compatibility mode.

  • SOUND CARD: Yes

  • FREE DISK SPACE: 11 GB
The Solus Project Recommended Requirements
  • CPU: Info

  • CPU SPEED: Quad Core 2.0 GHz+

  • RAM: 8 GB

  • OS: Windows 7 64 bit and newer

  • VIDEO CARD: DirectX11 compatible 3D card strongly recommended - GeForce 760 or equivalent and higher

  • SOUND CARD: Yes

  • FREE DISK SPACE: 11 GB
My system seems to meet the requirements.


Points to consider


  1. The Installer for Solus is one I have not met before (includes but is not limited to Ubiquity, Calamares, Thus, Anaconda, DrakLive). Because of my setup, I chose their equivalent (bottom option) for “Choose Other”, and chose pre-prepared EXT4 partitions for root (/). Solus under UEFI requires an ESP, of course, and it identified my /dev/sda2 existing one which was then at a size of 312 Mib, with about 76.5 MiB consumed between the other 25 or so Distros.

  2. The Installer did not specify a need for Swap, although I have one for Justin (just in case) of 4 GiB at /dev/sda3

  3. When the installer got to the point of starting to wind up and installed the bootloader (to /dev/sda as chosen), it executed within a minute or so. Typically this is the longest part for my installs, taking up to 15 minutes for os-prober to identify all my different Distros. Not so here.

  4. The .isos were downloaded http via the official website identifying my closest point

  5. sha256sums were checked and ratified as part of the downloads using DownThemAll and have been checked since.

  6. Downloads were performed on 2 different sticks in good order, for each operation.

  7. Method of burning was from command line, using dd, on unmounted partitions, using eg, for the first
    Code:
    # dd if=Solus-3-MATE.iso of=/dev/sdb bs=1M; sync

which always works for me


Points to Note

  1. Members @Condobloke and @nuna , both of whom came from whence I came, have used Solus. Brian got as far as installing Solus Budgie maybe 18 months ago, but did not like the Budgie DE. Nuna has just put it on VM in order to help @Horizon, but he is very busy as I understand it.

  2. Brief internet searches I have made indicate that Solus might have problems with xfs and btrfs compared to Ext4 – but this seems more a case of what it won’t install to

  3. Same searches indicate that it prefers a larger than typical ESP, of 512 MiB, so between failed install 1 and failed install 2, I took the time to increase the size of my ESP to 512 MiB plus, I think 558. Took a surprisingly long time in GParted but got there, still no joy, however the other Distros are happy to work with the altered ESP.

  4. For potential helpers, Solus uses a different package management system in terminal to eg apt, apt-get, yum, dnf, yaourt &c. It is called eopkg. There may be other differences. I have not yet tried using the Live medium to mount a Solus partition, chroot and reinstall Grub. PITA if there is an easier workaround.
I have access via my FMs to both installs, and can provide any output you require. I thought it would be silly to go to whatever Forum Solus use and sign up if I could find an answer in-house, here, but I can if needed, and bring back any knowledge I can learn.


BTW – There are a relatively few Linux Distros that do not work with large numbers of partitions. One is a sweet little lightweight called 4M Linux (only goes to 15 partitions), and an acquaintance of mine in New Zealand, whom is an alpha and beta tester for Mageia warned me its release candidate for Mageia 6 had some probs going past 30 (I have since found I was OK, installing both the RC and then the full release), but I have seen nothing yet to indicate Solus is one of these.

In summary, then

Hheeellllpppppppppp ! :D:D:D


Wizard
 


nuna

Member
Credits
0
According to Solus Help, it requires a 512MiB FAT32 partition for EFI, GPT disk and secure boot disabled, so nothing unusual.
More information at https://solus-project.com/articles/troubleshooting/ which states to boot from the UEFI boot menu (mainboard):
To ensure you are booting Solus you need to boot Linux Boot Manager from the EFI options.
Solus is using goofiboot as bootloader on UEFI systems. It seems they don't want to mix EFI specific bootloaders with grub (BIOS).

There were some users having a similar problem:

I thought it would be silly to go to whatever Forum Solus use and sign up if I could find an answer in-house, here, but I can if needed, and bring back any knowledge I can learn.
A proposed solution is answered here: Using GRUB with Solus on UEFI ...thanks to the kind user who had the patience to do a step by step tutorial on Solus forums.
 
Last edited:

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
2,030
I had a feeling I could rely on you for swinging by, @nuna :)

I had read the first of your dot pointed articles "Why Does Solus..." in my travels, but your placement of the article options helps considerably.

I will take a wee wander and try some of the options and report back as soon as able.

TIA of a successful outcome :D

Wiz
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
2,030
Making progress :confused:... writing this from Solus 3 GNOME, the latter of the two installs.

It definitely seems to have something to do with that Gummi Bear gummiboot thing, and tweaking your UEFI setup (did mine from F12).

I suspect I have a few hurdles ahead of me, but I will stumble around and see what I can ascertain.

@All I'll keep you posted, and thanks again @nuna :D

Wizard
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
2,030
A valid question, Paul.

With the aid of some of the articles posted by friend @nuna , I was able to, as I said earlier, install one of the Solus.

Gummiboot was forked into Goofiboot (all to do with avoiding systemd, as I understand it), and now clr-boot-manager has come into the picture, referred to here

https://github.com/solus-cold-storage/goofiboot

With the install, my computer had its boot setup rearranged between UEFI and CSM, something I am still working with, and I installed Linux Lite and Netrunner 18.03 Rolling (Arch-based) under a CSM regime. I now have two different grub menus depending on whether I F12 in at boot and switch between CSM and UEFI. All very interesting.

I have for the time being removed Solus, as the OP of the other thread, @Horizon , opted to change from Solus to Arch on her computer, so the project is on the back burner, until after I return from our road trip.

Interesting reading, though, can be found here - https://solus-project.com/forums/viewtopic.php?f=4&t=9500 - it is from Solus' own website forum, and yes, it is 4 pages long :rolleyes:o_O

However, the OP of that thread, now closed down, did have a number of legitimate concerns which I can in part vouch for. But I have not had the time yet to fully document my own journeys with it, and I am reluctant to join their Forum just to be seen as engaging in a bunfight :)

More when I have it

Cheers

Wizard
 


Members online


Top