Re-Enabling touchpad with xinput -enable 13 fails

RigasW

New Member
Dear all,

on my MINT 19.1 notebook I can successfully disable the touchpad using

xinput disable 13.

When I try to enable the touchpad again with

xinput enable 13

it does not work (I do not get any error message on that).

When doing disabling and enabling with my "admin" user, it works.
But the regular "desktop" user can only disable the touchpad, but not re-enable it.

this is how my xinput looks:

xinput
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ USB OPTICAL MOUSE id=10 [slave pointer (2)]
⎜ ↳ SynPS/2 Synaptics TouchPad id=13 [slave pointer (2)]
⎜ ↳ Sony Vaio Jogdial id=8 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Video Bus id=6 [slave keyboard (3)]
↳ Sony Vaio Keys id=7 [slave keyboard (3)]
↳ Power Button id=9 [slave keyboard (3)]
↳ USB2.0 Camera: USB2.0 Camera id=11 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=12 [slave keyboard (3)]



Did I miss something?

Thanks in advance,

RigasW
 


RigasW

New Member
After testing for several hours I found, that disabling the touchpad with "xinput disable nn" seems to work pretty consistent, while the following enabling only sometimes worked (as then as admin user) but in most of the test cases did not work at all.

To be precise, I could not move the cursor with the touchpad after doing a "enable".

The touchpad still responded to pressure, so I could do a left and a right mouse click with it (which is pretty useless, if you cannot move the cursor to where you want to click ....)
 

RigasW

New Member
I could solve the issue:

For a reason I do not remember I had installed the package "Xserver-xorg-input-synapics" when I set up the notebook.

I removed it ... and now everything works as designed.

xinput disable 12: Disables the touchpad
xinput enable 12: Enables it again.

I connected the functions to F2 and Shift-F2.

RigasW
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
G'day @RigasW and welcome to linux.org :)

Sorry I missed seeing this one but you seem to have a working solution in place, yeah?

If the touchpad is now on ID 12, did the AT keyboard move elsewhere?

If you want, give us the xinput output again and we'll look.

For a reason I do not remember I had installed the package "Xserver-xorg-input-synapics" when I set up the notebook.
... Possibly because your touchpad is Synaptics, but if it works without that all the better.


Sometimes when we use xinput to change the status of a device, and then other events occur, the device IDs can get re-mapped slightly.

With your previous xinput setup, an alternative to

Code:
xinput disable 13

# alternative is

xinput disable "SynPS/2 Synaptics TouchPad"
If, then, you come back to xinput later and your device ID is no longer there or has been re-mapped, you can scroll back through your bash history (direction key), find the exact syntax, and substitute enable for disable. This will then assign a new ID.

If you want to save your xinput output for future reference, it can be as easy as

Code:
xinput > xinput-list-save

# or choose your own filename, just not the command "xinput"
It will then be available in your home folder/partition.

Hope this helps

Chris Turner
wizardfromoz
 

RigasW

New Member
Hi Chris,

that is how it looks like now:

⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ SynPS/2 Synaptics TouchPad id=12 [slave pointer (2)]
⎜ ↳ Sony Vaio Jogdial id=8 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Video Bus id=6 [slave keyboard (3)]
↳ Sony Vaio Keys id=7 [slave keyboard (3)]
↳ Power Button id=9 [slave keyboard (3)]
↳ USB2.0 Camera: USB2.0 Camera id=10 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]

At the moment it works as I want it to work:

Touchpad is disabled, no cursor is jumping around the screen and I am not overwriting and deleting text that I have written seconds before.

If I understand correctly, you would advise that I use the device name instead of the device id for my disable/enable shortcuts?

Greetings from sunny Munich,

RigasW
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Munchen, eh? We have a young fellow named Peer you'll meet, from Hamburg :)

If I understand correctly, you would advise that I use the device name instead of the device id for my disable/enable shortcuts?
I would, in the longer term, in case the IDs change.

But if, in the short term, then obviously it is quicker to type

Code:
xinput disable 12
You will likely be aware that the xinput disable command only lasts for the duration of the session you are in - when you reboot, the functionality is lost and you have to invoke it again.

Touchpad is disabled, no cursor is jumping around the screen and I am not overwriting and deleting text that I have written seconds before.
There are longer-term solutions readily available, and I can tell you about them - where to find the config files and how to make the changes.

There are usually, also, options to disable the touchpad while typing, you may be interested in that?

Just let us know what Linux Distribution you are using - name, version and DE (Desktop Environment) eg MATE, Cinnamon &c, and we can go from there.

Cheers

Wizard
 

RigasW

New Member
Hi,

thanks for your great support!

I am running Mint 19.1 xfce.

I tried a configuration of the touchpad where it was automatically disabled when you press a key on the keyboard ... most of the time that worked, but not always, and then it was really a pain. I can type pretty fast with 10 fingers and more than once it happened that I unwillingly highlighted a big junk of text and deleted it by overwriting.

The solution where I can disable / enable the touchpad with a shortcut (I assigned it to F2 / Shift-F2)
fits perfect for my needs ... as long as this is a stable, reliable behavior.

Cheers,

RigasW
 

Members online


Latest posts

Top