Purchase Linux CDs / DVDs / Flash Drives at OSDisc.com

Welcome to Our Community

While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd please sign up again. Thanks!

problem with apt-get commands

Discussion in 'Ubuntu' started by aliEnsi, Jun 12, 2012.

  1. aliEnsi

    aliEnsi Guest

    Hi,

    I am using Ubuntu 10 under VMWare and behid a web proxy.
    It's impossible for me to run apt-get commands (apt-get install,apt-get update, apt-get upgrade...)



    Each time, I have systematically errors like :

    Unable to connect to....
    Unable to fetch ...

    Any ideas please ?
     
  2. nubbix

    nubbix Guest

    Try sudo aptitude install to see if that is installed
     
  3. nubbix

    nubbix Guest

    Ps, check vm settings and see if you forgot to bridge you network card with vm
     
  4. Akendo

    Akendo Guest

    When your behind a Proxy, you have to export into the bash enviroment the proxy settings. Use this:
    Code:
    export HTTP_PROXY='http://$IP:$PORT'
    export FTP_PROXY='ftp://$IP:$PORT'
    
    That should close the deal. When you want to make this persistent, put it into the /etc/profile file.
     
  5. aliEnsi

    aliEnsi Guest

    Reply to nubbix :
    Yes, aptitude is installed in my Ubuntu. And I get the same errors as when calling apt-get.
    Concerning VM settings, I think there no problem with them because I can connect to Internet through VMWare without problems...

    Reply to Akendo:
    I export the proxy setting as you described but there is no change.
    But, I tried to add my proxy parameters in the acquire section of the /etc/apt/apt.conf file:

    And the behavior become like this :
    The error "Unable to connect to...." no longer appear.
    The error "Unable to fetch ..." persists.
    I have this new error "400 Bad Request".

    Remark : I am using Ubuntu 10.01.1 LTS

    Any ideas?
     
  6. nubbix

    nubbix Guest

    Try using 12.04, version 10 is no longer supported
     
  7. Victor Leigh

    Victor Leigh Guest

    Version 10.04 is the LTS before version 12.04 and will still be supported until sometime in 2013.
     
  8. icebirdro

    icebirdro Guest

    Have you tried logging in to root from Terminal and install from there? or try sudo apt-get.
     
  9. nubbix

    nubbix Guest

    Ok my bad, good to know, thanks
     
  10. anter777

    anter777 Guest

    I had the same problem, actually helped. \ Thanks.
     

Share This Page