Purchase Linux CDs / DVDs / Flash Drives at OSDisc.com

Welcome to Our Community

While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd, 2017 please sign up again. Thanks!

  1. More ways to get the info! - we shoot all of our new original content out as well as random messages on Twitter and our newsletter!. Twitter | Newsletter
    Dismiss Notice

nVidia problems with OpenSuse 12.3 (64 bit)

Discussion in 'SuSE / OpenSUSE' started by DerrickDude, Mar 30, 2013.

  1. DerrickDude

    DerrickDude Guest

    Wow, the very first thread.......lol

    (Log in to hide this advertisement)

    Anyhow, I have a little minor problem that maybe someone has run across. It's two separate problems actually, not sure if they are related or not. I will try to keep this short as possible. I can post logs if needed but won't post them now. If you are a BOINC and/or Second Life user, that may be helpful.

    Computer specs: MSI 760GM-P23 mb with AMD Phenom II X6 1045T processor, 8 GB RAM, Zotac GF-GTX-550Ti, 1 GB video. Running 64 bit OpenSuse 12.3, with KDE 4.1, proprietary 310.32 nVidia drivers installed via one click. GLX-Gears gives 60 FPS consistently.

    Problem #1 - No graphics in Second Life (any viewer). Firestorm, Dolphin or Viewer2 will show all menus and such, but no huds or in world graphics of any kind. I can disable all the shadows and OpenGL buffer settings and get graphics, however the lag makes it virtually unusable. This problem started with 12.1 with 304 drivers but just appeared one day after working fine for many months. It just continued with the install of 12.3.

    Problem #2 - BOINC not recognizing GPU and CUDA capabilities.

    I have tried everything I know of to fix these two problems. I reinstalled all Mesa, Glibc and nVidia related packages (including 32bit) thinking they were broken somehow. The noveau drivers are blacklisted so the modules are not inadvertently loaded. I have looked at the logs and found nothing that screams "Hey, your video card is hosed!" I have done endless searches on both problems only to remain right back at square one after trying suggested remedies.

    Maybe someone can point me in the right direction. Let me know if logs are needed. I will gladly post. I thought I would just pose the problems first and go from there.

    Oh, this 12.3 install is pretty fresh and was a new install with format to wipe 12.1 completely.

    Thanks y'all!

    1 person likes this.
  2. mcneely.mike

    mcneely.mike Guest

    2 people like this.
  3. DerrickDude

    DerrickDude Guest

    Thanks Mike, but that problem is something that was particular to his system. I didn't have those problems, all of my viewers worked perfectly fine up until a few weeks ago. I am trying to figure out what got broken in my system and started causing this. I have no problems with the viewers running or crashing. They run fine, just no graphics in game.

    As for switching video cards.....I have had more problems with ATI cards in Linux and every other OS. I don't think I wanna open that headache again...lol
    1 person likes this.
  4. mcneely.mike

    mcneely.mike Guest

    Yeah... when i had an nvidia card, i loved it. Just can't afford it right now and am running an ATI because it came with the laptop.

    Wish i could help, but my help might hurt. :)
  5. DerrickDude

    DerrickDude Guest

    Update, problem #1 is solved. I have no idea which library it was as I got fed up and just re-installed all 32 bit libraries. Everything is back to normal with Firestorm. Seems the two problems aren't related as BOINC still won't recognize the CUDA functions of my GPU. I will continue to work on that. If anyone has any insight, please let me know!!!! :)


Share This Page