Welcome to Our Community

While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd, 2017 please sign up again. Thanks!

  1. Note: we recently updated out site software, please report any unseen issues - we do this often to insure your information is secure.
    Dismiss Notice

No sound after upgrading to mint 18.1

Discussion in 'Linux Audio / Video' started by davyng, Jun 23, 2017.

  1. Jeremy J

    Jeremy J New Member

    Joined:
    Feb 19, 2018
    Messages:
    14
    Likes Received:
    13
    [email protected] ~ $ aplay -D plughw:0,3 /usr/share/sounds/alsa/Front_Center.wav
    Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono

    No audio with above command.

    No audio with headphones plugged into every port on front and back.

    No other external speakers to try at the moment.

    @atanere, to rule out the video card, I removed the card, plugged HDMI into the motherboard, what I was going to do was install 18.3, but I cant get any video when turning the computer on and off to re-install.

    Thank you all again for trying to help me out.

    It's good to know audio works on 18.3 with the older build, which has been working for 5 years. However, plug and play took some random button clicking with 18.3. Bummer, to buy new hardware and assume it would just work. My fault.

    I don't need a gaming motherboard, I bought it solely based on reviews. Anyone want to recommend a board? Or point me in the direction to be reading about compatible hardware? Requirements are: Ryzen socket, DDR4, PCI slot for a video card. Perhaps something with significatly simpler audio.


     
    wizardfromoz and atanere like this.
  2. atanere

    atanere Moderator
    Gold Supporter

    Joined:
    Apr 6, 2017
    Messages:
    1,162
    Likes Received:
    1,152
    Yeah, I don't know if I would ever describe Linux as "plug and play".... but it is getting better. I'd still suggest going slowly and trying to solve, if you have the patience for it. Although a different motherboard might cure the problem, a different video card also might do the trick (maybe for less money... I'm a cheap kind of guy).

    I wish the headphones would have worked, and they still might with different random button-clicking... you would have definitely needed to switch off of HDMI Output back to speakers or headphones, among any other possible changes.

    Did you take a peek inside the BIOS setup?

    With your HDMI plugged in, have you tried this test (it is only noise/static, if it works):
    Code:
    speaker-test   #use CNTL-C to stop it (there may be a delay before it stops)
     
    wizardfromoz likes this.
  3. wizardfromoz

    wizardfromoz Well-Known Member

    Joined:
    Apr 30, 2017
    Messages:
    871
    Likes Received:
    972
    (my highlighting) - not really, friend ;), totally understandable.

    There is a large sub-community of Linux programmers and developers within the larger Community, many of them volunteer, whose main focus is on developing and modifying drivers to work with Linux. But you can imagine it is a huge job, and their load would be lightened considerably if manufacturers came more to the ball game.

    It may be like the X Files ... the truth is out there... or it is yet to come.

    Before kicking back (I am exhausted but have learnt a lot) and watching you guys do the voodoo that you do so well, I have found a couple of articles and will share them, if they do not muddy the waters.

    When I solve a problem I know nothing about (don't let this get out, or I'll have no street cred) I put it down to good Googling.

    In this case, I googled "AX370-Gaming K5 linux audio issue" (and often I will put "solved" to narrow the search), and I came up with

    https://forum.level1techs.com/t/ax370-gaming-k7-and-sound-issues-alc1220/122101/15 and previously I had discounted the K3 and K7 options as perhaps not being relevant. But through the above, I linked to this

    https://frdmtoplay.com/gigabyte-front-panel-audio-with-linux/

    ... and you can see there

    So reading through the rest I note similarities with what I was working on (close, but no cigar?) so hope they are of help.

    Finally, from me (deafening cheer from audience) one thought:

    1. as with testing for defective RAM sticks, and given Jeremy appears to have two audio cards, is there anything to be said for trying removing one at a time and see if something works?

    Cheers and good luck

    Wiz
     
    atanere likes this.
  4. Jeremy J

    Jeremy J New Member

    Joined:
    Feb 19, 2018
    Messages:
    14
    Likes Received:
    13
    [email protected] ~ $ aplay -D plughw:0,3 /usr/share/sounds/alsa/Front_Center.wav
    Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono

    No sound with command.

    No audio with headphones plugged in front or back. I'm afraid I don't understand the knowledge it takes to tell the motherboard where the sound is or needs to go.

    I'll pick up some inexpensive speakers from the store to test "normal" and post that in a day or two.

    Unfortunately, I don't recognize anything in the BIOS to adjust audio or audio channels. The only thing I have ever done with BIOS is to tell the computer to load from the DVDRW first to install a linux .iso.
     
    atanere and wizardfromoz like this.
  5. atanere

    atanere Moderator
    Gold Supporter

    Joined:
    Apr 6, 2017
    Messages:
    1,162
    Likes Received:
    1,152
    Just a short note from me as I've been working all night and now must sleep for awhile. A standard speaker arrangement should work (famous last words). But if for some reason it doesn't, you might consider a re-install of Cinnamon to reset everything back to original conditions since you are not too far into setting up this installation. Also, if Cinnamon fails to work, you might try one or two other distros to see if you can find success that way. In the process, you might also find another distro will make the HDMI work too. Just thinking out loud.... too tired to be very sensible right now. :confused::eek:

    Cheers
     
    wizardfromoz likes this.
  6. wizardfromoz

    wizardfromoz Well-Known Member

    Joined:
    Apr 30, 2017
    Messages:
    871
    Likes Received:
    972
    Just adding to what Sleepyhead was saying above - and I may be stating the bleeding obvious, but one person's bleeding obvious is another person's "Oh, I didn't think of that":

    If you try out an arbitrary number of other Distros, and have an appropriate supply of either USB sticks and or DVDs for Live Media, you can try these things out from the Live scenario without installing.

    This can apply to Wifi, Printers, Audio, Video - anything with drivers. For Gamers - joysticks &c.

    See if you can get your gear working with the Live, and if so, this has a 99.99% (arbitrary figure, but likely) chance of translating to the installed environment. Any changes you make will only apply to the current session of the Live medium, as they are only stored in RAM, but it could act as a good litmus test for choosing a Distro.

    Cheers

    Wizard
     
    atanere likes this.
  7. Jeremy J

    Jeremy J New Member

    Joined:
    Feb 19, 2018
    Messages:
    14
    Likes Received:
    13
    No, desktop speakers plugged into the Rear Speaker Out port don't produce audio. However, after the BIOS screen flashed while booting up, the speakers make a small cracking sound.

    While arbitrarily trying different distros is a possibility, I'd rather learn how to buy a motherboard with known working hardware. Something about this board doesn't work with Linux and I don't know how to adjust settings to make it. I'm scared to pick out another board. I don't need a gaming board, I only bought this one based on user reviews. What is simpler hardware known to work with Linux?
     
    atanere likes this.
  8. wizardfromoz

    wizardfromoz Well-Known Member

    Joined:
    Apr 30, 2017
    Messages:
    871
    Likes Received:
    972
    Mate, I'd be petrified :eek:, my hardware knowledge is very limited, others here will have more experience.

    I have one contribution, from Michael Larabel's site. Michael founded Phoronix in 2004, and his Phoronix Test Suite is highly favoured by people I used to work with at another site, used for benchmarking open source software including Linux.

    The page is here

    https://www.phoronix.com/scan.php?page=category&item=Motherboards

    ... but I do note that it includes a Gigabyte Aorus Gaming 7 :rolleyes:

    This was simply near the top under a search under "linux best motherboards".

    Hope it helps

    Cheers

    Wizard
     
    #28 wizardfromoz, Feb 26, 2018
    Last edited: Mar 1, 2018
    atanere likes this.
  9. atanere

    atanere Moderator
    Gold Supporter

    Joined:
    Apr 6, 2017
    Messages:
    1,162
    Likes Received:
    1,152
    Phoronix is a nice site, but I didn't find a review there of your exact mobo. A search for it through Phoronix into Google turned up an interesting thread about Gigabyte gaming mobo's and Ryzen CPU's.... but it was mostly about difficulty just being about to boot up and install Linux, so not quite applicable to your case either. This thread did seem to indicate that Fedora and Manjaro might be better distros to try.

    I don't have any specific mobo recommendations for you to buy. There are too many, and I run very old junk here myself. Checking those that have been reviewed at Phoronix is certainly a good guide for you though.

    I love to beat a dead horse, however, and if you have the time and patience, I know that Wizard and I will keep trying to help you solve the issues with your current setup. So, I'll comment a little further now, but I understand if you are going to give up on it and call it quits too.

    The comment I quoted above still takes me to your BIOS for possible tweaking. I have seen BIOS settings that select between onboard and PCI video, so when you removed the video card, this could have been a reason not to get video when you tried to reinstall Mint. But there are some other things that can cause a "black screen" problem... this can sometimes be fixed by giving a special command when booting on the Linux DVD/USB.... you interrupt the boot and insert the command "nomodeset" and then continue. It often works, but who knows if it will work for you unless you try it. (Ask if you want to try this and don't know how to do it.)

    But basically, this is suggesting starting over from scratch. And if you want to do that, I would remove the video card, then go into BIOS and find where it will let you "Reset to default" and choose that, and save the changes before exiting BIOS setup. If you made any BIOS tweaks previously, they will be gone too.... but default settings should work with anything to get you started again. The BIOS default will be to onboard video, if there is even a choice like that I mentioned. Then, with your new speakers plugged in, I'd try to boot the Mint install DVD/USB.... first without nomodeset, but then adding it if you still get the black screen. But using HDMI on the motherboard is beyond my experience too, so I still am unsure if these steps might work to start over from scratch.

    And, alternatively, I would still try some other Linux distros before buying a new motherboard. I still tend to think that a solution is possible for you. But it is taking more effort than what is typical.

    Cheers
     
    wizardfromoz likes this.
  10. Jeremy J

    Jeremy J New Member

    Joined:
    Feb 19, 2018
    Messages:
    14
    Likes Received:
    13
    I'll beat this dead horse. The machine is unplugged sitting in the corner. I don't know much about other distros. I hated the user friendly-ness of Debian. Ubuntu is ok, but I appreciate Mint's desktop setup.

    I ordered a usb flash drive to update the BIOS. I ordered a new HDMI cable, just in case. Both in the mail. Because since my last post, the old machine which audio worked with random button clicking, sound also stopped. It came back the next day, I did nothing different, except the next day there was a kernel firmware update that I installed and I guess that made sound come back. I don't know.

    Plan: put the kernel firmware update on the new machine, update the BIOS from Gigabyte's website when the flash drive arrives. Attach a new HDMI cable. I have not tried to install Linux without the video card installed. I will post back when this is done (probably Sunday night). And I'll keep replying to this thread.
     
    atanere likes this.
  11. wizardfromoz

    wizardfromoz Well-Known Member

    Joined:
    Apr 30, 2017
    Messages:
    871
    Likes Received:
    972
    Hear Hear to both of you :p and good morning from Oz, I am on my 2nd coffee.

    @atanere - that nomodeset option is certainly worth a try ... is there anything to be said for trialling it with the existing setup, inserting it at startup?

    Jeremy's setup, if LM 18.3 is the only OS on board, would have no Grub Menu by default, just boot straight in, but Grub Menu can be made visible by holding down or tapping the left Shift key. He could then choose "e" to edit and insert the nomodeset option. If he prefers to see a Grub Menu, then we can instruct on how to make that permanently visible.

    @Jeremy J - I wonder if it is purely the Linux Mint Cinnamon look that you like (& I like it too :D), or if it is specifically the Cinnamon DE.

    Since Linux Mint developed Cinnamon, it has been taken up by a number of the Distros Devs as an option, I could track down some for you to try if you wish. Or else you can take an existing Distro and install an additional DE, and choose to boot from one or the other at login.

    Think about it.

    Cheers and

    avagugweegend

    Wizard
     
    atanere likes this.
  12. atanere

    atanere Moderator
    Gold Supporter

    Joined:
    Apr 6, 2017
    Messages:
    1,162
    Likes Received:
    1,152
    A man after my own heart! :cool::D I hope the new cable and BIOS update will do the trick, or a fresh install if you go that far. I really think (and hope) a solution is there without buying a new motherboard, but it is sure making you work for it. Let us know how you're coming along.

    Cheers
     
    wizardfromoz likes this.
  13. Jeremy J

    Jeremy J New Member

    Joined:
    Feb 19, 2018
    Messages:
    14
    Likes Received:
    13
    No audio after fresh install, new HDMI cable, BIOS update to F20 from Gigabyte's website and sudo update and upgrade. Pressed the same buttons as before on the old machine to make sound work. Sure feels like a pebkac problem.

    I have not looked at distrowatch in years. I'm a fan of LM 18.3 Cinnamon because of the layout. Looks and acts most like Windows. Linux has often upset me in the past when it comes to moving buttons and menu bars around on me after an update.

    What distro should I try out as an option?

    I don't know anything about nomodeset. No grub present on start up. LM 18.3 is the only OS on the HD.

    I don't have a copy of Windows to confirm if the problem is hardware of Linux.

    Unrelated, the amazon store I bought the board from wont respond to my attempt to start a refund. I don't need a fancy motherboard. I need to learn how to buy a simple board that "just works".
     
  14. wizardfromoz

    wizardfromoz Well-Known Member

    Joined:
    Apr 30, 2017
    Messages:
    871
    Likes Received:
    972
    Hi Jeremy... Maaatttee

    Have a read of this, and then come back to me

    https://www.omgubuntu.co.uk/2016/07/key-to-show-grub-menu-ubuntu

    ... now I, in my travels, get conflicting info on this subject, some say left shift key, others right ... it may vary from pc make to pc make, but it does work. Some say keep tapping, some say hold down the key.

    Once you get it, it will look a bit like that Ubuntu reference in the link.

    When you get it, stick with the line that references your Mintie, and look at the bottom of the bordered screen and you'll find 'e' to edit. Press 'e'.

    You'll be presented with a bordered screen containing maybe 10 lines of commands.

    Down near the bottom (use your direction keys) there'll be a line perhaps starting with "vmlinuz" and including the words "quiet splash". It may or may not be followed by other words.

    Move to the right, and following "quiet splash" insert the word "nomodeset". If there are words following, put nomodeset in between quiet splash and those words.

    Follow the instructions at bottom to continue, could be Ctrl-x, F10, whatever, to boot.

    Let us know what happens.

    The nomodeset option only covers the one session, and resets on reboot. We can, however, make Grub permanently visible for you.

    Cheers

    Wiz
     
  15. atanere

    atanere Moderator
    Gold Supporter

    Joined:
    Apr 6, 2017
    Messages:
    1,162
    Likes Received:
    1,152
    Damn. :eek: We were all hoping for something to happen. Did the regular speakers not work either?

    Wizard may be onto something... I've learned it's not wise to second-guess him, anyway. :D So try to follow where he is leading you if you can.

    If you are game to try some other distros, I would try several, at least 3 or 4 if needed, to try to evaluate further. No need to install them, just boot on live DVD/USB to test out your hardware before installing. I still would not rule out Mint, but I'd give the MATE edition a chance (quite similar to Cinnamon, IMO). I would try Peppermint OS, and PCLinuxOS. For even more, I might try Manjaro, and Solus, and MX Linux. If you would be willing to disable UEFI and Secure Boot in BIOS, I would also recommend Linux Lite. Some of these are still Debian/Ubuntu based, but they may still have settings that make your hardware work.... several of the other distros are independent from Debian/Ubuntu, and that can also help if the problem is peculiar to the Debian/Ubuntu family.

    Off to sleep for now... one more midnight shift, then some days off.

    Cheers
     
    wizardfromoz likes this.
  16. Ken Simpson

    Ken Simpson New Member

    Joined:
    Mar 8, 2018
    Messages:
    1
    Likes Received:
    2
    I had no sound after installing Mint cinnamon 18.3,32 bit, on my laptop. Went to preferences, Sound, under output clicked on headphones, bingo! sound is back. Dont know why, I dont use headphones. Not a very technical reply, hope it may help.
     
    Rob and wizardfromoz like this.
  17. Jeremy J

    Jeremy J New Member

    Joined:
    Feb 19, 2018
    Messages:
    14
    Likes Received:
    13
    I hit R shift key every second on start up, 2-3 times/second, restarted the computer and tried L shift key with the same manic shift key button pushing, neither attempt led me to GRUB.

    I have a 16gb usb flash drive. I have LM mate 18.3 iso downloaded, I also have majaro xfce 17.16 iso downloaded. I went into the BIOS boot options, I don't understand how to make the computer boot from a usb drive with the available options. Would be interesting to boot either of those distros like a live cd to check audio.

    I did find another forum with a similar user problem of a very similar motherboard, but I don't understand the fix as listed in the second link. This kinda sorta looks like a fix to my problem, but I cant understand their language.

    https://forum.level1techs.com/t/ax370-gaming-k7-and-sound-issues-alc1220/122101

    https://frdmtoplay.com/gigabyte-front-panel-audio-with-linux/

    I cant return my Gigabyte GA-AX370-Gaming K5 and I promise I'll never buy a high end board again.
     
    #37 Jeremy J, Mar 14, 2018
    Last edited: Mar 14, 2018
  18. atanere

    atanere Moderator
    Gold Supporter

    Joined:
    Apr 6, 2017
    Messages:
    1,162
    Likes Received:
    1,152
    Hi Jeremy. @wizardfromoz gave you both of these same links above in post #23. Even earlier, he was onto the idea of using the pulse audio pacmd command to add an additional sink that might engage your sound stream... this is the same idea being described in the 2nd link as a possible fix. This fix entails activating a 3rd sink on your board instead of just the two that you have shown with earlier command line output. With a long thread, and fairly long breaks in between activity, it's easy to get lost (I know I am). This fix might work, and it might not.... but the description on the 2nd link does not quite fit your scenario either as it describes a situation where the back panel connections work, and the fix is to activate the front panel connections. I think we also confirmed earlier that you don't have any sound, front or rear.

    You may need to hold the shift key continuously.... not tap it. I have trouble making this work too.

    We usually try to encourage everyone to boot up on a live DVD or USB first to check out their hardware before installing Linux, and you clearly understand why now too. The first link you and Wizard gave indicated Manjaro Linux made the sound work on your motherboard, or one similar to yours. It would be well worth the effort to boot it up and test it... and if it fails, then to try some others. It is a huge advantage to find a distro that works out-of-the-box, if you can.

    When your computer is booting, there is usually an F-key (or ESC) that you can hit that will give you a boot menu... from there, you can choose USB as a one-time boot option (you may need the USB stick already plugged in when you do this). You probably used this method when you first installed Linux Mint. In your BIOS, you can set the computer to permanently boot first on a USB or DVD if a bootable device/media is plugged in. This slows down the boot process slightly as it has to search for devices at every boot time, so it is usually off by default. Anyway, in BIOS, you should have a section for Boot Order.... it is there that you can put the USB and/or DVD options above the hard drive, usually using the F5 and F6 keys to move each item up or down on the list.

    Cheers
     
    wizardfromoz likes this.
  19. wizardfromoz

    wizardfromoz Well-Known Member

    Joined:
    Apr 30, 2017
    Messages:
    871
    Likes Received:
    972
    Morning all :p

    Let's get Jeremy's Grub Menu permanently visible, he can always change it back if he wishes.

    Jeremy, we're going to alter a file which is simply called Grub, no extension, it is one of several files that build the full Grub process, and it lives in /etc/default/ .

    It requires admin privileges to change it. We're going to change the file, and then update Grub. We can do this from the Desktop GUI or from Terminal. For the benefit of The Viewers, the OP is using Linux Mint 18.3 'Sylvia' with the Cinnamon Desktop Environment.

    DESKTOP WAY

    1. Open your File Manager (Nemo) and in the left pane click File System, the folders will be revealed on the right
    2. Find Etc and double-click it, then navigate to Default but don't double-click it. Instead
    3. Right-click Default and choose Open as Root, enter your password.
    4. Navigate to the file Grub and double-click it, it opens in a Text Editor called Xed
    5. We'll change one line and check another.
    6. The line that says GRUB_HIDDEN_TIMEOUT=0 ... put a hash # in front of it, no spaces
    7. Check a line below GRUB_TIMEOUT=10 ... if it does not say 10, put a 10 there
    8. Exit and save changes
    The file is now saved, but we have yet to update Grub to apply the changes at reboot. See the end part of below.

    TERMINAL WAY

    1. At Terminal
      Code:
      sudo nano /etc/default/grub
    2. Navigation is by way of your directions keys
    3. Change/check the two lines as described above
    4. Ctrl-x to start the exit process, it will prompt you to save or discard changes
    5. Shift-y to save changes, it shows you the file name
    6. Enter will then exit (sounds funny :rolleyes:)
    UPDATE YOUR CHANGED GRUB

    This for both the methods above. At Terminal:

    Code:
    sudo update-grub
    Then reboot your computer, the Grub Menu should appear.

    Cheers

    Wizard
     
    atanere likes this.
  20. ZEUS-PA

    ZEUS-PA New Member

    Joined:
    Apr 13, 2018
    Messages:
    1
    Likes Received:
    2
    So, I realize I am a little late in the game here. I was having a similar issue and found a resolution to my problem there (and a pretty simple one at that!)
    https://www.linuxquestions.org/ques...und-hardware-in-linux-mint-18-1-a-4175605741/
    The link for the whole discussion is above, but the solution is here:
    ###########
    Here is what I did:

    Added the following line to the file etc/modprobe.d/alsa-base.conf:

    "options snd-hda-intel model=ref"
    ###########

    You'll have to open the containing folder, "modprobe.d" as root, which always makes me nervous, but after restarting my system, all sound works.
     
    wizardfromoz and atanere like this.

Share This Page