Mysterious Non-existent Network Adapter


New Member
Sep 17, 2019
Reaction score
Hi all,

Still relatively new to Linux so please be gentle.

I recently bought (what I thought was) and Intel Compute Stick and was planning on turning into a mobile HTPC and retro gaming device. It originally came with Windows 10 and all was well. I thought it might be a good opportunity to learn some basic Linux so installed Ubuntu 18.04 only to find out that both had no sound or network. Tried numerous other OS (LibreElec, OpenElec and Recalbox) and while I managed to get the sound working on all of them, still no Network. I then read in another forum that Ubuntu 19 was released and that the new drivers for the Stick PC I thought I'd bought were included. So I reinstalled Ubuntu on a clean install and hoped that this would fix it. It did not.

After searching in lots of forums, and trying all sorts of shell commands I realised that what I'd bought was a Chinese Rip Off. And now I cant identify my network adapter to fix the issue.

Attached is some files I hope will help diagnose the issue.



  • issue.txt
    23.8 KB · Views: 791

Latest posts