Mint Hardware

brian@brian-desktop:~$ inxi -Fxz
Kernel: 5.15.0-91-generic arch: x86_64 bits: 64 compiler: gcc v: 11.4.0
Desktop: Cinnamon v: 6.0.4 Distro: Linux Mint 21.3 Virginia
base: Ubuntu 22.04 jammy
Type: Desktop Mobo: ASRock model: B150M Pro4 serial: <superuser required>
UEFI: American Megatrends v: P7.30 date: 04/11/2017
Info: quad core model: Intel Core i7-7700 bits: 64 type: MT MCP
arch: Kaby Lake rev: 9 cache: L1: 256 KiB L2: 1024 KiB L3: 8 MiB
Speed (MHz): avg: 1268 high: 3020 min/max: 800/4200 cores: 1: 800 2: 800
3: 980 4: 3020 5: 1853 6: 1095 7: 800 8: 800 bogomips: 57600
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Device-1: Intel HD Graphics 630 vendor: ASRock driver: i915 v: kernel
arch: Gen-9.5 bus-ID: 00:02.0
Display: x11 server: X.Org v: with: Xwayland v: 22.1.1 driver: X:
loaded: modesetting unloaded: fbdev,vesa dri: iris gpu: i915 resolution:
1: 1920x1080~60Hz 2: 1920x1080~60Hz
API: EGL v: 1.5 drivers: N/A platforms: active: gbm,x11
inactive: wayland,device
API: OpenGL v: 4.6 vendor: intel mesa v: 23.0.4-0ubuntu1~22.04.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 630 (KBL GT2)
Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASRock
driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
Device-2: Logitech Z Cinéma driver: hid-generic,snd-usb-audio,usbhid
type: USB bus-ID: 1-9:4
API: ALSA v: k5.15.0-91-generic status: kernel-api
Server-1: PipeWire v: 0.3.48 status: off
Server-2: PulseAudio v: 15.99.1 status: active
Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6
IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
Local Storage: total: 2.43 TiB used: 336.78 GiB (13.5%)
ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 250GB
size: 232.89 GiB temp: 37.9 C
ID-2: /dev/sda vendor: Samsung model: SSD 750 EVO 120GB size: 111.79 GiB
ID-3: /dev/sdb vendor: Seagate model: ST3300822AS size: 279.46 GiB
ID-4: /dev/sdc vendor: Western Digital model: WD Elements 2621
size: 1.82 TiB type: USB
ID-1: / size: 227.68 GiB used: 26.56 GiB (11.7%) fs: ext4
dev: /dev/nvme0n1p2
ID-2: /boot/efi size: 511 MiB used: 12.9 MiB (2.5%) fs: vfat
dev: /dev/nvme0n1p1
Alert: No swap data was found.
System Temperatures: cpu: 41.0 C pch: 41.0 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 299 Uptime: 1h 22m Memory: total: 32 GiB note: est.
available: 31.02 GiB used: 2.87 GiB (9.3%) Init: systemd
target: graphical (5) Compilers: gcc: 11.4.0 Packages: 2646 Shell: Bash
v: 5.1.16 inxi: 3.3.31

Works as I expected.

It is likely to be because you tried to use Launch for a terminal command in the Software Manager, but I can't explain why the whacko error and dependency messages until I install Virginia.

Certainly inxi was not going to be installed, it is already there.


BTW hope we have not confused the OP.

Noel, stick with what I said earlier

It is likely to be because you tried to use Launch for a terminal command in the Software Manager,
In software manager it has the green tick....showing it is installed. If I click on it, it promptly shows that error message ::
The following packages have unmet dependencies:
mintsources: Depends: mint-common (>= 2) but it is not going to be installed
Depends: gir1.2-xapp-1.0 but it is not going to be installed
Depends: inxi but it is not going to be installed

and no possibility/link to uninstall
Synaptic package manager show inxi as installed : 3.3.13-1-1 ....and latest version as : 3.3.13-1-1
I would usually conclude that inxi was removed via the upgrade mechanism from LM21.2 to LM 21.3
For gir1.2-xapp-1.0 - Virginia has

gir1.2-xapp-1.0 2.8.2

and for

mint-common (>= 2) but it is not going to be installed

Virginia has

mint-common 2.3.1

... so it is all to do with the fact that the stuff is all already installed.
Guess what, it is an ongoing issue, the below is from my Linux Mint 21.2 Victoria


No version change to inxi, either.


I think deadbeef may also be a 'victim'...

Music player and organiser for those unaware.
inxi has been installed by default in Mint Cinnamon for least since 2016 when I started collecting Terminal commands.

Some of my very first Commands back then...
Mint Desktop environment
    inxi -Szxx
What OS are you using
   inxi -S
Version of Linux Mint
  inxi -Sz

Back then it was Cinnamon 17.2...has it been that long.

Members online