Lost sound on Pi4 after update.


Well-Known Member
A few months ago, I lost the sound from the HDMI output of my Pi, after an update. I am using the 4gb Pi4. After much cursing and gnashing of teeth, I rebooted, held down the shift key, and reloaded the noobs version of Raspian. The sound worked fine through numerous restarts, that is until I did the update again. Through the months I have tried every thing that I could think of to correct the problem, to no avail. Then I decided to try installing the latest version from the web. I loaded it onto a different micro sd card. Now the sound works just fine after updates. I was looking for the 64 bit beta version, but could not find it, so I loaded the 32 bit full version. All is well with the world once again.:cool:

Happy Trails,


Gold Member
Gold Supporter
I used this to setup mine no issues.

sudo apt install rpi-imager -if you want to by pass all the bs lol!
Last edited:
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online