Linux Mint 21.3 MATE desktop icon label wrapping

Stephen NP

New Member
Joined
Feb 10, 2024
Messages
18
Reaction score
3
Credits
133
Hello everyone. How to make these labels wrap as one line instead of being overlapped?
 

Attachments

  • 34534545.png
    34534545.png
    51.3 KB · Views: 57


I use Mate also (about 8 years). Not sure what you want can be done. I found something called the "mate-tweak" tool, but based on the screenshot I've seen of it, I don't see anything about what you're asking. You can install it anyway (it'll only use up about 1.2 MG) and poke around it, but it looks very basic. One way to "fix" it is by removing the spaces between the words but you might not like that idea (I wouldn't).
 
I saw one solution at the other distro forum when they edited some GTK2 file and rebooted. Like they edited some padding or spacing parameter. I'm not sure it works with Linux Mint MATE though.
 
Open your Menu > Appearance > Fonts > Desktop font > make smaller
 
I saw one solution at the other distro forum when they edited some GTK2 file and rebooted. Like they edited some padding or spacing parameter. I'm not sure it works with Linux Mint MATE though.
If the solution was specific for Mate, then it shouldn't matter what the OS is. Can you post a link to that solution?

One thing I do is shorten the text. For example, in your screenshot I see the Gimp app. I have that on my desktop also, and I shorten "GNU Image Manipulation..." to simply "Gimp."
 
Last edited:
Shortening a text is not a way out, either choosing the smaller font size. Here's what I've found recently: LINK.
 
Does that still have any effect ?

I am noting that the date goes back to 2011
 
On the desktop.
Yes, it's for XFCE, I didn't say it's for MATE, but this is the only referring piece of information I found.
 
Mate has very little documentation, and none of it is detailed (at least I can't find any). It also has no forum, like Xfce does. I searched your problem online a few times and found nothing to help. Two questions: 1) how important to you is fixing this issue? 2) how attached are you to Mate?
 
1) Quite important
2) I'd like to stick to MATE as I don't find Cinnamon stable and I'd like not to install XFCE as well
 
I've tried running Linux Mint MATE on a live USB and while it will split long lines... it does not split a single word, like your "bluetooth" example photo. Its default is very clean and readable, maybe depending on screen resolution.

When you first installed MATE, did it not display properly for you too? If it did display properly, what settings have you tinkered with? I tried changing display resolution and changed to 200% scaling, but neither cause the icon text to be cut off in the middle of a word. Fractional scaling is not available on MATE.

If it worked well when first installed, you may consider reinstalling to fix it. Then keep a good Timeshift backup in case it goes sideways again.

If you want the icon text to be on a single line (no exceptions), this thread may help. Changing the text-ellipsis-limit from 3 to 1 (3 line limit to 1 line limit) will show icon text that looks like "GNU Imag..." with the long multiple-lines truncated by the ellipsis. This below worked on the live USB with Mint MATE. If you then click on a truncated text, it will highlight and show you the full text. You have to logout and log back in (or reboot) to see the change.
Code:
gsettings set org.mate.caja.desktop text-ellipsis-limit 1

Further fiddling around, I was able to "break" the icon text (not sure how) to the point where it cut off in the middle of the word to do the line wrap. The settings that I was fiddling with are in the file manager, Caja. Open Caja, go to Edit, then Preferences, then the Views tab (opens first for me)... down at the bottom there are Defaults for Icon View with various % options. Try changing to see if you find one that works. It seems strange the the file manager settings has an effect on the desktop, but it does... see here and here for reference.

Other options to try are to install dconf-editor and/or mate-tweak tools. They may provide something that will help. You may need some combination of settings above to get what you want, or return to what you want.

With dconf-editor, this article (updated Oct 2022) says you can reset the MATE desktop back to it's original defaults with just a single terminal command. If it works, it may save you the trouble of a full reinstall, but the article does caution that you will wipe out any other customizations that you have done.
 
Last edited:
Further fiddling around, I was able to "break" the icon text (not sure how) to the point where it cut off in the middle of the word to do the line wrap. The settings that I was fiddling with are in the file manager, Caja. Open Caja, go to Edit, then Preferences, then the Views tab (opens first for me)... down at the bottom there are Defaults for Icon View with various % options. Try changing to see if you find one that works. It seems strange the the file manager settings has an effect on the desktop, but it does... see here and here for reference.
Removing a tick from "Use compact layout" option changed the situation to much better. And with 150% scaling letters are put right in lines, despite losing some shortcuts at the desktop. I've also tried to use dconf-editor to set custom scaling, but the settings there are the same as in Caja preferences. I'd like to set scaling like 110-120%, while Caja only has 100% and 150%. Mate-tweak didn't help me at all.
 
Last edited:
Sorry, there's an update of my trouble. After I removed the "Use compact layout" tick and reset X with Ctrl-Alt-Backspace (just to check if my changes are saved), letters are overlapped again. Then I again entered Caja and saw the tick activated again. Only after I removed the tick and put it back again letters became wrapped again. So the desktop doesn't save my changes after reboot.
Changing the same parameter from dconf-editor has the same result.
 
Last edited:
Well, that's a bummer. Caja should save your changes. I have not found any config files yet that may help. Keep searching for the right solution, or keep tinkering with the settings you know that have an effect... or reset/reinstall. I'm about out of ideas. Good luck!
 
Have you been changing such permissions? Still, if Caja needed root permission to save your changes... it should have prompted you for a password. The gsettings command did not need root, but needed logout/login to work.

Unless someone finds an easier answer, my guess is you will end up reinstalling. It is sometimes best to cut your losses (of time and effort) and just do it over. If you've done a lot of customization, it may take a good bit to put it all back together. But the best lesson to learn from this is to develop a good backup strategy so that you can recover from disasters like this quickly and easily.

Timeshift is one such tool to help with backup needs, and there are disk cloning tools that are also useful. This site has many threads already about these tools that can help you along. Make a good backup at each stage of customization... so that if you reach another disaster unexpectedly, you won't have to start from scratch again. Develop a schedule that works for you and make regular backups. :)
 
Have you been changing such permissions?
Never.
I didn't do much customization. I don't need to reinstall the system. I just need to make compact view available automatically after the system boot.
 


Top