KALI LINUX UPGRADE PROBLEM

aaryan

New Member
Credits
218
sudo apt full-upgrade -y
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
cpp-6 : Depends: libmpfr4 (>= 3.1.3) but 3.1.2-2 is installed
gcc-6 : Depends: libmpfr4 (>= 3.1.3) but 3.1.2-2 is installed
libasan3-arm64-cross : Depends: libc6-arm64-cross (>= 2.24) but it is not installed
Depends: libgcc1-arm64-cross (>= 1-3-cross.3)
Depends: libstdc++6-arm64-cross but it is not installed
libgcc-6-dev : Depends: libasan3 (>= 6.3.0-18+deb9u1) but it is not installable
Depends: libubsan0 (>= 6.3.0-18+deb9u1) but it is not installable
libqt5x11extras5-dev : Depends: libqt5x11extras5 (= 5.7.1~20161021-2) but it is not installed
libubsan0-arm64-cross : Depends: libc6-arm64-cross (>= 2.24) but it is not installed
Depends: libgcc1-arm64-cross (>= 1-3-cross.3)
Depends: libstdc++6-arm64-cross but it is not installed
linux-headers-4.9.0-14-amd64 : Depends: linux-headers-4.9.0-14-common (= 4.9.246-2) but it is not installable
Depends: linux-kbuild-4.9 (>= 4.9.246-2) but it is not installable
linux-headers-amd64 : Depends: linux-headers-4.19.0-13-amd64 but it is not installable
qtbase5-dev : Depends: libqt5concurrent5 (= 5.3.2+dfsg-4+deb8u4) but 5.11.1+dfsg-9 is installed
Depends: libqt5core5a (= 5.3.2+dfsg-4+deb8u4) but 5.11.1+dfsg-9 is installed
Depends: libqt5dbus5 (= 5.3.2+dfsg-4+deb8u4) but 5.11.1+dfsg-9 is installed
Depends: libqt5gui5 (= 5.3.2+dfsg-4+deb8u4) but 5.11.1+dfsg-9 is installed
Depends: libqt5network5 (= 5.3.2+dfsg-4+deb8u4) but 5.11.1+dfsg-9 is installed
Depends: libqt5printsupport5 (= 5.3.2+dfsg-4+deb8u4) but 5.11.1+dfsg-9 is installed
Depends: libqt5sql5 (= 5.3.2+dfsg-4+deb8u4) but 5.11.1+dfsg-9 is installed
Depends: libqt5test5 (= 5.3.2+dfsg-4+deb8u4) but 5.11.1+dfsg-9 is installed
Depends: libqt5widgets5 (= 5.3.2+dfsg-4+deb8u4) but 5.11.1+dfsg-9 is installed
Depends: libqt5xml5 (= 5.3.2+dfsg-4+deb8u4) but 5.11.1+dfsg-9 is installed
Depends: qtbase5-dev-tools (= 5.3.2+dfsg-4+deb8u4) but it is not installed
Recommends: libqt5opengl5-dev (= 5.3.2+dfsg-4+deb8u4) but it is not installed
virtualbox-6.1 : Depends: libc6 (>= 2.28) but 2.27-6 is installed
Depends: libqt5x11extras5 (>= 5.6.0) but it is not installed
Depends: libsdl1.2debian (>= 1.2.11) but it is not installed
Depends: libssl1.1 (>= 1.1.1) but 1.1.0l-1~deb9u2 is installed
Recommends: libsdl-ttf2.0-0 but it is not installed
Recommends: linux-image but it is not installable
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
 


wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
13,622
And have you?
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online

No members online now.

Top