New Member
Oct 7, 2022
Reaction score
Hello, all. I've already posted this on Red Hat's community forum but, so far, no one has been able to provide any assistance and I am on a time crunch to get the solution for work.
I'm hoping someone could help with the following articles: # If you can't access this, I have also attached it.

First, the following setting is made in our environment that was set by the Admin before me in /etc/sysconfig/irqbalance:


This is supposed to be set for CPUs 0-19. I'm actually having a difficult time understanding if that hex setting is correct for CPUs 0-19 per the Admin's intention. I could not find anywhere in the articles (and in my Google'ing) on how to tell if that setting is actually working as intended. One thing I have found on the systems that have that setting is if I run 'ps -aeF' I still see what looks to be irqs' on CPUs 0-19. Based on my understanding from the articles, I would have assumed I would NOT see any irq assigned to any of the CPUs 0-19.
The other thing I am trying to do and I'm a little confused on how to set is to add CPU 27 to that setting.
If anyone can assist, I would greatly appreciate it. This is for RHEL/CentOS 7.9.


  • RH-KB3152271.txt
    2.6 KB · Views: 63

So, after further research, I think I came to a solution. First of all, if my configurations are correct, my CPU27, in hex, should b 8000000. Also, I think I can see the results from irqbalance -d...I think. I'm still trying to grasp the output of that command.
I have never tried this but looking at one of the examples in the documentation link you shared I would think it would look something like this.
Because below that it says.
The above mask excludes CPUs 8 to 15 as well as CPU 33 from IRQ balancing.
By my calculations based on this formula from the KB:

$ echo "obase=16;ibase=2;00001000000011111111111111111111" | bc | tr '[:upper:]' '[:lower:]'

I think my setting is supposed to be this since I want to continue to ban 0-19 and add 27 to the setting (my systems have more than 32 CPUS):

IRQBALANCE_BANNED_CPUS=000fffff, 8000000

But, I could be wrong, because math.
Last edited:

Staff online