i'm having trouble with everything - please help

Birk

New Member
hello, i'm very new to all of this.

I wanted to install linux on my computer so I followed a tutorial and did the following.
i have downloaded iso file. (i have tried deepin, ubuntu and kde neon)
i have used rufus 3.3 to make bootable usb drive
i have booted from drive but when i try to install i get following errors.
IMG_20181130_193250857.jpg

i don't know what this means ): i get the same error on all systems i tried

if i try to run without installing i get blank screen on ubuntu and nice night sky image on deepin :)
i didn't take a picture of that but it wasnt very interesting.

i havnt messed around alot in bios thingy, I have only changed boot order and disabled fast boot and set safe boot to other os.

I would apreciate some help with this.
 


arochester

Moderator
Staff member
Gold Supporter
What is the MAKE and MODEL of your computer?

If it is a generic computer can you give some general specs, please?
 

Birk

New Member
What is the MAKE and MODEL of your computer?

If it is a generic computer can you give some general specs, please?
i'm not sure what MAKE and MODEL is but these are the specs i have noted.

CPU: Intel Core i7-4790
GPU: nvidia gtx 970 (if i remember correctly)
Memory: 12288 mb (DDR3)
i know it's asus motherboard but i don't know the model

i found this as well, not sure if it's useful
BIOS Version - 0703x64
ME Version - 9.1.1.1000
PCH Stepping - 00/AO

this was a prebuilt asus computer and i don't think they sell this model anymore. i can't find it on the store where i bought it anyway.
I can probably find more info if i boot windows. just let me know

EDIT: found some more stuff.

System Manufacturer: ASUSTeK COMPUTER INK.
System Model: G20AJ
BIOS: 0703
 
Last edited:

arochester

Moderator
Staff member
Gold Supporter
Has your computer not got a label on it telling you the model?

Not really my area because I tend to compute on a pile of old junk. I think you need to get into the BIOS to look at areas like Fast Boot, Secure Boot and Legacy Options.

Your next problem will be the Nvidia GPU. Try something like Linux Mint. Like Ubuntu but with the restricted drivers pre-installed.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
G'day all - an equally viable solution is that the stick is old and worn or has not been formatted properly by Rufus.

With Rufus did you choose quick format? If so, uncheck that and try to get a full format.

As an alternative you could try Etcher, who have a new owner, Balena, they are at https://www.balena.io/etcher/

... and try burning with that. If it fails, try with another stick.

Another alternative given you are using Windows is to download GParted, which is cross-platform

https://gparted.org/ - read the front page then click Download near top.

If you use GParted, you will insert the stick, start GParted, unmount the stick if it tells you to, then Delete the contents, create a New Partition Table (ms-dos), and create a new Partition (FAT32). Then burn the .iso again.

Cheers

Chris Turner
wizardfromoz
 

Birk

New Member
Thanks all for posting and helping me out :)
I should probably mention that I fixed it. Yay. I really wish I was paying more attention as to what caused it. I was actually about to give up and boot windows but when I realised my windows install was broken beyond repair I decided to try one last time. Then it just worked, idk.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter

Birk

New Member
That's GREAT news, Birk, I was forgetting my manners before, so welcome to linux.org :)

You may be ready to hit the sack, but next time you are online, let us know which Distro you opted for, down to the version and desktop, if you can.

Also start reading my Tute on Timeshift, as it can be applied to nearly any Distro.

https://www.linux.org/threads/timeshift-similar-solutions-safeguard-recover-your-linux.15241/

View attachment 3539

Cheers

Chris Turner
wizardfromoz
Haha thanks, I'll have to read that.
I ended up with deepin, the latest version. I just thought it looked cool :D
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
I have Deepin (I run about 80 Linux over 2 systems), there is also a Manjaro Community Edition which has the Deepin DE, I have that, too.

If you have any questions on Timeshift, just hook over to the Tute and ask there.

Enjoy your Linux

Wizard
 

Members online


Latest posts

Top