[I'll Try To Fix Wine Later, Thanks For The Help] Error When Trying To Install WIne

NePoran

Member
Credits
266
Should I try to reinstall libc:i386?

user: sudo apt install --install-recommends winehq-stable
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
winehq-stable : Depends: wine-stable (= 6.0.0~groovy-1)
E: Unable to correct problems, you have held broken packages.
user:~$ sudo apt install wine-stable
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
wine-stable : Depends: wine-stable-i386 (= 6.0.0~groovy-1)
Depends: wine-stable-amd64 (= 6.0.0~groovy-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
user:~$ sudo apt install wine-stable-i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
wine-stable-i386:i386 : Depends: libc6:i386 (>= 2.32) but 2.31-0ubuntu9.2 is to be installed
E: Unable to correct problems, you have held broken packages.
user:~$ sudo apt install libc6:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
libc6:i386 is already the newest version (2.31-0ubuntu9.2).
0 upgraded, 0 newly installed, 0 to remove and 34 not upgraded.
 


Lord Boltar

Active Member
Credits
2,434
what version of Ubuntu are you running? it says
winehq-stable : Depends: wine-stable (= 6.0.0~groovy-1)
wine-stable-i386:i386 : Depends: libc6:i386 (>= 2.32) but 2.31-0ubuntu9.2 is to be installed
2.32 is for groovy (20.10) 2.31 is for focal (20.04)
Looks like you may be installing for wrong version of WINE what repository did you use?
for 20.04 Focal it is
Code:
sudo add-apt-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ focal main'
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online

No members online now.

Latest posts

Top