How to Detect USB External Modem

Vicktoria

Active Member
Credits
889
I'm Back...I guess I hardly left. I am installing another Mint version 19.3 Cinnamon. All was flowing nicely till I came home and attempted to connect to dialup. I installed wvdial and I believe it is properly configured. GNOME PPP is installed and I configured that, but it cannot detect the modem. I get info of a usr/share/alsa/pcm/modem.conf being talked about, but putting that in responds with no such file or directory. I've been reading man & help and can't figure out a direction. This is my last chore currently before I learn how to back things up. The usb external modem is a Zoom brand 56K coaxtent and the driver has been installed. I tried entering /ttyACMO in the location window of GNOME PPP as well as trying all the offered locations from the dropdown list. Message is 'no modem detected on system. I'm using the modem on the Windows machine now.
As always my thanks for an assist.
 


Vicktoria

Active Member
Credits
889
Tolkem, thanks for direction. I read the site...no info on detection. I have the drivers installed. The message is 'All dependencies satisfied', and when I try to install another driver the message is 'You already have the latest driver installed'. Yet the modem cannot be detected and I am using it now on the Windows machine, so it works. When I look for 'info modem' I get 'no menu item modem'. When I run detect in GNOMEPPP I get 'No modem on the machine'. I am a noobe and pretty much illiterate with software and finding things. Tried all the terminal commands I've learned so far...locate, find etc. The only entry is in usr/bin/wvdial and the config file in /etc. All other responses to modem queries says 'no such file or directory'. I've read all man pgs and help files I can find. I'm lost :(
 

Condobloke

Well-Known Member
Credits
2,464
  • Install gnome-ppp from Ubuntu Software Center.
  • Connect USB Modem.
  • Open the terminal and type: sudo gnome-ppp.
  • Open Setup and select Detect button (try it 5-6 times if it cannot detect your modem, if still it can't detect then reconnect your modem or restart OS)

If you have no joy there, .....
Be aware this is a fairly involved page......but the person there (gene) had success.
Just how his setup compares to yours, I have no idea.
Worth a look.
 

Tolkem

Well-Known Member
Credits
1,276
Yet the modem cannot be detected and I am using it now on the Windows machine, so it works
You're welcome! Too bad you haven't being able to solve your issue. I've only used a ppp device once and luckily for me it worked OOTB, so my experience in such procedures is none, all I can offer is paste some links I may find to articles hoping they can help you, like this one http://manpages.ubuntu.com/manpages/bionic/man8/pppconfig.8.html and this one, though with more focus on Arch, the basic principles apply across different distros https://wiki.archlinux.org/index.php/Ppp
 

Vicktoria

Active Member
Credits
889
Hallelujah, I can post today! Could not get on yesterday. I think I'm on the trail of an answer but I need some expertise as this is over my head. I've been researching as I've been trying to have my modem detected by the dial-up software, as well as back up the system using clonezilla, yet neither of these attempts have been successful, and both seem to be connected to recognition of the usb device. The Linux machine is:
Fujitsu AH532 with 8GB RAM and 500GB HD, Intel Core i360060 [email protected] 2GHz x 2, Intel Skylake GT2 graphics card
I've got Cinnamon 19.3 Tricia on it.
The Modem is a Zoom USB External Conexent DGC with driver installed and recognized by system version 1.06-k2.6.20-16-lowlatency-1.ubuntu
GNOME PPP gives the message 'No modem on the system' when I press the 'Detect' button, yet when I query system with lsusb it shows: BUS 003 Device 006: ID 0803:3095 Zoom Telephonics, Inc. v.92 56K mini external Modem Model 3095.

This sounds to me like it is a communications issue between the serial port and the program. Especially since Clonezilla won't recognize wither my usb external hard drive or a usb jump drive. I will continue to research, yet I am not versed in computer technology and am at a loss.
The info on the external hard drive and the usb can be read and accessed through file manager. HELP Please.
 

Vrai

Well-Known Member
Credits
1,533
@Vicktoria
Have you tried plugging the modem into the computer and turning on or powering up the modem before turning on and booting the computer?
 

Vicktoria

Active Member
Credits
889
Hiya Vrai, yes I have to have the modem plugged in before booting up machine for it to work. Don't you think there is a connection between the modem recognition and the clonezilla lack of recognition of both usb external and usb jump? I feel there is some setting or utility that needs installed or whatever the proper term is...perhaps a configuration setting. I'm just too illiterate in how a computer works to figure it out. Thanks so very much fr your consideration. I appreciate other brains out there trying to figure this out.
 

Tolkem

Well-Known Member
Credits
1,276
Open a terminal and type these commands:
Code:
whereis ppp
You should get something like
Code:
ppp: /etc/ppp /usr/share/ppp
If that is correct, next type
Code:
egrep -v '#|^ *$' /etc/ppp/options   >> change the location if diffrent, i.e not in /etc but somwhere else
To see what options are active and paste the contents here, they should look similar to this:
Code:
asyncmap 0
auth
crtscts
lock
hide-password
modem
lcp-echo-interval 30
lcp-echo-failure 4
noipx
 

Vicktoria

Active Member
Credits
889
Thank you Thank you Tolkem. I just booted the machine to try your instructions and it came up with the linux background, which I had changed. I've been getting a 'real time error' and have tried to get into BIOS to look at things yet only get a screen with a list of Ubuntu at first position, then cd/dvd and network. Trying to enter any of them does nothing. Can't get into bios to set boot order or anything, so that is an issue as well, although the time is correct today. I wonder if i should try to update BIOS, and if so where/How would i do that. I read that caused issues sometimes, yet something isn't right there.

I read the info from the links you suggested before. Sounds to me like the software [especially those dealing with the serial ports] isn't communicating through the kernel with the software. I'll try inputting your instructions. I entered whereis and it was where it was suppose to be /etc/ppp /user/share/ppp. But when I entered '# | ^ *$' /etc/ppp/options, the response was '# | ^ *$' 'command not found'. I tried it with no spaces and got same response. Does that give us a clue?

Thanks for the assistance. I'll continue to study the material you linked, I'm almost through it all.

Condobloke, sorry I don't see a response to your guidance about gnomeppp. I installed that first thing. That's the one that tells me There is no modem on the machine.
 

Condobloke

Well-Known Member
Credits
2,464
^^.....what Vrai said above....leave updating BIOS alone
 

Vicktoria

Active Member
Credits
889
Vrai, Condobloke, thanks for BIOS info...I thought I read that. Yet in reading the Linux Kernel Series, which is Great, I see the BIOS is the 'conductor' for many commands. When I had windows on the Fujitsu, I could access the BIOS and change time, passwords, boot order etc. Since the Ubuntu Crash, when I couldn't even get the machine to boot, all I get when I try to get into BIOS is a page showing 1. ubuntu, 2.Drive 0 HDD, 3. CD/DVD drive, & 4. Network: Realtek PXE B02 D00. Trying to enter any of these gives no response and the other tab is Application menu which is the same as on Windows with Diagnostic screen giving Phoenix SecureCore Tiano, and Diagnostic program which shows no response after running the program.

I mention this concern with the BIOS not working properly, as it seems the kernel uses the BIOS to control hardware sometimes, and it seems there is some issue between the software detecting the usb ports. Both gnomeppp and clonezilla are not recognizing the usb modem or the usb external hard drive. Since the software uses the kernel to communicate with the hardware, and since the kernel uses the BIOS to control the hardware at least sometimes, it sounded like it was a kernel communication issue or a BIOS communication issue perhaps. Since I know the BIOS isn't working correctly, I thought maybe this might help the problem. I'm just trying to solve this puzzle...may be a case of a little knowledge being dangerous. As always I appreciate all input. Thanks
 

Tolkem

Well-Known Member
Credits
1,276
But when I entered '# | ^ *$' /etc/ppp/options, the response was '# | ^ *$' 'command not found'.
You made a typo, the actual command is
Code:
egrep -v '#|^ *$' /etc/ppp/options
you missed the egrep -v part. Try again using that, copy/paste if you need to.
 

Vicktoria

Active Member
Credits
889
Thanks Tolkem, sorry for mistake. Can't do copy/paste on dialup as Linux Fujitsu machine can't get on line, using Windows machine. So it worked here is screenshot.. Dang, can't upload screenshot...maybe too slow on dial-up most annoying! Well maybe it worked this time, still getting error message. So does this tell you anything useful? I hope it is visible. I continue to read and it looks like there are many potential scripts that could be involved. I still wonder about the BIOS. The 'real time error' message blipped by on boot today and the clock is incorrect. Yet i can't get into the BIOS to change it. I can change it from the gui in Linux. Thanks for yourn efforts.
 

Attachments

Vrai

Well-Known Member
Credits
1,533
Thanks Tolkem, sorry for mistake. Can't do copy/paste on dialup as Linux Fujitsu machine can't get on line, using Windows machine. So it worked here is screenshot.. Dang, can't upload screenshot...maybe too slow on dial-up most annoying! Well maybe it worked this time, still getting error message. So does this tell you anything useful? I hope it is visible. I continue to read and it looks like there are many potential scripts that could be involved. I still wonder about the BIOS. The 'real time error' message blipped by on boot today and the clock is incorrect. Yet i can't get into the BIOS to change it. I can change it from the gui in Linux. Thanks for yourn efforts.
Maybe uncomment "#persist"?
 

Tolkem

Well-Known Member
Credits
1,276
So does this tell you anything useful?
modem option should be active, yet I didn't see it in that screenshot. Open a terminal and type
Code:
sudo nano /etc/ppp/options
type your password when asked and in that file locate the line where the modem option is, if it's commented - has the "#" symbol in front of it - delete/comment it out, hit Ctrl + o and Enter to save your changes, next hit Ctrl + x to close nano. You might have to reboot for it to take effect, not sure about this though so try and if it doesn't work reboot and try again.

 
Last edited:

Vrai

Well-Known Member
Credits
1,533
locate the line where the modem option is, if it's commented - has the "#" symbol in front of it -delete/comment it out
@Vicktoria - to clarify, just delete the "#" (hash).
Wouldn't want you to delete the whole line by mistake.

Any line with the "#" in front of it will be ignored by the script or tool.
For the line or item to be read and recognized 'uncomment' or delete the hash "#".
 

Tolkem

Well-Known Member
Credits
1,276
@Vicktoria - to clarify, just delete the "#" (hash).
Wouldn't want you to delete the whole line by mistake.

Any line with the "#" in front of it will be ignored by the script or tool.
For the line or item to be read and recognized 'uncomment' or delete the hash "#".
Yes, thanks @Vrai for pointing that out. Sometimes I forget some people may not be familiar with some Linux related terms such as "comment/uncomment" some text in a file, usually this means removing/deleting the # symbol at the beginning of a line. In your case @Vicktoria it means removing/deleting it from the beginning of the line where modem option is in the the file /etc/ppp/options By the way, once the file's open in nano, hit Ctrl + w which will bring a search box up, type modem and hit enter, to cycle through all the lines containing the word "modem" hit Ctrl + w till you find the one that needs to be uncommented. Should be something like:
Code:
# Use the modem control lines.  On Ultrix, this option implies hardware
# flow control, as for the crtscts option.  (This option is not fully
# implemented.)
modem >> this is the one you're looking for!

# Set the MRU [Maximum Receive Unit] value to <n> for negotiation. pppd
# will ask the peer to send packets of no more than <n> bytes. The
# minimum MRU value is 128. The default MRU value is 1500. A value of
 

Vicktoria

Active Member
Credits
889
Tolkem, Thanks very much for your efforts. And Vrai you saved me again. I absolutely was going to delete the whole line. Tolkem, I really am uneducated in computers. Big learning curve here. So I will try this and report back, hopefully from the Fujitsu Linux machine on dieal-up. Thank you both for the rescue.
 


Members online


Latest posts

Top