G-Sync not saved in X Configuration File

R/\ZV/\N

New Member
Joined
Oct 14, 2023
Messages
3
Reaction score
0
Credits
29
Hi,


I'm new on this forum and I'm also new on Linux world. Couple of day ago I decided to give Linux a try because of the level of bloatware from Windows 10 Pro I also have in my dual boot PC (and I hope the future be more Linux friendly).
I've installed Mint Cinnamon Victoria because I like to play games sometime. And my problem (till now) is 'Unable to open X config file '/etc/X11/xorg.conf' for writing when I try to save G-Sync option in nvidia Settings / Control Center, meaning each time I'll boot into Mint I must put that tick for G-Sync. My level of skill in/with Linux is a bit above zero, so I'm going to ask you nicely to help me solve this problem.

Screenshot from 2023-10-13 20-51-16.png


and...

Screenshot from 2023-10-13 20-51-34.png
 


Just use "sudo" to edit that file, open a terminal and run the following.
Code:
 sudo nvidia-xconfig
Then you can edit and save the Nvidia Xorg configuration, the other option is to just open the display settings but there you don't have access to the Nvidia specific settings.
 
Just use "sudo" to edit that file, open a terminal and run the following.
Code:
 sudo nvidia-xconfig
Then you can edit and save the Nvidia Xorg configuration, the other option is to just open the display settings but there you don't have access to the Nvidia specific settings.
WARNING: Unable to locate/open X configuration file.

Package xorg-server was not found in the pkg-config search path.
Perhaps you should add the directory containing `xorg-server.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xorg-server' found
New X configuration file written to '/etc/X11/xorg.conf'
 

Attachments

  • Screenshot from 2023-10-17 21-04-57.png
    Screenshot from 2023-10-17 21-04-57.png
    760.9 KB · Views: 80
From someone from Mint forum...

sudo chmod +x /usr/share/screen-resolution-extra/nvidia-polkit

It worked. And thanks for your support too.
 
I made a typo in my reply, it should have been.
Code:
sudo nvidia-settings
 


Top