Failed to start Raise network interfaces

Sergio Rodriguez

New Member
Mar 9, 2019
Reaction score
I recently installed Debian and I'm getting the following message at startup:

[FAILED] Failed to start Raise network interfaces.
See 'systemctl status networking.service' for details.

I run that command and I got the following message:

● networking.service - Raise network interfaces
   Loaded: loaded (/lib/systemd/system/networking.service; enabled; vendor pres$
   Active: failed (Result: exit-code) since Wed 2019-03-13 21:13:05 -05; 10min $
     Docs: man:interfaces(5)
  Process: 386 ExecStart=/sbin/ifup -a --read-environment (code=exited, status=1/FAILURE)
  Process: 379 ExecStartPre=/bin/sh -c [ "$CONFIGURE_INTERFACES" != "no" ] && [ -n "$(ifquery --read-environment --list --exclude=lo)" ] && udevadm $evadm se
 Main PID: 386 (code=exited, status=1/FAILURE)

My Wi-Fi connection is working, but I want to understand this error and how to fix it

I have some input for this Thread

(Wizard appears in a puff of smoke)

... but I want to run a couple of experiments first, and then put together some information that is cohesive and factual. Might take me a couple of days.

Can I ask of both of you whether your wifi is actually working (ie the error is non-fatal) or not, on your Debians?


Chris Turner
wifi works....happy for you Peer.
Why does it work now ?
(or did I misunderstand ??) o_O
obviously I misunderstood !!....ignore my previous post
No, Brian - that's OK and understandable ... Peer is likely running with "noquiet nosplash" in his /etc/default/grub (as I do) or else, Debian is displaying some of its startup output as it heads to login screen.

The warning he is receiving is likely the same as one I was receiving on my old Toshiba Satellite, it was non-fatal and wifi still works on it. I will explain more when I have put it together.


Ta (pronounced "tar", Aussie and English for thanks), Sergio :)

I'll try to make some time this weekend to look into this further, I am interested, myself.


I found a solution here, @wizardfromoz and @Peer

I don't understand the logical of it but worked.

Now, the result of "systemctl status networking.service" is this:

● networking.service - Raise network interfaces
   Loaded: loaded (/lib/systemd/system/networking.service; enabled; vendor prese
   Active: active (exited) since Sat 2019-04-06 21:35:18 -05; 17min ago
     Docs: man:interfaces(5)
  Process: 419 ExecStart=/sbin/ifup -a --read-environment (code=exited, status=0
  Process: 415 ExecStartPre=/bin/sh -c [ "$CONFIGURE_INTERFACES" != "no" ] && [
 Main PID: 419 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
   CGroup: /system.slice/networking.service
Last edited:
Hey, that's great, Sergio, well done and "Ta" for sharing :)

I have bookmarked that reference and will take a closer look at it. It may also help me with some problems I have with Debian.

Enjoy your Linux