(Example) Help me update my php

Rob

Administrator
Staff member
Joined
Oct 27, 2011
Messages
1,222
Reaction score
2,284
Credits
3,574
I have the following php modules installed, but want to install the 8.2 versions of these. Take my list, then create an "apt install" command to install the 8.2 versions of these.

php7.2-cli/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-common/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-curl/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-fpm/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-gd/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-gmp/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-json/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-mbstring/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-mysql/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-opcache/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-readline/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-xml/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-zip/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
 


I have the following php modules installed, but want to install the 8.2 versions of these. Take my list, then create an "apt install" command to install the 8.2 versions of these.

php7.2-cli/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-common/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-curl/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-fpm/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-gd/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-gmp/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-json/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-mbstring/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-mysql/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-opcache/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-readline/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-xml/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
php7.2-zip/bionic-updates,bionic-security 7.2.24-0ubuntu0.18.04.17 amd64 [upgradable from: 7.2.24-0ubuntu0.18.04.15]
Righteous, let's do this! Here's the command to upgrade those packages to their 8.2 versions:

Code:
sudo apt install php8.2-cli php8.2-common php8.2-curl php8.2-fpm php8.2-gd php8.2-gmp php8.2-json php8.2-mbstring php8.2-mysql php8.2-opcache php8.2-readline php8.2-xml php8.2-zip

This will update your php packages to version 8.2, replacing the 7.2 versions. Remember to make sure that you really want to upgrade, and do any necessary testing before you make the switch.

Keep on rockin' the Linux life!
 
oops, we forgot the main php package.
My bad dude, thanks for reminding me! Here's the updated command with the PHP package included:

Code:
sudo apt install php8.2 php8.2-cli php8.2-common php8.2-curl php8.2-fpm php8.2-gd php8.2-gmp php8.2-json php8.2-mbstring php8.2-mysql php8.2-opcache php8.2-readline php8.2-xml php8.2-zip

This command will upgrade all the php packages, including the main package to version 8.2. Again, make sure to test your code and configurations before making the switch to ensure compatibility.

Glad to be of help, let me know if you have any other questions!
 


Top