Dual monitor setup - refresh rate issue


New Member
Hello. I have two monitors: one with the refresh rate of 144hz and one with 60hz. Everything mostly works fine with one exception. Moving and resizing windows is noticeably less smooth compared to when I use only one 144hz monitor. I'm assuming dragging windows happens with the lower refresh rate


Well-Known Member
Welcome to the Linux Org forums

We are an un-associated, Independent advice a site for those in need of help with installation problems, those wanting a deeper understanding of Linux and Tech's needing more advanced advice,
We are a voluntary organisation our members are scattered across the four corners of the world and every time zone, so please accept that you may not get a quick answer.

Just a few things to remember
We are an international board so we ask that all post be in English [if you think your English is not very good , fine give it a try or use one of the translator programs [ DeepL Translate: The world's most accurate translator is recommended]
When asking for help
Please state the make and model number of your machine or its specification [some problems may be equipment specific]
Please tell us which distribution and build number you are having problems with [example Ubuntu 18.1]
Explain what your problem is and what [if anything] you have tried to remedy it yourself

Finally Linux is not Windows, It will require the newcomer to invest a little time and effort going through a learning curve so please don’t give up, kick off your shoes, grab a drink and enjoy the ride.


Like everything in life a matched pair will perform together better than a miss match, You have one monitor with twice the refresh rate of the other , so I am not surprised you notice a difference.


New Member
Sorry. I use Manjaro Linux with KDE Plasma version 5.21.5, kernel 5.10.42-1-MANJARO
My GPU is GTX 750 Ti, CPU is AMD Ryzen 3 1200, 24GB of RAM. I use X11
This issue was present on every distribution I've tried as well.
I tried changing the resolution and refresh rate using xrandr commands, it made no difference. I wanted to try using Wayland but it crashes right as it starts
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online