• We had to restore from a backup today after a failed software update. Backup was from 0000 EDT and restored it at 0800 EDT so we lost about 8hrs. Today is 07/20/2024. More info here.

Dual boot does not function properly, only after hitting F12 function key.

peter885

New Member
Joined
Oct 26, 2020
Messages
7
Reaction score
2
Credits
57
I succesfully have installed Ubuntu 20.04 alongside Windows 10 dual boot.
However, when I start up my desktop Windows10 shows up.
But, when I during startup hit the F12 function key, I get the option of choosing Windows boot manager (first on top) or Ubuntu (second).
When I choose Ubuntu, the Grub screen appears. Ubuntu is on top followed by Windows10.
After a short time out Ubuntu starts up automatically(because it is on top). Ubuntu is my favourite.
How can I manage to get Ubuntu on top after hitting F12? When Ubuntu is on top,
my computer will then start up directly in the grub menu.
 


You can configure Grub to load a different default entry. Why do you need to press F12 before you can choose which Grub entry you want to boot?
 
The first thing I see after booting my desktop is login screen Windows10. When I hit F12 I can choose between Windows or Ubuntu. When I choose Ubuntu the grub menu comes up. So I have to configure grub while there is a grubmenu. Ill try.
 
It sounds like maybe you have two hard drives.
You installed Windows on one and Linux on the other?

If this is the case, usually you can select a "Boot Order" in the BIOS/UEFI.

Just put Ubuntu before Windows and save the setting.
 
I have installed Linux on extern ssd Samsung EVO drive with USB connection.Have done this before (Windows 8.1 and Ubuntu 18.04 dual boot). Cant see Ubuntu in Bios, only Windows boot manager.
But I will check it again. I have checked 4 options: windows boot manager, removable drive, cdrom, lan.Only Windows Boot Manager works.
 
Last edited:
Some BIOS/UEFI's let you manually add a boot option.
 
Acer Aspire does not. I tried the program efibootmgr. Its not very diffcult to make changes. The problem is that after saving the changes, during reboot these changes get lost.
 
bcdedit /set "{bootmgr}" path "\EFI\systemd\systemd-boot.efi"
is another possible solution I found. But it needs more knowledge before executing this kind of changes.
 
I have SOLVED my problem.​
efibootmgr -v <enter> shows the boot options (F12)​
efibootmgr -o <enter> means make changes​
Output before changing:​
user@user:~$ efibootmgr <enter>​
BootCurrent:0000​
Timeout: 1 seconds​
BootOrder: 0000,0002​
Boot0000* Windows Boot Manager
Boot0002* ubuntu
Then:​
sudo efibootmgr -o 0002 <enter>
Bootorder 0002 en bootcurrent 0002​
System now starts up with grubmenu with Ubuntu​
on top. Followed by Windows10.​
Now I am satisfied.​


 

Members online


Top