(do not consider because duplicate) rtc_cmos: no alarms.

nutr

New Member
Credits
59
Hi,

I'm using debian 10 with tablet based on intel atom z3735f. The linux kernel 5.8.0-rc1 shows the following log:
[ 3.520169] rtc_cmos 00:00: registered as rtc0
[ 3.520209] rtc_cmos 00:00: setting system clock to 2020-06-16T07:00:22 UTC (1592290822)
[ 3.520217] rtc_cmos 00:00: GPIO lookup for consumer wp
[ 3.520220] rtc_cmos 00:00: using ACPI for GPIO lookup
[ 3.520232] rtc_cmos 00:00: using lookup tables for GPIO lookup
[ 3.520235] rtc_cmos 00:00: No GPIO consumer wp found
[ 3.520294] rtc_cmos 00:00: no alarms, y3k, 242 bytes nvram

and hence there is no wakealarm file
ll /sys/class/rtc/rtc0/
total 0
-r--r--r-- 1 root root 4096 Jun 16 13:29 date
-r--r--r-- 1 root root 4096 Jun 16 13:29 dev
lrwxrwxrwx 1 root root 0 Jun 16 13:29 device -> ../../../00:00
-r--r--r-- 1 root root 4096 Jun 16 13:29 hctosys
-rw-r--r-- 1 root root 4096 Jun 16 13:29 max_user_freq
-r--r--r-- 1 root root 4096 Jun 16 13:29 name
drwxr-xr-x 2 root root 0 Jun 16 13:29 power
-r--r--r-- 1 root root 4096 Jun 16 13:29 since_epoch
lrwxrwxrwx 1 root root 0 Jun 16 13:29 subsystem -> ../../../../../class/rtc
-r--r--r-- 1 root root 4096 Jun 16 13:29 time
-rw-r--r-- 1 root root 4096 Jun 16 13:29 uevent

also rtcwake does not work
rtcwake -m no -s 60
rtcwake: set rtc wake alarm failed: Invalid argument



I extracted DSDT.dsl

---------DSDT.dsl--------
Device (RTC)
{
Name (_HID, EisaId ("PNP0B00") /* AT Real-Time Clock */) // _HID: Hardware ID
Name (_CRS, ResourceTemplate () // _CRS: Current Resource Settings
{
IO (Decode16,
0x0070, // Range Minimum
0x0070, // Range Maximum
0x01, // Alignment
0x08, // Length
)
})
}

Device (HPET)
{
Name (_HID, EisaId ("PNP0103") /* HPET System Timer */) // _HID: Hardware ID
Name (_UID, Zero) // _UID: Unique ID
Method (_STA, 0, NotSerialized) // _STA: Status
{
Return (0x0F)
}

Method (_CRS, 0, Serialized) // _CRS: Current Resource Settings
{
Name (RBUF, ResourceTemplate ()
{
Memory32Fixed (ReadWrite,
0xFED00000, // Address Base
0x00000400, // Address Length
)
Interrupt (ResourceConsumer, Level, ActiveHigh, Exclusive, ,, )
{
0x00000008,
}
})
Return (RBUF) /* \_SB_.HPET._CRS.RBUF */
}
---------DSDT.dsl--------

It seems there is no interrupt for RTC, but there is for HPET.

[ 0.010578] ACPI: HPET 0x000000003CCF0000 000038 (v01 INSYDE INSYDE 00000003 ACPI 00040000)
[ 0.018763] x86/hpet: Will disable the HPET for this platform because it's not reliable
[ 0.018895] ACPI: HPET id: 0x8086a201 base: 0xfed00000


From internet I can see log line of type:
rtc0: alarms up to one month, y3k, 114 bytes nvram, hpet irqs


I need RTC alarm to wake up tablet from hibernation, how can I enable rtc_cmos alarms?

Thanks
 
Last edited:


Members online


Top