display manger

Leonardo_B

Active Member
Joined
Apr 15, 2020
Messages
239
Reaction score
103
Credits
1,830
I was useing i3 wm only on my system. I went to shutdown and restart and had lightdm display manger crash on me on start up . Couldnt get to any thing so i decided to do a fresh install of i3 fedora and install sway on top of it. But i wanta make sure that my system doesnt crash again cause of lightdm . What should i run that supports wayland. seem everything is working in sway but Kaffeine
 


f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,819
Reaction score
3,461
Credits
35,108
Not everything has full Wayland support yet but you can install Xwayland for backwards compatibility, on Fedora that is the following package.
Code:
xorg-x11-server-Xwayland.x86_64 : Xwayland
Also Sway doesn't support some display managers, the easier way to start Sway is by using ~/.xinitrc and ~/.bashrc or ~./bash_profile.
 
Last edited:
OP
L

Leonardo_B

Active Member
Joined
Apr 15, 2020
Messages
239
Reaction score
103
Credits
1,830
Not everything has full Wayland support yet but you can install Xwayland for backwards compatibility, on Fedora that is the following package.
Code:
xorg-x11-server-Xwayland.x86_64 : Xwayland
Also Sway doesn't support some display managers, the easier way to start Sway is by using ~/.xinitrc and ~/.bashrc or ~./bash_profile.
xwayland auto installed in fedora 34, i going to try useing what u sayed about /.xinitrc and ~/.bashrc or ~./bash_profile.
 
OP
L

Leonardo_B

Active Member
Joined
Apr 15, 2020
Messages
239
Reaction score
103
Credits
1,830
from my understanding if im correct
systemctl disable displaymanagername.service

sudo dnf install xorg-x11-xinit


then make .xinitrc file in /home directory
then add this line exec sway-session

then add this to your .bashrc
if [ -z "${DISPLAY}" ] && [ "${XDG_VTNR}" -eq 1 ]; then
exec startx
fi
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,819
Reaction score
3,461
Credits
35,108
Yes that is correct that you should disable your displaymanagert first, this should be enough to add to your ~/.bashrc or ~/.bashrc
Code:
if [ -z $DISPLAY ] && [ "$(tty)" = "/dev/tty1" ]; then
  exec sway
fi
When booting your system it should then automatically start in tty1.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Staff online


Top