Debian | Brightness control keys don't work


New Member
Oct 30, 2023
Reaction score
Okay, so this is a very common problem for laptop users as I can see from the amount of results in google related to this topic. Still, none of them helped me, so I decided to create this thread personally. My apologies to everyone who's already tired of the brightness problem.

I remember having the exact issue after installing Debian for the first time; that time I managed to resolve it by setting GRUB_CMDLINE_LINUX_DEFAULT to "quite acpi_backlight=vendor acpi_osi=linux". Today I decided to upgrade my system to Debian 12.2, which also caused moving on Linux Kernel v6.1... and the brightness keys stopped working again. I tried various combinations of acpi_backlight, acpi_osi and pcie_asmp, but nothing worked for me.
Some things I noticed about this situation:
  • In most cases, the brightness is set to 0 when booting the system
  • It still can be controlled in power management settings (which is already not bad, but I still want keys control back)
  • Using "...acpi_backlight=native" sets the brightness to 100
  • Using "...acpi_osi=" breaks the system, booting stops on several ACPI errors ("Could not resolve symbol [\...], AE_NOT_FOUND") so I have to fix it via recovery mode
  • Pressing Fn+F2/Fn+F3 (brightness control keys) causes some errors appear in dmesg:
[ 1901.625799] atkbd serio0: Unknown key pressed (translated set 2, code 0xab on isa0060/serio0).
[ 1901.625813] atkbd serio0: Use 'setkeycodes e02b <keycode>' to make it known.
[ 1901.634442] atkbd serio0: Unknown key released (translated set 2, code 0xab on isa0060/serio0).
[ 1901.634455] atkbd serio0: Use 'setkeycodes e02b <keycode>' to make it known.
[ 1902.006356] atkbd serio0: Unknown key pressed (translated set 2, code 0xab on isa0060/serio0).
[ 1902.006369] atkbd serio0: Use 'setkeycodes e02b <keycode>' to make it known.
[ 1902.014584] atkbd serio0: Unknown key released (translated set 2, code 0xab on isa0060/serio0).
[ 1902.014598] atkbd serio0: Use 'setkeycodes e02b <keycode>' to make it known.
- xev doesn't register these keyboard shortcuts. Almost all the other Fn+F* (except for F12, which is designed to turn on/off airplane mode) work fine.

I saw several similar threads where people were asked to send their pc specs, so here is my inxi -Fxxxza output. I hope it will be useful.

  Kernel: 6.1.0-13-amd64 arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1.0-13-amd64
    root=UUID=178c339e-1ed3-4a4b-986b-a23bfe616a78 ro quiet pcie_asmp=force
    acpi_backlight=vendor acpi_osi=Linux
  Desktop: KDE Plasma v: 5.27.5 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 7 dm: SDDM
    Distro: Debian GNU/Linux 12 (bookworm)
  Type: Laptop System: HP product: HP 255 G7 Notebook PC
    v: Type1ProductConfigId serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: HP model: 85EA v: 51.27 serial: <superuser required> UEFI: Insyde
    v: F.35 date: 02/02/2021
  ID-1: BAT1 charge: 37.7 Wh (100.0%) condition: 37.7/40.9 Wh (92.3%)
    volts: 12.7 min: 11.3 model: Hewlett-Packard PABAS0241231 type: Li-ion
    serial: <filter> status: full
  Info: model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx bits: 64
    type: MT MCP arch: Zen/Zen+ note: check gen: 1 level: v3 note: check
    built: 2019 process: GF 12nm family: 0x17 (23) model-id: 0x18 (24)
    stepping: 1 microcode: 0x8108109
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 384 KiB desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
    desc: 1x4 MiB
  Speed (MHz): avg: 1473 high: 2100 min/max: 1400/2100 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1400 2: 1400
    3: 1400 4: 2100 5: 1291 6: 1400 7: 1400 8: 1400 bogomips: 33535
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_rstack_overflow mitigation: safe RET
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    vendor: Hewlett-Packard driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 04:00.0 chip-ID: 1002:15d8
    class-ID: 0300 temp: 57.0 C
  Device-2: Quanta HP TrueVision HD Camera type: USB driver: uvcvideo
    bus-ID: 3-2.1:3 chip-ID: 0408:5365 class-ID: 0e02
  Display: x11 server: X.Org v: with: Xwayland v: 22.1.9
    compositor: kwin_x11 driver: X: loaded: amdgpu
    unloaded: fbdev,modesetting,vesa dri: radeonsi gpu: amdgpu display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: BOE Display 0x0687 built: 2015
    res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6")
    diag: 394mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6 Mesa 22.3.6 renderer: AMD Radeon Vega 8 Graphics
    (raven LLVM 15.0.6 DRM 3.49 6.1.0-13-amd64) direct-render: Yes
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 04:00.1 chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Hewlett-Packard
    driver: snd_pci_acp3x v: kernel alternate: snd_rn_pci_acp3x, snd_pci_acp5x,
    snd_pci_acp6x pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 04:00.5
    chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.1.0-13-amd64 status: kernel-api tools: alsamixer,amixer
  Server-1: PipeWire v: 0.3.65 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active tools: pw-cat,pw-cli,wpctl
  Server-2: PulseAudio v: 16.1 status: off (using pipewire-pulse)
    tools: pacat,pactl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter
    vendor: Hewlett-Packard driver: rtw_8822be v: N/A modules: rtw88_8822be
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 02:00.0
    chip-ID: 10ec:b822 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-1: Realtek Bluetooth 4.2 Adapter type: USB driver: btusb v: 0.8
    bus-ID: 3-2.3:4 chip-ID: 0bda:b00b class-ID: e001 serial: <filter>
  Report: hciconfig ID: hci0 rfk-id: 1 state: down
    bt-service: enabled,running rfk-block: hardware: no software: no
    address: <filter>
  Info: acl-mtu: 1021:8 sco-mtu: 255:16 link-policy: rswitch hold sniff park
    link-mode: peripheral accept
  Local Storage: total: 476.94 GiB used: 20.31 GiB (4.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
    model: BC511 HFM512GDJTNI-82A0A size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: HPS0 temp: 34.9 C scheme: GPT
  ID-1: / raw-size: 55.31 GiB size: 54.14 GiB (97.89%) used: 13.25 GiB (24.5%)
    fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 32.7 MiB (12.8%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 29.79 GiB size: 29.15 GiB (97.87%)
    used: 7.03 GiB (24.1%) fs: ext4 dev: /dev/nvme0n1p8 maj-min: 259:8
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 14.9 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p6 maj-min: 259:6
  System Temperatures: cpu: 56.6 C mobo: N/A gpu: amdgpu temp: 56.0 C
  Fan Speeds (RPM): N/A
  Processes: 236 Uptime: 41m wakeups: 1 Memory: 5.73 GiB
  used: 2.46 GiB (42.9%) Init: systemd v: 252 target: graphical (5)
  default: graphical tool: systemctl Compilers: gcc: 12.2.0 alt: 10/12
  Packages: pm: dpkg pkgs: 2419 libs: 1504 tools: apt,apt-get pm: rpm pkgs: 0
  Shell: Bash v: 5.2.15 running-in: konsole inxi: 3.3.26