Solved Arch KDE Application Launcher not Searching ~/.local/share/applications

Solved issue


May 23, 2023
Reaction score
The gist is in the thread title. I'm on the latest release of Arch, and my application launcher (start menu) does not seem to be looking in "$HOME/.local/share/applications" for desktop entries. I have modified several, and these are not being reflected in my launcher. I have used the bundled KMenuEdit, but I want it to work according to specs (seems it isn't). I have modified my bash.bashrc file to include "~/.local/share" as a path to XDG_DATA_DIRS (which works when using printenv). I have set a script (conforming to the KDE specs) in "~/.config/plasma-workspace/env" (though, now that I think of it—and I don't if this matters—I didn't make it executable). I have also updated mime cache by running
update-desktop-database ~/.local/share/applications

None of the preceding fixes the issue. In the past (on other distros), I did not have this issue. Any ideas how to solve this?

Those who persist, huh... I figured it out. All works as intended, the problem was with the "Category" key in the .desktop file. It appears some categories span multiple menus. In my case, I wanted to remove an entry from the "Utilities" menu, well another value was used for the "Utilities" menu besides just "Utilities;". All good now.

Members online