• Important: We recently upgraded our forum software - please let us know if you run into any issues.

After an update, system boots, then video fails...

lnxguy

New Member
It's been a whole month since I got my system working with my superwide display and the newest Nvidia drivers.

All was well until today, when it got past the GRUB2 boot and began to run Plymouth. At that point, the screen freezes in the top third and fills the bottom third with either a splatter of dashes [-] or a solid color, blue so far...

I can see my custom gfxboot image for a second in the bottom third of the screen, then the dashes.

I ignored the display and was able to log in as root and force a shutdown, so I may have partial control of the command line.

I haven't tried startx yet because I don't know if X is even running. I doubt it.

Is this another nvidia problem, or possibly related to the GRUB2 boot issue?

Anyone else have this behavior? I'm stuck for now...

I edited the GRUB2 script, removing quiet and splash with no change.

I know the command line is still working, but I am blind, since the display is only showing garbage characters.

If I switch to TTY7, the bottom third of the screen turns blue, so X is running. I still can't see anything since the display is not working.

This machine is working fine running Win10 with no issues....

I seem to have control on the CL by logging in as root and sending various commands, such as halt and reboot. I tried XFdrake and the bottom third went blank, indicating the text (gibberish) had switched to the ncurses.

The only further steps I can think of would be to ssh into the box and poke around, buy I don't know what I am looking for! Why would the graphics be broken before the X session starts?

I don't want to reinstall, but I can handle lots of surgery to get this figured out...

Thanks for any insights
 


TechnoJunky

Active Member
What Linux distro are you running? What version?

What happened between the last time it was working and the next time where it wasn't working? Did you run updates?
 

lnxguy

New Member
What Linux distro are you running? What version?

What happened between the last time it was working and the next time where it wasn't working? Did you run updates?
Distro is PCLinuxOS 2019 with all the updates as of Sunday, May 12.

PC is an AMD Ryzen 7, 3.2 Ghz, 32 GB RAM booting UEFI from an M.2 NVME SSD. Nvidia RTX 2060 GPU.

The system was running fine after some updates and has been rebooted twice with no issues. The system was shut down for three days and started this weirdness on the first boot after being off. No updates or changes...

I will attempt to SSH into the box and try installing a different kernel and reinstalling GRUB2 for starters.

Not sure where else to go on this one. Why would the video work fine in Windoze, but be completely corrupted in Linux? Weird.
 

arochester

Moderator
Staff member
Gold Supporter
I removed all the older kernels.
It is good practice to have two kernels available, the current one and the previous one. You never know when you might have to boot into the older kernel.
 

TechnoJunky

Active Member
For a possible answer of why it's weird in Linux but not in Windows is drivers. Both OSes drivers and different drivers than each other. And although Nvidia has always provided drivers for Linux, they don't seem to give as much love to us as they do Windows. I've always had Nvidia cards in my comps and used to always had to download the drivers from Nvidia, and when updating the kernel, had to recompile before the video would work with the new kernel (it could have been because I used Fedora). Newer Ubuntu based distros have eliminated this headache thank goodness. Anyway it's possible that you updated your kernel and it doesn't like the driver setup. If you downloaded the Nvidia driver from Nvidia, you may need to run the configuration again. Here's a link to an article that may help you update and correct the problem. http://www.linuxandubuntu.com/home/how-to-install-latest-nvidia-drivers-in-linux
 

lnxguy

New Member
Update:

I was able to SSH in to my system and it was running OK, except for in ps aux, there was a process called .../gdm/Xkeeps crashing.

I did a system update, reinstalled GRUB2, GDM, gfxboot, the Nvidia driver and DKMS module and fixed a config setting in my gfxboot config.

Nope. nothing worked...

I remembered that I had the Nouveau module blacklisted before, so I found that file and added it back in.

That still didn't fix it, so I ran XFdrake again after deleting xorg.conf. The only thing I did differently was uncheck the box next to "Enable RENDER Acceleration (this may cause bugs when displaying text)" Yeah, no $417...

I made sure to leave the resolution at "Automatic (24 BPP)" and Guess what?

It booted.

The GDM screen was new and had a different background, but it worked.

I think I'll delete my xorg.conf and put he old one back in to see if all is well.

Holy $417 this one was nasty!
 

Members online

No members online now.

Top