ACPI Error on LG Gram 17 inch when attempting to multiboot

Jeffrey Lapinski

Active Member
Here is a link to my initial post concerning this issue

A bit of background here: I recently purchased a LG Gram 17 inch and intended to multiboot a few Debian/Ubuntu based distros. I am able to disable secure boot and successfully install and run Mint 19.2 Cinnamon but every time I try to install a 2nd distro I encounter an "ACPI" Storm very similar to this https://bugzilla.kernel.org/show_bug.cgi?id=203617

When I attempt to install a 2nd distro I make sure that secure boot remains disabled and additionally I delete the secure boot signatures before installing the second
distro.
4361


@arochester provided this link where the problem is also discussed https://www.reddit.com/r/linuxhardware/comments/bl5ny8
Any one ever encounter this? Any one have solution? If more detailed information is needed please let me know.

Here is the only "fix" I have found and it appears to be for Arch based systems. From what I am reading it looks like the problem is when trying to boot systems using a kernel version above 4.18 which explains why Mint 19.2 is still working well since it is using 4.15
 
Last edited:


Jeffrey Lapinski

Active Member
Update: it does appear to be kernel related. So far I can successfully boot both Cinnamon and XFCE editions of 19.2 using 4.15-60
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
....and it appears to be for Arch based systems
No - despite the Arch reference at GitHub,

pci=nommconf

can be applied at startup with most if not all of the available distros, including the Debian-based distros.

You could try it at startup from the Grub menu by kicking through to 'e' for edit and appending it to the line starting kernel. Then if it works, you can add it to the /etc/default/grub file with the line starting

GRUB_CMDLINE_LINUX_DEFAULT=

and on exit

sudo update-grub

It's available with the kernel since v2.6.

On your latest - sounds good, for now?

Wiz
 

Jeffrey Lapinski

Active Member
Ok, “in theory” adding this line before attempting to install a distro w/ a newer kernel should allow me to install and boot the new system.

What is the difference between just editing/adding the line in grub vs /etc/default/grub ?
 

Jeffrey Lapinski

Active Member
The install of xfce was more of an experiment to see if it would work! I don’t intend to add any distros until I get this bug worked out! I want my Plasma!
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Changes made via choosing 'edit' at Grub Menu appearance are applicable through the session that is being launched only.

Once you shutdown or reboot, the change/s made will not be present in the startup parameters.

Linux uses 3 main sources in its startup configuration -

  • grub.cfg (some Families such as RPM have as grub2.cfg) in /boot/grub (sometimes as /boot/grub2, again RPM-based)
  • (... which can be altered through editing and saving) /etc/default/grub, once it has been edited and saved, must further be followed with sudo update-grub in Debian-based and Manjaro distros, or with grub-mkconfig -o /boot/grub/grub.cfg in others, also varies in eg Fedora between UEFI and non-UEFI and the grub2 syntax
  • and scripts either provided by the Devs of your Distro or authored yourself in /etc/grub.d/
Linux also uses /etc/fstab (file system table), both as it stands originally, and with modifcations made by the user to find or alter certain patterns and behaviours with Swap, drive and partition IDs, hardware modifications &c

So if the change/s you make to the parameters with using 'e' for Edit at startup gets you into your Distro and works for the session, make the same change/s to /etc/default/grub so the benefits will persist from there on.

HTH

Wiz
 

Jeffrey Lapinski

Active Member
Thanks, Chris!
I hope to try and fix this over the weekend. Just to be clear on my end - do I do the edit before or after installing a new distro? I’m assuming after since Mint doesn’t need to updates code?
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
After :)
 

Jeffrey Lapinski

Active Member
Before I attempt this repair I'd like to verify how I am going to do this.
1. Install an additional .deb based distro with a kernel above 4.15
2. Once installed and at the grub menu enter edit 'e'
3. Add pci=nommconf to the line starting kernel (I assume at the beginning of the line)?
4. If successful I need to add the same text (pci=nommconf) to the /etc/default/grub file with the line that starts
GRUB_CMDLINE_LINUX_DEFAULT= (at the beginning)?
5. Exit
6. sudo update=grub

Does that sound correct?

I added the two photos below. At the grub menu on the OS that are already installed I entered the edit screen. There is no line starting "kernel" am I missing something?
 

Attachments

Last edited:

Jeffrey Lapinski

Active Member
Code:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
Here is the /etc/default/grub file from LM 19.2 Cinnamon. I haven't done this yet but when I do is this how it should look?

pci=nommconf GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" (except I would add this to the /etc/default/grub file in say Netrunner?
 

alter_ohm

New Member
there is the kernel option "pci=nommconf" to avoid the acpi problem, but there is also another workaround (disabling RTD3 bios option) to avoid a hang-up while booting linux. a link which leads to this solution is already posted here in this thread, but somebody may find it useful if there is no need to search for it on other websites.

from https://github.com/crazyluv/solve-lg-gram-17-linux-boot-error :
crazyluv said:
Solve! LG gram 17 linux boot infinite acpi error for kernel 4.18 over

I found a workaround for acpi infinite error in LG Gram 17 inch kernel 4.18 and above. I just tested it and successfully booted ubuntu 19.04 kernel 5.0.

I looked at all the settings for the 14-inch grams of 2018 that were before 17 inches and found the differences to find the cause. The workaround is as follows:

  1. At boot time, press F2 to enter bios.
  2. Press ctrl + alt + F7 to switch to advanced mode.
  3. Select the advanced tab.
  4. Select Intel Advanced Menu.
  5. Select Thunderbolt (TM) Configuration.
  6. Select Discrete Thunderbolt (TM) Configuration.
  7. Select Thunderbolt (TM) OS Select.
  8. Set Windows 10 Thunderbolt support to Enabled(without RTD3 or "Disabled"). After a delay of about 5 seconds after setting, the confirmation message for saving the setting changes appears.
  9. Save the changed settings and reboot.
  10. Now you can boot normally(without having to set "pci=nommconf" in grub) with the latest kernel!

enjoy linux!

I got a hint and the link is https://github.com/dhedlund/kernel-patch-lg-gram-17 and I found that it seems to be a problem with Thunderbolt.

Thank you.

to boot some linux distributions it is necessary to disable secure boot. i could boot and install mint 19.2 with secure boot enabled but hat to disable it for kali linux.
- enter BIOS / Security tab / Secure Boot Information / disable "Secure Boot Option"

there is also a general forum thread for all things related to the lg gram 17 on another website. see http://forum.notebookreview.com/threads/new-lg-gram-17.827017/page-37
 

Jeffrey Lapinski

Active Member
This appears to be working! It is actually allowing me to install Manjaro 18.1.0 KDE. I had to disable "thunderbolt" in a few places as I was continuing to hit errors. Once I disabled "Windows 10 support" it allowed me to boot into the live USB and install. I will post once the OS is installed and working!

update: so far so go!
Thank you so much for that link!!
 
Last edited:

alter_ohm

New Member
This appears to be working! It is actually allowing me to install Manjaro 18.1.0 KDE. I had to disable "thunderbolt" in a few places as I was continuing to hit errors. Once I disabled "Windows 10 support" it allowed me to boot into the live USB and install. I will post once the OS is installed and working!

update: so far so go!
Thank you so much for that link!!
i never had to disable thunderbolt. in the bios i only disabled "secure boot" and i never deleted any signatures. i installed "manjaro-kde-18.0.4-stable-x86_64" to the ssd with "pci=nommconf" kernel option because i didn't know of the alternative solution at that moment.

right now thunderbolt is enabled but i switched it from "Enabled +RTD3" to just "Enabled". so only the RTD3 option is disabled. after that i changed grub again by removing the "pci=nommconf" kernel option :
# to change grub permanently
sudo nano /ect/default/grub
sudo update-grub
manjaro-kde--18.0.4 boots without the special kernel option and in bios thunderbolt is enabled.


solution from crazyluv:
to avoid linux (kernel >= 4.18) acpi error hang-up (no need to add "pci=nommconf" kernel option) disable RTD3:
- enter bios / press CTRL+ALT+F7 / Advanced tab / Intel Advanced Menu / Thunderbolt Configuration / Discreet Thunderbolt Configuration / Thunderbolt OS Select / switch Windows 10 Thunderbolt support from "Enabled +RTD3" to "Enabled" or "Disabled"
 

Jeffrey Lapinski

Active Member
witch Windows 10 Thunderbolt support from "Enabled +RTD3" to "Enabled" or "Disabled"
This is what worked. It installed without issue and is currently running smoothly! Disabling the secure boot option worked for Mint but not for anything else. I assumed it was due to the newer kernel? Not sure, but any time I tried to install anything with a kernel over 4.15 it just wouldn't work. Disabling Windows 10 Thunderbolt support worked.
 

alter_ohm

New Member
hm, english is not my native language and i think it's possible we are not completely understanding each other. i just wanted to bring it to your attention that you don't have to disable the windows 10 thunderbolt support. enabling it without RTD3 is a solution.
of course, disabling windows 10 thunderbolt support also works.
 

Jeffrey Lapinski

Active Member
Ok, no problem at all! I realized that after I reread your post but since I have it working I didn't feel the need to change it. I am not dual booting with Windows and I don't use anything with Thunderbolt. Thank you again for your post! I have been trying to figure this out for a few weeks now!
 

Members online


Top