Xen instalation issue

K

klaus_1974

Guest
Hello,

I just installed Xen in a 64bits RHEL 5.4, however every time I'm getting this error every time:

Traceback (most recent call last):
File "/usr/sbin/xm", line 8, in ?
from xen.xm import main
File "/usr/lib/python2.4/site-packages/xen/xm/main.py", line 54, in ?
from xen.util.acmpolicy import ACM_LABEL_UNLABELED_DISPLAY
File "/usr/lib/python2.4/site-packages/xen/util/acmpolicy.py", line 30, in ?
import xen.util.xsm.acm.acm as security
File "/usr/lib/python2.4/site-packages/xen/util/xsm/acm/acm.py", line 28, in ?
from xen.lowlevel import acm
ImportError: /usr/lib/python2.4/site-packages/xen/lowlevel/acm.so: wrong ELF class: ELFCLASS32


# uname -r
2.6.18-274.el5xen

I've instaled:

python-virtinst-0.400.3-12.el5.noarch.rpm
libvirt-python-0.9.0-1.el5.art.x86_64.rpm
libvirt-0.9.0-1.el5.art.x86_64.rpm
kernel-xen-2.6.18-274.el5.x86_64.rpm


Have I done anything wrong?

Thanks,

Klaudio
 


R

Rob

Guest
Hi Klaudio,

I think the clue comes in w/ the last line:
ImportError: /usr/lib/python2.4/site-packages/xen/lowlevel/acm.so: wrong ELF class: ELFCLASS32

This suggests that you're using a 32bit version of python 2.4

What's the output of:
# rpm -q python
 
R

Rob

Guest
I'm not a big python user.. but try exporting the pythonpath to tthe 64bit python perhaps?
[xcode=bash]
export PYTHONPATH=/usr/lib64/python2.4/site-packages
[/xcode]
 
K

klaus_1974

Guest
I guess the problem is related with xen packages wich are not x86_64 rpms. I installed :

xen-3.2.0-0xs.centos5.i386.rpm
xen-3.2.0-0xs.centos5.src.rpm
xen-debuginfo-3.2.0-0xs.centos5.i386.rpm
xen-devel-3.2.0-0xs.centos5.i386.rpm
xen-libs-3.2.0-0xs.centos5.i386.rpm

Couldn't find any x86_64 rpms.
Still searching.

Thanks anyway.
 


Members online


Top