Ubuntu/Windows 10 dual boot GRUB issues

DataLore

New Member
Credits
85
In April I tried dual-booting Ubuntu 19.10 on my new Lenovo Yoga C740 but I couldn't get Ubuntu to boot, so I deleted the partition and have just tried again, only to have the same issues. I followed this guide including the parts in the beginning, disabling fast startup and secure boot. I created a partition of "unallocated space" and installed ubuntu onto that. Once installed, Ubuntu will not boot, I have no GRUB menu, and Ubuntu is not listed in the UEFI boot settings*. I then followed this guide on installing boot repair using my Ubuntu usb, but when I opened boot repair there was no "recommended repair" option. Instead I had it create this report although I can't say what most of that is telling me**.
When boot repair wasn't working, I decided to try this windows command prompt I found the last time I tried dual-booting, and then try boot repair again.
Code:
bcdedit /set "{bootmgr}" path \EFI\ubuntu\grubx64.efi
When I opened boot repair, it said it needed to install mdadm. The first time I said yes, the second time, after trying the windows command prompt, I accidentally said no. When I said no, I got the "recommended repair" option. I wrote down the commands boot repair had me enter in the terminal so if anyone wants to see them I can type them up. I think it was trying to remove GRUB and reinstall it. A prompt came up in the terminal that asked (paraphrased) "do you want to remove all GRUB 2 files from /boot/grub?" and after I finished all of that, it said, "GRUB is still present" and I couldn't continue. I closed and reopened boot repair, and when it asked to install mdadm I said yes. I still got the "recommended repair" option, only this time it had a couple of new prompts related to mdadm. But still, when I entered all of the commands, it said "GRUB is still present". I restarted the computer, went back into the Ubuntu usb, re-installed boot repair, and when it asked to install mdadm I said yes. Again, I didn't get the "recommended repair" option. That's when I decided to head to the forums.
I'm very new to programming in general but I've already grown to dislike windows. I want to dual-boot only so I can keep playing video games on windows, but at the end of the day I will sacrifice some of my pleasure for business if necessary, so my last resort will be going 100% linux. I'm just starting a class in C++ and I really want to be using linux. I tried programming on windows for about 5 minutes and it was 5 minutes too many o_O anyway, I tried to be overly detailed so hopefully that helps, and any advice will be greatly appreciated!

*In the Windows boot menu (before getting to the Lenovo BIOS menu) if I click certain settings like "security", I have to go through bitlocker and get a security code from my Microsoft account. I don't know what bitlocker is or if that's relevant at all to my issues. I am able to enter BIOS without doing this.
** in the report, my usb device is listed as "Linpus Lite". I had to look that up, and google says it's a "low-cost" version of linux? My laptop is not officially certified to run linux but it isn't a netbook or anything. When I plug it into windows, it's listed as "ubuntu 19.10" or SanDisk. Just another thing that may or may not be relevant.
 





Top