Trouble with booting from Ext SSD HDD 500Gb Samsung T5

Soulful_Quaser

New Member
Hi all,

I've looked through the forum and couldn't see post explaining my exact problem. But i may have missed it.

So my issue is, I've downloaded ubuntu-18.04.3-desktop-amd64 (into downloads folder) and I've also downloaded rufus-3.8 to create a bootable USB drive. After running rufus everything appeared to go ok (Formatted to NTFS) and my Ext hdd now contains multiple folders and files for Ubuntu.

In the BIOs i have changed the boot order, so that boot from USB is first but it always just boots my Windows OS as usual?

Some specs:
8GB RAM
Processor Intel i7-4790 CPU @ 3.60GHz
Windows 10

Is there anything i'm doing that's blindingly, obviously wrong?

Any help would be awesome.

Thanks.
 


wizardfromoz

Super Moderator
Staff member
Gold Supporter
After running rufus everything appeared to go ok (Formatted to NTFS) and my Ext hdd now contains multiple folders and files for Ubuntu.
This concerns me. What was formatted to NTFS? The USB stick?



(Wizard appears in a puff of smoke)

The USB stick should be formatted to FAT32.

Then use Rufus to burn the Ubuntu .iso to the stick.

Then boot from the stick and you should be brought into an Ubuntu desktop that offers for you to try Ubuntu or install Ubuntu and go from there.

The Ubuntu installer, called Ubiquity, will detect your Windows 10 and offer to install alongside it, or to erase whole disk and install Linux, or else choose Something Else.

Choose Something Else.

This will launch a screen showing Partitions.

If your rig has just the one drive, with Windows 10 on it (your C: drive) this will be regarded by Linux as (device) /dev/sda, and your Ext HDD as /dev/sdb.

Where it asks where to install the system, choose /dev/sdb.

You can use the partitioning process to clean off whatever Ubuntu stuff is already on the Ext HDD.

Do not encrypt your Home Partition.

See how you go and ask any questions.

Cheers

Chris Turner
wizardfromoz
 

Soulful_Quaser

New Member
Hi guys, thanks for the replies.

So I’m only using an ext Hdd the Samsung SSD, (No USB Stick) which I formatted to NTFS and burnt the Ubuntu ISO file to....... But you’re saying format that to FAT32?

Am I better off using a USB stick to burn the ISO file to and have my Ext Hdd plugged in alongside it to install the OS to?
Also if that’s the case, have that formatted in the partitioning process?

Just for information my rig has a C drive containing my windows OS and also a 1TB D drive for storage

Thanks for the input, it’s much appreciated.
 

CptCharis

Well-Known Member
Am I better off using a USB stick to burn the ISO file to and have my Ext Hdd plugged in alongside it to install the OS to?
Also if that’s the case, have that formatted in the partitioning process?
This is the best way. I have done with my LMint.
The USB stick will be formatted during the process. As far for your ext HDD i think FAT32 can work.
In my case I formated my HDD as NTFS and installation completed without issues.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
I was confused (some might say my normal state of affairs, but Wizard would turn them into toads), but think the penny has dropped now.

Rufus has recognised your Ext HDD as being an eligible USB device to burn to, and you have burned the Ubuntu iso to the drive itself. This has effectively turned the drive into one big USB stick :)

Ba-bumm (Family Feud, wrong answer).

With rare exceptions (includes Virtual Machine setup) to install Linux you need either a USB stick or a DVD to burn the iso to.

You then alter your BIOS (as you have done correctly) to boot the USB stick or DVD ahead of the HDD (this setting can be either for one-time boot or permanently).

Have the stick in place and boot/reboot (in some cases you have to go through the BIOS on the way) and you will be brought into a desktop setting of Ubuntu.

From there, you take the installer through as I have described above.

Capta (@CptCharis ) has said above

In my case I formated my HDD as NTFS and installation completed without issues.
... so you can leave the drive as NTFS if you wish, but what will happen is the Installer will convert the space needed for Linux to our File System - EXT4.

When the install is completed, you reboot the machine, and instead of your usual entry to Windows, you will be brought into a black and white screen with a small Menu, this is called the GRUB Menu (Grand Universal Bootloader).

Grub will have Ubuntu listed on top, then an Advanced option (no need to use for now), and then a line saying Windows Boot Manager, which is your way into Windows.

There is a default 10-second timer on Grub before the default option is booted (Ubuntu) ub-nless you choose Windows.

Do be sure that you have your Windows recovery plan in place (a Recovery USB stick or backup) in case anything goes wrong.

See how you go, and report back with outcomes or any questions.

Cheers

Wizard
 

Soulful_Quaser

New Member
Thanks for the replies again guys.

So I burnt the ISO onto USB stick and then installed it onto my Ext HDD and everything works great now, so thanks for your input.

The issues I did come across:

Ubuntu didn’t recognise my correctly input password, (initially Very basic and written down) so wouldn’t allow me to get past the user login screen, it also wasn’t recognised in TTY. Which after some research shows is a fairly common issue with a first time install. God knows why???

To try and fix it I rebooted it (Twice actually) after the second reboot, I came to a screen where there was a fault with GRUB (Can’t remember off the top of my head what it said on the screen). So at that point I disabled secure boot which seemed to fix that issue.
I then launched Ubuntu in recovery mode and reset my password. Which fixed that issue.

So everything is working ok now

What have I lost not using secure boot? I also disabled Fast boot as well. But I assume that’s not affecting any security around my PC.

Thanks again for the help guys.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Excellent finds, Capta - I am going to bookmark those :D

Quaser

...but I assume that’s not affecting any security around my PC.
Correct.

What you can do, with your Linux, now that you are up and running, is install the software firewall.

At Terminal (shortcut is Ctrl-Alt-t) (my comments are prefaced with a hash)

Code:
sudo ufw enable

#enter your password, you will see no movement (security) and press Enter
You will receive a message saying the firewall is enabled (now, in real time) and will run on every boot/reboot.

ufw is the Uncomplicated Fire Wall, and between it and a firewall at your router, many LInux users find no need for antivirus software (myself included), although you can get it.

Cheers

Wizard
 

Soulful_Quaser

New Member
Apologies for the late reply, unfortunately work gets in the way lol

Thanks for that Wizard, once I'm back up and running i will enable that. (This forum is awesome).

Next issue................ My PC now doesn't display anything on my monitor, it appears to boot up ok, but nothing is ever displayed on my monitor.

Would it be anything to do with my Zotac Nvidia Geforce Gtx 980 Ti graphics card?

I've also tried to use the display port fixed to the motherboard but no joy? I'm pulling my hair out a little bit lol
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
...unfortunately work gets in the way lol
Well, how dare it? is all I can say :) (kidding)

Nvidia can be problematic, and there is a video out there of our Founder, Linus Torvalds, using the 'f' word about them :)

For The Viewers, you have Windows 10, and so you have a Grub Menu with Linux on top followed by Windows Boot Manager to access Windows.

1. Does Windows work OK?

Does the Grub Menu have, at the bottom of the screen, entries for 'c' for command, and 'e' for Edit?

If so, we can try the edit to temporarily alter the startup parameters to exclude the Nvidia factor, using a command called

nomodeset

I'll be around for maybe another 30 minutes or so, but jumping between Distros.

Back soon I hope.

Wizard

(This forum is awesome).
Yeah, we'll take that ;)
 

Soulful_Quaser

New Member
I don't even get to see anything displayed on my monitor, at no point does it receive a signal from my PC. It's as though my monitor isn't even plugged in :(

*Edit*
Just went home for lunch and thought, i'd boot my computer up and now it appears to be working again??? Meaning i can see the PC boot up on my monitor, get to the GRUB screen then log into Ubuntu.
How do i prevent it it from doing that again?

*Further Edit*
Just for a bit more info: As i'm now logged in, i have gone to the "About" screen and next to "Graphics" it says "NV120" So i'm using the Nvidia Graphics Drivers
 
Last edited:

wizardfromoz

Super Moderator
Staff member
Gold Supporter


Staff online


Top