Trouble getting AMD graphics card working with OpenCL

organist1958

New Member
Joined
Oct 31, 2023
Messages
5
Reaction score
0
Credits
58
Hello all,
I have a Dell Precision T5810 (a very picky/temperamental machine), which I have put a Radeon VII and 2 Vega 64's in, and which I would like to mine with (I have free power at this location). I was able to get Teamredminer working on Windows with no issues and very little configuration/setup. I decided to install Mint because Windows has a lot of trouble with this machine for whatever reason (and I hate Windows).

I installed Mint 21.3, downloaded the AMDGPU-PRO driver .deb, installed it, and then ran the following command:

sudo amdgpu-install --usecase=workstation,rocm,opencl --opencl=rocr,legacy --vulkan=pro --accept-eula

When I do that, it produces the following output (see screenshot), and after rebooting, clinfo does not list any platforms. I have tried with many different variations of the 'amdgpu-install' command, but they all produce almost the exact same output. If I run

lshw -c display

all 3 of my GPU's are properly listed, so Mint sees them, but OpenCL is not functioning. Any ideas/help much appreciated.

I am running Mint 21.3, with 5.15.0-105-generic, with XFCE. The computer is a Dell Precision Tower 5810 with an Intel Xeon E5-2697 with 16GB of ECC RAM.
 

Attachments

  • Screenshot_2024-04-20_19-02-53.png
    Screenshot_2024-04-20_19-02-53.png
    176.2 KB · Views: 77


Top