TigerVNC server not found at apt

BoodyWin

Member
Joined
Feb 1, 2024
Messages
31
Reaction score
11
Credits
265
Well, I'm using a virtual machine for using Linux, but unfortunately, I tried to install tigervncserver (for gui apps) on the Linux distro (Ubuntu 22.04) but it wasn't found at apt, i tried to use apt-get, getting it from sourceforge but nothing changes.
Here's the output when i tried to install from apt normally:
Code:
boodywin@DESKTOP-9LDVUPD:~$ sudo apt install tightvncserver
[sudo] password for boodywin:
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package tightvncserver
boodywin@DESKTOP-9LDVUPD:~$ sudo apt-get install tightvncserver
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package tightvncserver
boodywin@DESKTOP-9LDVUPD:~$
and here's when i downloaded it from sourceforge:
Bash:
boodywin@DESKTOP-9LDVUPD:~$ ls
tigervncserver_1.13.1-1ubuntu1_amd64.deb  tigervncserver_1.13.1-1ubuntu1_arm64.deb
boodywin@DESKTOP-9LDVUPD:~$ sudo apt install tigervncserver_1.13.1-1ubuntu1_amd64.deb
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package tigervncserver_1.13.1-1ubuntu1_amd64.deb
boodywin@DESKTOP-9LDVUPD:~$ sudo apt install ./tigervncserver_1.13.1-1ubuntu1_amd64.deb
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Note, selecting 'tigervncserver' instead of './tigervncserver_1.13.1-1ubuntu1_amd64.deb'
The following additional packages will be installed:
  cpp cpp-11 fontconfig-config fonts-dejavu-core gcc-11-base libdrm-amdgpu1 libdrm-intel1 libdrm-nouveau2
  libdrm-radeon1 libfontconfig1 libfontenc1 libfreetype6 libgl1 libgl1-amber-dri libgl1-mesa-dri libglapi-mesa
  libglvnd0 libglx-mesa0 libglx0 libice6 libisl23 libjpeg-turbo8 libjpeg8 libllvm15 libmpc3 libpciaccess0
  libpixman-1-0 libsensors-config libsensors5 libsm6 libx11-xcb1 libxaw7 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0
  libxcb-present0 libxcb-randr0 libxcb-shape0 libxcb-shm0 libxcb-sync1 libxcb-xfixes0 libxcomposite1 libxcursor1
  libxdamage1 libxfixes3 libxfont2 libxft2 libxi6 libxinerama1 libxkbfile1 libxmu6 libxpm4 libxrandr2 libxrender1
  libxshmfence1 libxt6 libxtst6 libxv1 libxxf86dga1 libxxf86vm1 x11-common x11-utils x11-xkb-utils x11-xserver-utils
  xfonts-base xfonts-encodings xfonts-utils
Suggested packages:
  cpp-doc gcc-11-locales lm-sensors xtigervncviewer tigervnc-java mesa-utils nickle cairo-5c xorg-docs-core
The following NEW packages will be installed:
  cpp cpp-11 fontconfig-config fonts-dejavu-core gcc-11-base libdrm-amdgpu1 libdrm-intel1 libdrm-nouveau2
  libdrm-radeon1 libfontconfig1 libfontenc1 libfreetype6 libgl1 libgl1-amber-dri libgl1-mesa-dri libglapi-mesa
  libglvnd0 libglx-mesa0 libglx0 libice6 libisl23 libjpeg-turbo8 libjpeg8 libllvm15 libmpc3 libpciaccess0
  libpixman-1-0 libsensors-config libsensors5 libsm6 libx11-xcb1 libxaw7 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0
  libxcb-present0 libxcb-randr0 libxcb-shape0 libxcb-shm0 libxcb-sync1 libxcb-xfixes0 libxcomposite1 libxcursor1
  libxdamage1 libxfixes3 libxfont2 libxft2 libxi6 libxinerama1 libxkbfile1 libxmu6 libxpm4 libxrandr2 libxrender1
  libxshmfence1 libxt6 libxtst6 libxv1 libxxf86dga1 libxxf86vm1 tigervncserver x11-common x11-utils x11-xkb-utils
  x11-xserver-utils xfonts-base xfonts-encodings xfonts-utils
0 upgraded, 68 newly installed, 0 to remove and 0 not upgraded.
Need to get 59.3 MB/61.0 MB of archives.
After this operation, 220 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 /home/boodywin/tigervncserver_1.13.1-1ubuntu1_amd64.deb tigervncserver amd64 1.13.1-1ubuntu1 [1617 kB]
Get:2 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 gcc-11-base amd64 11.4.0-1ubuntu1~22.04 [20.2 kB]
Get:3 http://archive.ubuntu.com/ubuntu jammy/main amd64 libisl23 amd64 0.24-2build1 [727 kB]
Get:4 http://archive.ubuntu.com/ubuntu jammy/main amd64 libmpc3 amd64 1.2.1-2build1 [46.9 kB]
Get:5 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 cpp-11 amd64 11.4.0-1ubuntu1~22.04 [10.0 MB]
Get:6 http://archive.ubuntu.com/ubuntu jammy/main amd64 cpp amd64 4:11.2.0-1ubuntu1 [27.7 kB]
Get:7 http://archive.ubuntu.com/ubuntu jammy/main amd64 fonts-dejavu-core all 2.37-2build1 [1041 kB]
Get:8 http://archive.ubuntu.com/ubuntu jammy/main amd64 fontconfig-config all 2.13.1-4.2ubuntu5 [29.1 kB]
Get:9 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libdrm-amdgpu1 amd64 2.4.113-2~ubuntu0.22.04.1 [19.9 kB]
Get:10 http://archive.ubuntu.com/ubuntu jammy/main amd64 libpciaccess0 amd64 0.16-3 [19.1 kB]
Get:11 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libdrm-intel1 amd64 2.4.113-2~ubuntu0.22.04.1 [66.7 kB]
Get:12 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libdrm-nouveau2 amd64 2.4.113-2~ubuntu0.22.04.1 [17.5 kB]
Get:13 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libdrm-radeon1 amd64 2.4.113-2~ubuntu0.22.04.1 [21.6 kB]
Get:14 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libfreetype6 amd64 2.11.1+dfsg-1ubuntu0.2 [389 kB]
Get:15 http://archive.ubuntu.com/ubuntu jammy/main amd64 libfontconfig1 amd64 2.13.1-4.2ubuntu5 [131 kB]
Get:16 http://archive.ubuntu.com/ubuntu jammy/main amd64 libfontenc1 amd64 1:1.1.4-1build3 [14.7 kB]
Err:17 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libglapi-mesa amd64 23.0.4-0ubuntu1~22.04.1
  404  Not Found [IP: 91.189.91.81 80]
Get:18 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libgl1-amber-dri amd64 21.3.9-0ubuntu1~22.04.1 [4218 kB]
Get:19 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libllvm15 amd64 1:15.0.7-0ubuntu0.22.04.3 [25.4 MB]
Get:20 http://archive.ubuntu.com/ubuntu jammy/main amd64 libsensors-config all 1:3.6.0-7ubuntu1 [5274 B]
Get:21 http://archive.ubuntu.com/ubuntu jammy/main amd64 libsensors5 amd64 1:3.6.0-7ubuntu1 [26.3 kB]
Get:22 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxcb-dri3-0 amd64 1.14-3ubuntu3 [6968 B]
Err:23 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libgl1-mesa-dri amd64 23.0.4-0ubuntu1~22.04.1
  404  Not Found [IP: 185.125.190.39 80]
Get:24 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libx11-xcb1 amd64 2:1.7.5-1ubuntu0.3 [7802 B]
Get:25 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxcb-dri2-0 amd64 1.14-3ubuntu3 [7206 B]
Get:26 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxcb-glx0 amd64 1.14-3ubuntu3 [25.9 kB]
Get:27 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxcb-present0 amd64 1.14-3ubuntu3 [5734 B]
Get:28 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxcb-randr0 amd64 1.14-3ubuntu3 [18.3 kB]
Get:29 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxcb-shm0 amd64 1.14-3ubuntu3 [5780 B]
Get:30 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxcb-sync1 amd64 1.14-3ubuntu3 [9416 B]
Get:31 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxcb-xfixes0 amd64 1.14-3ubuntu3 [9996 B]
Get:32 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxfixes3 amd64 1:6.0.0-1 [11.7 kB]
Get:33 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxshmfence1 amd64 1.3-1build4 [5394 B]
Get:34 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxxf86vm1 amd64 1:1.1.4-1build3 [10.4 kB]
Err:35 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libglx-mesa0 amd64 23.0.4-0ubuntu1~22.04.1
  404  Not Found [IP: 185.125.190.39 80]
Get:36 http://archive.ubuntu.com/ubuntu jammy/main amd64 x11-common all 1:7.7+23ubuntu2 [23.4 kB]
Get:37 http://archive.ubuntu.com/ubuntu jammy/main amd64 libice6 amd64 2:1.0.10-1build2 [42.6 kB]
Get:38 http://archive.ubuntu.com/ubuntu jammy/main amd64 libjpeg-turbo8 amd64 2.1.2-0ubuntu1 [134 kB]
Get:39 http://archive.ubuntu.com/ubuntu jammy/main amd64 libjpeg8 amd64 8c-2ubuntu10 [2264 B]
Get:40 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libpixman-1-0 amd64 0.40.0-1ubuntu0.22.04.1 [264 kB]
Get:41 http://archive.ubuntu.com/ubuntu jammy/main amd64 libsm6 amd64 2:1.2.3-1build2 [16.7 kB]
Get:42 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxt6 amd64 1:1.2.1-1 [177 kB]
Get:43 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxmu6 amd64 2:1.1.3-3 [49.6 kB]
Get:44 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libxpm4 amd64 1:3.5.12-1ubuntu0.22.04.2 [36.7 kB]
Get:45 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxaw7 amd64 2:1.0.14-1 [191 kB]
Get:46 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxcb-shape0 amd64 1.14-3ubuntu3 [6158 B]
Get:47 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxcomposite1 amd64 1:0.4.5-1build2 [7192 B]
Get:48 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxrender1 amd64 1:0.9.10-1build4 [19.7 kB]
Get:49 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxcursor1 amd64 1:1.2.0-2build4 [20.9 kB]
Get:50 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxdamage1 amd64 1:1.1.5-2build2 [7154 B]
Get:51 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxfont2 amd64 1:2.0.5-1build1 [94.5 kB]
Get:52 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxft2 amd64 2.3.4-1 [41.8 kB]
Get:53 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxi6 amd64 2:1.8-1build1 [32.6 kB]
Get:54 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxinerama1 amd64 2:1.1.4-3 [7382 B]
Get:55 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxkbfile1 amd64 1:1.1.0-1build3 [71.8 kB]
Get:56 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxrandr2 amd64 2:1.5.2-1build1 [20.4 kB]
Get:57 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxtst6 amd64 2:1.2.3-1build4 [13.4 kB]
Get:58 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxv1 amd64 2:1.0.11-1build2 [11.2 kB]
Get:59 http://archive.ubuntu.com/ubuntu jammy/main amd64 libxxf86dga1 amd64 2:1.1.5-0ubuntu3 [12.6 kB]
Get:60 http://archive.ubuntu.com/ubuntu jammy/main amd64 libglvnd0 amd64 1.4.0-1 [73.6 kB]
Get:61 http://archive.ubuntu.com/ubuntu jammy/main amd64 libglx0 amd64 1.4.0-1 [41.0 kB]
Get:62 http://archive.ubuntu.com/ubuntu jammy/main amd64 libgl1 amd64 1.4.0-1 [110 kB]
Get:63 http://archive.ubuntu.com/ubuntu jammy/main amd64 x11-utils amd64 7.7+5build2 [206 kB]
Get:64 http://archive.ubuntu.com/ubuntu jammy/main amd64 x11-xkb-utils amd64 7.7+5build4 [172 kB]
Get:65 http://archive.ubuntu.com/ubuntu jammy/main amd64 x11-xserver-utils amd64 7.7+9build1 [170 kB]
Get:66 http://archive.ubuntu.com/ubuntu jammy/main amd64 xfonts-encodings all 1:1.0.5-0ubuntu2 [578 kB]
Get:67 http://archive.ubuntu.com/ubuntu jammy/main amd64 xfonts-utils amd64 1:7.7+6build2 [94.6 kB]
Get:68 http://archive.ubuntu.com/ubuntu jammy/main amd64 xfonts-base all 1:1.0.5 [5896 kB]
Fetched 51.0 MB in 18s (2845 kB/s)
N: Download is performed unsandboxed as root as file '/home/boodywin/tigervncserver_1.13.1-1ubuntu1_amd64.deb' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)
E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/m/mesa/libglapi-mesa_23.0.4-0ubuntu1%7e22.04.1_amd64.deb  404  Not Found [IP: 91.189.91.81 80]
E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/m/mesa/libgl1-mesa-dri_23.0.4-0ubuntu1%7e22.04.1_amd64.deb  404  Not Found [IP: 185.125.190.39 80]
E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/m/mesa/libglx-mesa0_23.0.4-0ubuntu1%7e22.04.1_amd64.deb  404  Not Found [IP: 185.125.190.39 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
boodywin@DESKTOP-9LDVUPD:~$ sudo apt install ./tigervncserver_1.13.1-1ubuntu1_arm64.deb
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Note, selecting 'tigervncserver:arm64' instead of './tigervncserver_1.13.1-1ubuntu1_arm64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 tigervncserver:arm64 : Depends: libbsd0:arm64 (>= 0.2.0) but it is not installable
                        Depends: libc6:arm64 (>= 2.35) but it is not installable
                        Depends: libgcc-s1:arm64 (>= 3.3.1) but it is not installable
                        Depends: libgcrypt20:arm64 (>= 1.9.0) but it is not installable
                        Depends: libgl1:arm64 but it is not installable
                        Depends: libgmp10:arm64 (>= 2:6.2.1+dfsg) but it is not installable
                        Depends: libgnutls30:arm64 (>= 3.7.2) but it is not installable
                        Depends: libhogweed6:arm64 but it is not installable
                        Depends: libjpeg8:arm64 (>= 8c) but it is not installable
                        Depends: libnettle8:arm64 but it is not installable
                        Depends: libpam0g:arm64 (>= 0.99.7.1) but it is not installable
                        Depends: libpixman-1-0:arm64 (>= 0.30.0) but it is not installable
                        Depends: libselinux1:arm64 (>= 3.1~) but it is not installable
                        Depends: libstdc++6:arm64 (>= 5.2) but it is not installable
                        Depends: libsystemd0:arm64 but it is not installable
                        Depends: libunwind8:arm64 but it is not installable
                        Depends: libx11-6:arm64 (>= 2:1.4.99.1) but it is not installable
                        Depends: libxau6:arm64 (>= 1:1.0.9) but it is not installable
                        Depends: libxdamage1:arm64 (>= 1:1.1) but it is not installable
                        Depends: libxdmcp6:arm64 but it is not installable
                        Depends: libxext6:arm64 but it is not installable
                        Depends: libxfixes3:arm64 but it is not installable
                        Depends: libxfont2:arm64 (>= 1:2.0.1) but it is not installable
                        Depends: libxrandr2:arm64 (>= 2:1.2.0) but it is not installable
                        Depends: libxtst6:arm64 but it is not installable
                        Depends: zlib1g:arm64 (>= 1:1.1.4) but it is not installable
                        Recommends: xfonts-base:arm64
                        Recommends: x11-xserver-utils:arm64 but it is not installable
E: Unable to correct problems, you have held broken packages.
boodywin@DESKTOP-9LDVUPD:~$
 


sudo apt install ./tigervncserver_1.13.1-1ubuntu1_amd64.deb

This is not how standalone *.deb packages are installed, you need to use dpkg command instead:

Bash:
sudo dpkg -i ./tigervncserver_1.13.1-1ubuntu1_amd64.deb

But prefered method is to install it from repository, first try searching for it with:

Bash:
sudo apt search vnc --names-only

Then see if in the output there is package name you want, and try sudo apt install <package_name> again but with correct package name.
 
@BoodyWin wrote:
Code:
boodywin@DESKTOP-9LDVUPD:~$ sudo apt install tightvncserver
There's a typo there, hence package will not be found. But tigervnc is in the repos.

One can run the following with tab completion to see what's available:
Code:
[tom@min ~/]$ apt-cache show tigervnc-<TAB>
tigervnc-common             tigervnc-tools
tigervnc-scraping-server    tigervnc-viewer
tigervnc-standalone-server  tigervnc-xorg-extension

The apt command will install with the dependencies, if the package is in the repositories.
The dpkg command will install a .deb package alone, which is fine if all the dependencies have been taken care of one way or another, for example, if the package is a stand-alone one with its dependencies included inside it, or its known external dependencies have been previously installed.
 
Last edited:
if you find tigervnc to give you grief, you can use anydesk. They have a linux version. I had issues with massive memory leaks on tigerVNC. But I am sure it was just me. So keep in mind anydesk will work also and probably easier. just go download the .deb and install as above if you want to try it.
 


Latest posts

Top