[Solved] What's this.

The Duck

Well-Known Member
Joined
Jun 3, 2023
Messages
565
Reaction score
625
Credits
4,027
I ran this command.

Code:
systemctl -a status

Here's the output.
Is this something I should be concerned about.

Code:
linuxmint@linuxmint:~$ systemctl -a status
● linuxmint
    State: degraded
     Jobs: 0 queued
   Failed: 1 units
    Since: Wed 2024-03-06 13:07:20 CST; 20min ago
   CGroup: /
           ├─sys-fs-fuse-connections.mount
           ├─sys-kernel-config.mount
           ├─sys-kernel-debug.mount
           ├─dev-mqueue.mount
           ├─user.slice
           │ └─user-1000.slice
           │   ├─[email protected]
           │   │ ├─session.slice
           │   │ │ ├─xdg-document-portal.service
           │   │ │ │ ├─2293 /usr/libexec/xdg-document-portal
           │   │ │ │ └─2302 fusermount3 -o rw,nosuid,nodev,fsname=portal,auto_unmount,subtype=portal -- /run/user/1000/doc
           │   │ │ ├─xdg-desktop-portal.service
           │   │ │ │ └─2289 /usr/libexec/xdg-desktop-portal
           │   │ │ ├─pulseaudio.service
           │   │ │ │ └─988 /usr/bin/pulseaudio --daemonize=no --log-target=journal
           │   │ │ └─pipewire.service
           │   │ │   └─987 /usr/bin/pipewire
           │   │ ├─app.slice
           │   │ │ ├─gvfs-goa-volume-monitor.service
           │   │ │ │ └─1439 /usr/libexec/gvfs-goa-volume-monitor
           │   │ │ ├─xdg-permission-store.service
           │   │ │ │ └─2296 /usr/libexec/xdg-permission-store
           │   │ │ ├─dconf.service
           │   │ │ │ └─2752 /usr/libexec/dconf-service
           │   │ │ ├─gvfs-daemon.service
           │   │ │ │ ├─1216 /usr/libexec/gvfsd
           │   │ │ │ ├─1222 /usr/libexec/gvfsd-fuse /run/user/1000/gvfs -f
           │   │ │ │ └─1470 /usr/libexec/gvfsd-trash --spawner :1.9 /org/gtk/gvfs/exec_spaw/0
           │   │ │ ├─dbus.socket
           │   │ │ ├─gvfs-udisks2-volume-monitor.service
           │   │ │ │ └─1428 /usr/libexec/gvfs-udisks2-volume-monitor
           │   │ │ ├─xfce4-notifyd.service
           │   │ │ │ └─1332 /usr/lib/x86_64-linux-gnu/xfce4/notifyd/xfce4-notifyd
           │   │ │ ├─gpg-agent.service
           │   │ │ │ └─1257 /usr/bin/gpg-agent --supervised
           │   │ │ ├─gvfs-gphoto2-volume-monitor.service
           │   │ │ │ └─1445 /usr/libexec/gvfs-gphoto2-volume-monitor
           │   │ │ ├─xdg-desktop-portal-gtk.service
lines 1-44
 
Last edited:


I believe this is where the problem was created when I applied this tweak from this link.

Remove the option 'save session' from the logout window​

2.5. In the logout dialog, you can enable saving the session ("Save session for future logins"). But that's generally a nuisance, especially for beginners with Linux Mint Xfce. Because all open application windows will be restarted automatically, upon each login.... So it's best not to enable this.

You can remove old sessions like this:

Menu button - System - Xfce Terminal

Type (use copy/paste):
Code:
rm -r -v ~/.cache/sessions/*

Press Enter.

Note: User setting, so repeat this in each user account.

In order to prevent mistakes, you can remove this option from the logout window for all users like this:

a. Menu button - System - Xfce Terminal

b. Create a directory with a command: type in the terminal (use copy/paste to avoid errors):
Code:
sudo mkdir -v /etc/xdg/xfce4/kiosk

Press Enter. Type your password when prompted. In Ubuntu this remains entirely invisible, not even dots will show when you type it, that's normal. In Mint this has changed: you'll see asterisks when you type. Press Enter again.

c. Now create a file with a command: type in the terminal (use copy/paste to avoid errors):
Code:
sudo touch /etc/xdg/xfce4/kiosk/kioskrc

Press Enter.

d. Then copy/paste this command into the terminal, in order to edit that new file:
Code:
xed admin:///etc/xdg/xfce4/kiosk/kioskrc

In that empty text document, copy/paste the following text:
Code:
[xfce4-session]
SaveSession=NONE

e. Save the modified file.

f. Reboot your computer. The option for saving the session should have disappeared from the logout screen.
 
Did you follow that advice recently?....do you have a Timeshift snapshot you can roll back to ?

I dont think it is a big concern...if it was you probably wouldn't be able to boot
 
Try running:

Code:
systemctl --failed
 
Here's the out put of
Code:
 systemctl --failed

Code:
linuxmint@linuxmint:~$ systemctl --failed
  UNIT                    LOAD   ACTIVE SUB    DESCRIPTION                            
● casper-md5check.service loaded failed failed casper-md5check Verify Live ISO checksums

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.
1 loaded units listed.
linuxmint@linuxmint:~$

No Timeshift Snapshot I have just installed Linux Mint 21

Thanks
 
Okay went to the Linux Mint forum and found this.


Seemed to do the trick.

Code:
linuxmint@linuxmint:~$ systemctl -a status
● linuxmint
    State: running
     Jobs: 0 queued
   Failed: 0 units
    Since: Wed 2024-03-06 17:30:15 CST; 2min 44s ago
   CGroup: /
           ├─sys-fs-fuse-connections.mount 
           ├─sys-kernel-config.mount 
linuxmint@linuxmint:~$ systemctl -a status
● linuxmint
    State: running
     Jobs: 0 queued
   Failed: 0 units
    Since: Wed 2024-03-06 17:30:15 CST; 2min 44s ago
   CGroup: /
           ├─sys-fs-fuse-connections.mount 
           ├─sys-kernel-config.mount 
           ├─sys-kernel-debug.mount 
           ├─dev-mqueue.mount 
           ├─user.slice 
           │ └─user-1000.slice 
           │   ├─[email protected] 
           │   │ ├─session.slice 
           │   │ │ ├─xdg-document-portal.service 
           │   │ │ │ ├─1595 /usr/libexec/xdg-document-portal
           │   │ │ │ └─1604 fusermount3 -o rw,nosuid,nodev,fsname=portal,auto_unmount,subtype=portal -- /run/user/1000/doc
           │   │ │ ├─xdg-desktop-portal.service 
           │   │ │ │ └─1591 /usr/libexec/xdg-desktop-portal
           │   │ │ ├─pulseaudio.service 
           │   │ │ │ └─1044 /usr/bin/pulseaudio --daemonize=no --log-target=journal
           │   │ │ └─pipewire.service 
           │   │ │   └─1043 /usr/bin/pipewire
           │   │ ├─app.slice 
           │   │ │ ├─gvfs-goa-volume-monitor.service 
           │   │ │ │ └─1493 /usr/libexec/gvfs-goa-volume-monitor
           │   │ │ ├─xdg-permission-store.service 
           │   │ │ │ └─1598 /usr/libexec/xdg-permission-store
           │   │ │ ├─gvfs-daemon.service 
           │   │ │ │ ├─1272 /usr/libexec/gvfsd
           │   │ │ │ ├─1278 /usr/libexec/gvfsd-fuse /run/user/1000/gvfs -f
           │   │ │ │ └─1525 /usr/libexec/gvfsd-trash --spawner :1.9 /org/gtk/gvfs/exec_spaw/0
           │   │ │ ├─dbus.socket 
           │   │ │ ├─gvfs-udisks2-volume-monitor.service 
           │   │ │ │ └─1483 /usr/libexec/gvfs-udisks2-volume-monitor
           │   │ │ ├─xfce4-notifyd.service 
           │   │ │ │ └─1388 /usr/lib/x86_64-linux-gnu/xfce4/notifyd/xfce4-notifyd
           │   │ │ ├─gpg-agent.service 
lines 1-38


           ├─sys-kernel-debug.mount 
           ├─dev-mqueue.mount 
           ├─user.slice 
           │ └─user-1000.slice 
           │   ├─[email protected] 
           │   │ ├─session.slice 
           │   │ │ ├─xdg-document-portal.service 
           │   │ │ │ ├─1595 /usr/libexec/xdg-document-portal
           │   │ │ │ └─1604 fusermount3 -o rw,nosuid,nodev,fsname=portal,auto_unmount,subtype=portal -- /run/user/1000/doc
           │   │ │ ├─xdg-desktop-portal.service 
           │   │ │ │ └─1591 /usr/libexec/xdg-desktop-portal
           │   │ │ ├─pulseaudio.service 
           │   │ │ │ └─1044 /usr/bin/pulseaudio --daemonize=no --log-target=journal
           │   │ │ └─pipewire.service 
           │   │ │   └─1043 /usr/bin/pipewire
           │   │ ├─app.slice 
           │   │ │ ├─gvfs-goa-volume-monitor.service 
           │   │ │ │ └─1493 /usr/libexec/gvfs-goa-volume-monitor
           │   │ │ ├─xdg-permission-store.service 
           │   │ │ │ └─1598 /usr/libexec/xdg-permission-store
           │   │ │ ├─gvfs-daemon.service 
           │   │ │ │ ├─1272 /usr/libexec/gvfsd
           │   │ │ │ ├─1278 /usr/libexec/gvfsd-fuse /run/user/1000/gvfs -f
           │   │ │ │ └─1525 /usr/libexec/gvfsd-trash --spawner :1.9 /org/gtk/gvfs/exec_spaw/0
           │   │ │ ├─dbus.socket 
           │   │ │ ├─gvfs-udisks2-volume-monitor.service 
           │   │ │ │ └─1483 /usr/libexec/gvfs-udisks2-volume-monitor
           │   │ │ ├─xfce4-notifyd.service 
           │   │ │ │ └─1388 /usr/lib/x86_64-linux-gnu/xfce4/notifyd/xfce4-notifyd
           │   │ │ ├─gpg-agent.service 
lines 1-38


@Condobloke Thanks for your help.
 
Run this command to disable the md5check for Live Disk check.
sudo systemctl disable casper-md5check.service

And to verify Live Disk in the future Run this command:
sudo systemctl enable casper-md5check.service

jpresario@Dragon-Terminal:~$ sudo systemctl enable casper-md5check.service
Created symlink /etc/systemd/system/multi-user.target.wants/casper-md5check.service → /lib/systemd/system/casper-md5check.service.
jpresario@Dragon-Terminal:~$ sudo systemctl disable casper-md5check.service
Removed /etc/systemd/system/multi-user.target.wants/casper-md5check.service.
jpresario@Dragon-Terminal:~$
 


Top