[Solved] Making iso file from DVD

Goss

New Member
hey,
i have some system on DVD, which i want to make iso from,

i found code on
https://www.thomas-krenn.com/en/wiki/Create_an_ISO_Image_from_a_source_CD_or_DVD_under_Linux

2 step implementation gives
Code:
check size:
# isoinfo -d -i /dev/cdrom | grep -i -E 'block size|volume size'

create iso:
# dd if=/dev/cdrom of=/path/to/test.iso bs=<block size from above> count=<volume size from above> status=progress
so i created iso, which have size of 2 GB when check properties,
but whem im opening with Archive Menager, it is empty beside folder '.' which is 0 bytes.

What i am missing
 
Last edited:


dos2unix

Member
in dd, the "bs" option isn;t necessarily the size of your image file. It is the size of cache of memory that it copies the file in.
For example bs=4M will copy your image in 4meg chunks and opposed to 64k chunks. (less going back and forth)

The other things I don't see here here is... Where is your output file?

The base syntax for dd (with no flag options) is like this.... dd if=(input file system) of=(output file system)
For example... dd if=fedora-30-server-x86-64.iso of=/dev/sdc bs=512M
Will write an iso image to my usb drive. The image isn't 512meg in size (it's bigger) but I'm using that much memory caching to copy the image.
 

Goss

New Member
There I've pasted command from website,
I've edited it, so of=/path/to.iso

Anyways, in my /home/user folder there is the ISO file, but when open by archive in GNU, there is nothing but '.'
 

Jarret B

Active Member
Staff member

Goss

New Member
Ok Jarret,
this time it went much better,
Code:
sudo apt install brasero -y
with Brasero, 2 GB is 2GB

there is a thing though, that directory inside .iso file is /./files and should be just /files,
where does it coming from?

EDIT : it works, when you mount this file, it looks proper
 
Last edited:

Jarret B

Active Member
Staff member
I believe part of that is the file itself. Once mounted it is fine. When you "burn" the image to a disc or device the "file" part is removed and the extra '/.' is not seen.
 

Members online


Top