Purchase Linux CDs / DVDs / Flash Drives at OSDisc.com

Welcome to Our Community

While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd, 2017 please sign up again. Thanks!

Screen resolution

Discussion in 'Desktop / X' started by Jef_UK, May 3, 2016.

  1. Jef_UK

    Jef_UK Guest

    Hello group.
    Complex problem; I'm out of ideas; If anything is unclear let me know I'll try to clarify that part.


    Problem summery
    I'm trying to get a 'ATI' gpu to work; I have two problems.
    1. When PXE booting a Debian OS the driver/firmware does not load.
    2. to test to see if I can get the device to work by installing on a hard drive I'm limited to low resolutions and unable to change them.
    OS used is Jessie, GPU is ATI x1950pro.

    Background
    I'm trying to build a thin client similar to some of the HP ones that are on ebay. I have a working server running X2go, Working DHCP/PXE/TFTP/NFS server that I can boot from over the network.

    Problem Details
    I've tried to follow instructions to add the:
    Code:
    apt-get install firmware-linux-nonfree libgl1-mesa-dri xserver-xorg-video-ati xserver-xorg-video-radeon 
    to the chroot Linux that's used to PXE boot; I've done this with the "x2go client shell" and chroot specified commands; but get errors in dmesg On the thin client about:
    xrandr lists some gamma error when run

    and if I remove 'nomodeset' from the boot file issued by PXE/TFTP it starts with no xserver/xorg;
    startx fails with:
    What have I tried?

    To simplify matters I dug out an IDE hard drive and a (three) CD-ROMs to install local not Read-Only copy to check if I can get things working. trying to fix the chroot reboot and wait 20 minutes was not working.

    So...
    After installing the OS and updating sources.list I have:
    Code:
    apt-get install firmware-linux-nonfree libgl1-mesa-dri xserver-xorg-video-ati xserver-xorg-video-radeon 
    now on reboot the hardware is Identified and seems to load the correct module:
    Code:
    [email protected]:~# dmesg | grep 'drm'
    [  9.889082] [drm] Initialized drm 1.1.0 20060810
    [  10.762930] [drm] radeon kernel modesetting enabled.
    [  10.763758] [drm] initializing kernel modesetting (RV570 0x1002:0x7280 0x174B:0xE190).
    [  10.763789] [drm] register mmio base: 0xE9000000
    [  10.763791] [drm] register mmio size: 65536
    [  10.765584] [drm] Generation 2 PCI interface, using max accessible memory
    [  10.765620] [drm] Detected VRAM RAM=512M, BAR=256M
    [  10.765622] [drm] RAM width 256bits DDR
    [  10.765794] [drm] radeon: 512M of VRAM memory ready
    [  10.765797] [drm] radeon: 128M of GTT memory ready.
    [  10.765824] [drm] GART: num cpu pages 32768, num gpu pages 32768
    [  10.766504] [drm] Possible lm63 thermal controller at 0x4c
    [  10.780013] [drm] radeon: 3 quad pipes, 1 z pipes initialized.
    [  10.783532] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
    [  10.783534] [drm] Driver supports precise vblank timestamp query.
    [  10.783593] [drm] radeon: irq initialized.
    [  10.783625] [drm] Loading R500 Microcode
    [  10.920787] [drm] radeon: ring at 0x00000000E0001000
    [  10.920817] [drm] ring test succeeded in 0 usecs
    [  10.921039] [drm] ib test succeeded in 0 usecs
    [  10.922053] [drm] Radeon Display Connectors
    [  10.922057] [drm] Connector 0:
    [  10.922059] [drm]  DVI-I-1
    [  10.922060] [drm]  HPD2
    [  10.922064] [drm]  DDC: 0x7e40 0x7e40 0x7e44 0x7e44 0x7e48 0x7e48 0x7e4c 0x7e4c
    [  10.922065] [drm]  Encoders:
    [  10.922067] [drm]  CRT1: INTERNAL_KLDSCP_DAC1
    [  10.922070] [drm]  DFP3: INTERNAL_LVTM1
    [  10.922072] [drm] Connector 1:
    [  10.922073] [drm]  SVIDEO-1
    [  10.922075] [drm]  Encoders:
    [  10.922076] [drm]  TV1: INTERNAL_KLDSCP_DAC2
    [  10.922078] [drm] Connector 2:
    [  10.922079] [drm]  DVI-I-2
    [  10.922081] [drm]  HPD1
    [  10.922083] [drm]  DDC: 0x7e50 0x7e50 0x7e54 0x7e54 0x7e58 0x7e58 0x7e5c 0x7e5c
    [  10.922085] [drm]  Encoders:
    [  10.922087] [drm]  CRT2: INTERNAL_KLDSCP_DAC2
    [  10.922088] [drm]  DFP1: INTERNAL_KLDSCP_TMDS1
    [  11.014142] [drm] fb mappable at 0xD0060000
    [  11.014151] [drm] vram apper at 0xD0000000
    [  11.014153] [drm] size 3145728
    [  11.014155] [drm] fb depth is 24
    [  11.014156] [drm]  pitch is 4096
    [  11.014480] fbcon: radeondrmfb (fb0) is primary device
    [  11.082739] radeon 0000:01:00.0: fb0: radeondrmfb frame buffer device
    [  11.082758] [drm] Initialized radeon 2.39.0 20080528 for 0000:01:00.0 on minor 0
    
    
    So hardware works OK. But before I start trying to reproduce on the chroot for the TCE lets check usability...

    xrandr lists:
    Code:
    Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
    DVI-0 disconnected (normal left inverted right x axis y axis)
    S-video disconnected (normal left inverted right x axis y axis)
    DVI-1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
      1024x768  60.00*
      800x600  60.32  56.25
      848x480  60.00
      640x480  59.94
    
    So resolution
    Code:
    cvt 1920 1200
    # 1920x1200 59.88 Hz (CVT 2.30MA) hsync: 74.56 kHz; pclk: 193.25 MHz
    Modeline "1920x1200_60.00"  193.25  1920 2056 2256 2592  1200 1203 1209 1245 -hsync +vsync
    
    and
    Code:
    xrandr --newmode "1920x1200_60.00"  193.25  1920 2056 2256 2592  1200 1203 1209 1245 -hsync +vsync
    
    But the mode does not stay after reboot and I cannot switch to it.

    dpkg-reconfigure xserver-xorg seems to do nothing.
    these are the files in




    If I need to get any logs from the local install of the TCE I can post them up. Just let me know


    Thanks
     
  2. Mitt Green

    Mitt Green Guest

    Hey,

    Try to put this xrandr line in .xinitrc:
    Code:
    xrandr --newmode "1920x1200_60.00" 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync
    and see what happens.
     
    1 person likes this.
  3. Jef_UK

    Jef_UK Guest

    Thanks.
    I've added this to /etc/xdg/xfce4/xinitrc
    Code:
    xrandr --newmode "1920x1200_60.00" 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync && sleep 5 && xrandr --addmode DVI-1 1920x1200_60.00 && sleep 1 && xrandrr --output DVI-1 --mode 1920x1200_60.00 &
    
    And after a few screen blanks and redraws it is working after login. Not at login screen but after is OK.

    So that proves that the hardware can work. tomorrow I'll try getting the driver to load again from the pxe boot.
    However the PXE environment does not run XFCE so I'll have to try some place else.

    Thanks again.
     
  4. Jef_UK

    Jef_UK Guest

    All working.
    Early on when trying to setup the resolution I had made a 10-monitor.conf file of xorg-conf.d

    That was preventing xserver from starting so I removed it from the chroot and the gui instantly loaded.

    Now I had the driver loaded and a GUI and know the above randr works so i added this command to:
    /opt/x2gothinclient/etc/x2gothinclient_start
    my final start file is as follows
    Code:
    /usr/bin/x2goclient --no-menu \
      --maximize \
      --link=lan \
      --kbd-type=auto \
      --set-kbd=1 \
      --geometry=fullscreen \
      --thinclient \
      --haltbt \
      --read-exports-from=~/export \
      --background=/etc/x2go/x2goclient-background.svg \
      --no-session-edit \
      --session="TS1" \
      --add-to-known-hosts & sleep 1 && xrandr --newmode "1920x1200_60.00" 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync && sleep 1 && xrandr --addmode DVI-1 1920x1200_60.00 && xrandr --output DVI-1 --mode 1920x1200_60.00 &
    
    Thanks for the inspiration!
     

Share This Page