Solved PFsense/OPNsense DNS issue ..

Solved issue

truckerDave

Active Member
Joined
Oct 7, 2023
Messages
132
Reaction score
106
Credits
1,141
I set up a small (actually tiny) PC to act as a firewall and installed OPNsense. I then adjusted the IP address on my Mint PC and connected it to the LAN port. All was good.

I was able to access the OPNsense web UI and had access to the internet on my Mint PC. After a look around in the web UI to familiarize myself, I decided to use the web UI to check for updates. There were updates available and I went ahead and applied them.

After the update, I am no longer able to access the internet from my Mint PC. I get an error in the browser stating, something to the effect, DNS not found. I'm not anywhere near home so I can't relay exactly what it said.

After a bunch of searching and head scratching, it occurred to me that my PC is set to use Quad9's DNS servers. Could this be causing an issue? If I were home, I'd remove it and know. But I'm not home and it's bugging the crap out of me.

(Made it home early and replaced OPNsense with pfSense. No immediate change.)
 
Last edited:


Nope. The above was not the issue.

Messed around with this, that and the other all evening. Reset to factory defaults (as if pfSense was built in a factory :rolleyes:), shut it all down and went to bed.

Got up this morning and, still having no idea what is/was causing the issue, (on pfSense) I'm able to access the internet AND the pfSense web UI.

I'm sure that won't last long :cool:

If one of the moderators comes along, feel free to delete this thread. I can't see how it would benefit anyone. I have no idea what, if anything, I did to resolve the issue. I must have reset both OPNsense and pfSense 10 times each and never was able to reach the internet from my client machine. Well, until now. I guess a Linux gremlin moved in over night and fixed it for me.
 
Last edited:
Next time your Mint pc seems to not have internet access, from your Mint pc just ping an external dns server(ie: 9.9.9.9) and see if you get a reply. If you get a reply then the problem is the dns running on OPNsense or whatever dns server your Mint installation is using whether that be one manually configured or one configured through dhcp. If you don't get a reply from the ip of the external dns server, then also ping your local gateway and see if you get a reply, if you don't get a reply from you local gateway then you won't have a connection to the internet. But better to do it reverse, ping local gateway and see if you get a reaction, if you get a reaction then ping the external dns server's ip, that way if the first one fails you won't need to do the second one because if the first one fails you will already know that you won't have internet access. Unless your setup differs a bit(ie if you are using a switch or other networking devices), but then you can still apply the same but maybe in a different order.
 
Last edited:
lol! Not sure what you mean with that? What were the results?
 
lol! Not sure what you mean with that? What were the results?
I could ping anything with the firewall. And nothing with the client. However, I do believe it was resolved, at least for now, by setting the IP on the client to "Auto". Even though the pfSense box is using 192.168.1.* and having a static IP on the client of 192.168.1.100, I was not able to get through. I'm sure it's a simple setting somewhere. But I'm still learning my way through this.

More than likely, I was doing something wrong in setting the static IP address.
 

Members online


Latest posts

Top