• We did not send an email asking for donations - please read this post.

openSUSE Qt5: QtWidgets: No Such File Or Directory.....? :3

blackneos940

Active Member
Joined
May 16, 2017
Messages
332
Reaction score
195
Credits
205
Hello everyone!..... ^^ I had ungodly amounts of Mountain Dew today, and I decided to take a crack at compiling JasKinasis' Qt Programs under openSUSE, which I just installed last night..... :) What Package/step am I missing.....? :< I tried: qmake -project; qmake; make; , and I even did EXACTLY what Jas said to do in his tutorial, just to be sure I got it right..... :\ Neither process (pun intended :)) worked, so here I am..... :) Any ideas, guys.....? :3 It works under Lubuntu..... :3 Thank you SO much for any help..... :3 I really appreciate it..... :)
 


wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
7,778
Reaction score
6,603
Credits
28,596
Hiya Blackie :p

I haven't read through Jas's Tute yet, but if we slip in an @JasKinasis it might draw his attention here :D

Do you have any output from errors, and/or screenshots you can show us?

I don't have an OpenSUSE on board at the moment, but that is RPM-based, where Jas works mostly from a Debian environment, I do not know if that has any bearing on it.

We'll see what he says, but if you can get that stuff together that would be cool.

Chris Turner
wizardfromoz
 

JasKinasis

Well-Known Member
Joined
Apr 25, 2017
Messages
1,562
Reaction score
2,224
Credits
11,517
From the looks of it, you are probably missing some of the QT development libraries.

I haven't used any RPM based distros for a number of years now, so offhand - I don't know what QT5 development packages are available for Suse.

You'll need whichever one provides the QTWidgets library.

I'm glad you got the tutorial code working on Lubuntu though!
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top