openbox - disable window move to another desktop workspace

t3kg33k

New Member
Joined
Oct 7, 2022
Messages
11
Reaction score
4
Credits
127
I'm hoping someone here (smarter than me) can help with Openbox and changing the default in rc.xml to disable the movement of windows from one desktop to another.
If you are not aware, there is a default that when you select a window titlebar (cursor changes to hand) you can select the keyboard shortcut of Superkey+F2, or F3, or back to F1 (depending on how many desktops are configured) and the window will move to that desktop. I want to disable this.
I've been playing around with a few settings by referencing their documentation but so far I haven't found a solution. I have very little experience with editing xml so there's that challenge also. My assumption that changing the mousebind Titlebar section may be the key (maybe adding an 'if...then' statement?), but I could be wrong.
Any assistance in solving this problem would be greatly appreciated.

Edit: I forgot to mention that there is a requirement to keep those Superkey shortcuts enabled. Just disabling the window movement from one desktop to another is what is required.
 
Last edited:

Members online

No members online now.

Top