no screens error trying to boot Linux Mint 18 on iMac Pro

Kh694

New Member
Hi, I am trying to dual boot Linux Mint 18.1 Cinnamon on my iMac Pro (2017). I have a bootable usb that loads perfectly normally from my Mid-2013 MacBook Air, but when I try it on my mac, I get to the first boot menu and if I choose:

- Start Linux -> all I can get is a black screen

- Start Linux (Compatibility mode) -> I get a black screen or a login prompt, I can login with usr mint,
no password. From here, I have tried editing the xconf files, but this doesn’t seem to save between boots and doesn’t seem to help anyway. I also don’t seem to be able to connect to the internet to update to a useful AMD driver like I have seen suggested in some forums .... I also get a blue screen and error from xorg that no screens are available

- OEM -> also black


I have tried editing the Start Linux and Start Linux compatibility with "nomodeset" and "radeon.modeset=0" to no avail


Is there anything more I can do? Am I in a driver black hole?


Thanks
 


rhmcbride

New Member
I wish I had an answer right away but I think the problem involves the graphics on IMac Pro Retina.
Your older MAC had simplier graphics and probably uses more standard drivers.
My 2015 Retina MacBook pro often has graphics chokes when I boot up linux but the older MACs that I have run Linux without complaints. What about older versions of Mint do these work?
 

Kh694

New Member
Hi Bob,

I have tried Linux Mint 17, 18.1, 18.3, 19.2 ... Ubuntu 18.04 and 16.04 all with the same black screen.

Is there a version you think would be best to try?
 

rhmcbride

New Member
I am sorry to report that you have done everything that I would have tried to fix the problem.
You may well be in a driver black hole as you feared.
Have you tried any of the Debian or Fedora based distros?
 

Cerebroside

New Member
I have the same problem, also on an iMac Pro 2017 with Radeon Pro Vega 64. I tried to run Ubuntu 19.10 from an external usb ssd but I also got the black screen after the boot menu. If anyone has an idea it would be much appreciated.
 
Last edited:
  • Like
Reactions: Puq

Condobloke

Well-Known Member

Condobloke

Well-Known Member
New thread please
 

Kh694

New Member
Thank you, I just thought I post it under this thread because I have the same problem on a similar system. I edited my posting to make it more clear. Or is it still better to open a new thread? (I'm new here)
Please tag me if you get a solution working... I really need to get some kind of dual boot on the same system and am taking any suggestions at this point
 



Members online


Latest posts


Top