Network Connection not possible after disconnecting from OpenVPN

tinfoil-hat

Active Member
Joined
Oct 24, 2021
Messages
349
Reaction score
173
Credits
2,418
Hi, I am using Linux Mint Cinnamon and use it's Network-Manager (I beleve it's the gnome-network-manager). I can successfully connect to the VPN. But when I disconnect from my OpenVPN, a popup message appears: "Network Interface has no connection" yadayada. Disabling the Network and enabling it again, doesn't fix the problem. However manually running following works as expected:

sudo openvpn /path/to/server.ovpn

Happy to hear from you

- tinfoil-hat
 


I am fairly sure openvpn uses Firewall ip-tables as part of its secure approach. In other words, it inserts a set of firewall rules when the vpn is running.

I use Airvpn. The two are very similar, in that they both use firewall tables.

I also experienced a few minor glitches in this area......I found that the default Firewall did not switch itself back to normal mode when I had disconnected the vpn

So, I now use Firewalld <<<....note the d ....I use this as my firewall. It remains turned ON, indefinitely.

The default Linux firewall (ufw) stays turned OFF ......When the vpn is activated, it automatically uses the firewall tables associated with the ufw firewall. It does not have to be turned on for the vpn to use it.

This solved any dramas I was having with airvpn and I think it will solve yours too.

Firewalld is available in the Software Manager in Linux Mint Cinnamon

(menu...type in software manager...search for firewalld....install)

You can check to make sure it running with

Code:
firewall-cmd --state

It will answer with one word...... running.

1677284613842.png


I have found it to be absolutely reliable. 10/10

I let it run with its default settings.
 
zsh: command not found: firewall-cmd
and UFW status is Inactive
 
>if you reboot after disconnecting from the vpn
I thought, I had mentioned it in OP. When I reboot everything is fine again. But it su**s that I always have to reboot
 
It would be a good idea to have a firewall running

ufw: (uncomplicated firewall)

Code:
sudo ufw enable

To check that it is running...

Code:
sudo ufw status verbose

Firewalld ...as described above in post#2....install from software manager
 
It would be a good idea to have a firewall running

ufw: (uncomplicated firewall)

Code:
sudo ufw enable

To check that it is running...

Code:
sudo ufw status verbose

Firewalld ...as described above in post#2....install from software manager
Why should i run a firewall in my Homenetwork, with only me in the network, on a desktop, behind a NAT Router with no open ports? :D
 
Why should i run a firewall in my Homenetwork, with only me in the network, on a desktop, behind a NAT Router with no open ports? :D
Because say there's a vulnerability in your router's firmware that allows someone to access your lan. They will then do a scan on your lan and see what devices are active and try to see how far they can get, if you have no firewall on your system it's just makes it less hard to for trying to get into your system that has files that you would not rather get stolen or encrypted by someone else. Or if another device on your lan has a remote execution vulnerability they can then use that system to access your lan to see what they can find and get to on your home lan, a firewall is another layer of protection and just makes it more difficult instead of making it less difficult when not running a firewall. I know it may sound extreme or exaggerated but there are good reasons to run a firewall.

If I were to guess what the problem could of your OP, it would be that after disconnecting from your vpn the dns server of your vpn provider stays active. I would try running this from the command-line and then replacing "wireless" with the name of your lan's wifi connection.
Code:
nmcli connection wireless up
 
Last edited:

Members online


Top