netplan "renderer NetworkManager" = could not resolve 'ca.archive.ubuntu.com'

jeremyy44

Member
Joined
Jan 20, 2021
Messages
44
Reaction score
8
Credits
411
Hi so today I stumbled upon a problem.
When adding the line "renderer NetworkManager" to my netplan .yaml I get a could not resolve error when trying to do a apt update.

My .yaml looks like
---------------------------------
network:
ethernets:
enp9s0:
addresses:
- 192.168.2.10/24
gateway4: 192.168.2.1
nameservers:
addresses:
- 8.8.8.8
- 8.8.4.4
version: 2
renderer: NetworkManager
---------------------------------

I need to add this line because I use cockpit a lot to manage my server and it requires it for me to be able to manage my network interfaces through the web gui.
 


Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
984
Reaction score
637
Credits
7,299
there should be 2 files under /etc/netplan/
1) 01-netcfg.yaml
2) 01-network-manager-all.yaml
open network-manager-all it should look like

# Let NetworkManager manage all devices on this system
network:
version: 2
renderer: NetworkManager

Also what version of Linux are you running the above is for Buntu based OS
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!


Latest posts

Top