mint 21.2 upgrade affected power management

z7vl7abxc

Well-Known Member
Joined
Jun 17, 2023
Messages
500
Reaction score
394
Credits
4,033
i installed mint 21.1 xfce on this system a few of months ago. i didn't have any issues with power management until the upgrade to 21.2 a little over a week ago. i have the screen set to switch off after 1 minute, but every now and again since that 21.2 upgrade it wakes itself up. i found the following messages with dbus-monitor that seem to indicate MintUpdate inhibits power management when it runs so i thought i would post and see if anyone could think of a way to try and troubleshoot. i do have a timeshift snapshot i could roll back to. i just wanted to see if there was a different way to possibly fix the issue since it's not particularly disruptive.

i see these messages just after the screen wakes up:
Code:
dbus-monitor | grep -iA2 inhibit
method call time=1691018051.214586 sender=:1.68 -> destination=org.freedesktop.PowerManagement serial=50 path=/org/freedesktop/PowerManagement/Inhibit; interface=org.freedesktop.PowerManagement.Inhibit; member=Inhibit
   string "MintUpdate"
   string "Refreshing available updates"
method call time=1691018051.215084 sender=:1.55 -> destination=:1.54 serial=158 path=/org/freedesktop/ScreenSaver; interface=org.freedesktop.ScreenSaver; member=Inhibit
   string "libxfce4ui"
   string "Inhibit requested"
method return time=1691018051.215222 sender=:1.54 -> destination=:1.55 serial=119 reply_serial=158
   uint32 8

these show up not too long after when it looks like the update process has finished:
Code:
method call time=1691018070.246881 sender=:1.68 -> destination=org.freedesktop.PowerManagement serial=54 path=/org/freedesktop/PowerManagement/Inhibit; interface=org.freedesktop.PowerManagement.Inhibit; member=UnInhibit
   uint32 35
method call time=1691018070.247326 sender=:1.55 -> destination=:1.54 serial=160 path=/org/freedesktop/ScreenSaver; interface=org.freedesktop.ScreenSaver; member=UnInhibit
   uint32 8
method return time=1691018070.247470 sender=:1.54 -> destination=:1.55 serial=123 reply_serial=160

some info about those names (1.54 and 1.55) from busctl:
Code:
:1.54      2724 xfce4-session   <user>             :1.54         session-c2.scope      
:1.55      3000 xfsettingsd     <user>             :1.55         session-c2.scope
 


I am not familiar with xfce, so I have to ask....when you click on menu and type in screensaver....what do you get?

In cinnamon i get...
1691024160865.png

1691024211996.png


same/similar on xfce ?
 
these show up not too long after when it looks like the update process has finished:
Are you saying it wakes up to do updates?
If so just toggle off the "refresh updates automatically"
That should fix it. Just make sure you check for updates manually
Screenshot from 2023-08-02 19-59-55.png
 
thank you both for your help and suggestions.

one of the options i have seen used with xfce is light locker. if i search for "screensaver" in the menu, light locker is the program that is listed. these are the light locker and power manager settings:
Screenshot_2023-08-02_19-59-32.png
Screenshot_2023-08-02_19-59-41.png

Are you saying it wakes up to do updates?
the system isn't suspended, the screen just switches off. it comes back on when updating. i could try switching off the automatic updates and may give that a go if i can't find a way to work it out otherwise.

previously automatic updates worked just fine without waking up the screen. they still work fine on mint 20.3 xfce.
 
i could try switching off the automatic updates and may give that a go if i can't find a way to work it out otherwise
last ditch effort, but I'm pretty sure you'll be good to go. ;)
 
have you experimented with the settings in Power Manager...?

eg. you said you have it set to sleep after 1 minute....does shifting the 'blank after' slider affect it at all?

etc



1691025725027.png
 
that's a good idea. i changed the switch off after setting to a few different numbers to see if maybe that would help. i had trouble with blank after leaving the backlight on with a different system so i stopped using it. i will try some settings with the first two options and see if they help. thanks.
 
all three power power management settings (blank after, put to sleep after and switch off after) seem to work as intended by turning off the display. unfortunately after trying various combinations of the three and each separately, the screen still turns back on for updates.

i did go ahead and switch off "Refresh the list of updates automatically" in Update Manager's Preferences as suggested to see if that makes a difference.
 
i did go ahead and switch off "Refresh the list of updates automatically" in Update Manager's Preferences as suggested to see if that makes a difference.
LMK, so I can tuck that away in case it ever happens to me.
I'm in the middle or resurrecting a laptop from 2010. 64bit Intel core i3 that so far refuses to boot 64 bit OSes. Trying a few more now.
 
will do. so far mint xfce has been fairly solid and even this is only a minor quirk that i would like to solve without rolling back if possible.

I'm in the middle or resurrecting a laptop from 2010. 64bit Intel core i3 that so far refuses to boot 64 bit OSes. Trying a few more now.
back when i was hanging out on reddit, from time to time someone would mention that older 64-bit systems could possibly have a 32-bit uefi implementation that would make regular installs a chore. i don't know it that was the same time frame (2010) or not, but thought i would mention it just in case.
 
back when i was hanging out on reddit, from time to time someone would mention that older 64-bit systems could possibly have a 32-bit uefi implementation that would make regular installs a chore. i don't know it that was the same time frame (2010) or not, but thought i would mention it just in case.
Frig!! I'll bet that's why I've been banging my head. Not one 64bit OS would install except Windoze. I'm not using this with only 4Gb ram, which is what a 32bit OS will support. Off to the trash heap it is!
Thanks for the heads up! ;)
 
LMK, so I can tuck that away in case it ever happens to me.
a couple of days later and i haven't seen any more spontaneous wakeups or inhibit messages when monitoring dbus messages (until i ran a manual update && upgrade) so i would say that worked.

now that i have a somewhat workaround, i'll probably do the rollback some time this week to see if there was some issue with the upgrade that gets solved by doing it over. thank you both again for adding your thoughts and suggestions.
 


Top