Making movies sound with equal levels all the time

rado84

Active Member
For quite some time I have this problem with all movies and all video players - when the characters of a movie speak, the sound is often so quiet that I can hardly hear what they say and I have to increase the sound volume. But that's bad because when the action scenes start (shootings, explosions, etc.) the volume suddenly goes up like crazy and I have to turn the volume down, otherwise it can blow my eardrums up.
So, the question is - has anyone found a solution for this?

P.S. The strange part is that if I extract the audio from the movie (using MKV Toolnix GUI) and play it in Audacious, the sound levels are equal and tolerable all the time and it doesn't matter whether I'm listening to a characters conversation or action scenes. So I'm thinking it's something in the video players that's causing it, I just can't figure it out what it is.
 


wizardfromoz

Super Moderator
Staff member
Gold Supporter
G'day @rado84 :)

Can you give us the output of

Code:
inxi -A
?

Cheers

Chris Turner
wizardfromoz
 
I think that what is described is how the audio mix is done by the movie studios
to maximize the " flash bang " impact in theaters , and I agree , it can be very irritating !
There's probably not much that can be done about that , after the fact .

Some media players ( eg. PotPlayer for Windows ) have a "normalize" function which
acts like a compressor/limiter on the audio track .

I don't know which players for GNU/Linux have that function , but a quick search should
find something suitable ( maybe as a plug-in ? ).

Note - this type of function can have unwanted consequences such as the "breathing " effect
found with some noise reduction systems for analogue audio tapes , back in the day ( eg. dbx )
 

rado84

Active Member
G'day @rado84 :)

Can you give us the output of

Code:
inxi -A
?

Cheers

Chris Turner
wizardfromoz
Code:
[email protected] ~ $ inxi -A
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel
           Card-2 NVIDIA GP107GL High Definition Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.13.0-45-generic
[email protected] ~ $

Some media players ( eg. PotPlayer for Windows ) have a "normalize" function which
acts like a compressor/limiter on the audio track .

I don't know which players for GNU/Linux have that function , but a quick search should
find something suitable ( maybe as a plug-in ? ).
I know about POT Player but it won't run in Linux bc it can't find the codecs it's looking for. As for searching plug-ins, I would have searched, if I knew what terms to enter in Google search.
At the moment I'm watching the old movies about Mad Max and they don't have this "flash bang" problem - the sound in the entire movie has the same levels, this only happens in newer movies after 2000. For instance, "Independence day" of 1996 - perfect leveled sound, no flash bang enhancements.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
G'day rado ... :)

I am not an audiophile, but I see from your inxi output you are using Alsa. Pulseaudio and pavucontrol may present better options.

The article below has no dates on it, so you may have to check its currency, but have a read

https://www.howtoforge.com/tutorial/advanced-audio-control-on-linux/

Good luck

Chris Turner
wizardfromoz
 

rado84

Active Member
In a moment of desperation long ago I tried all these things and it's still the same - every single movie whose audio codec is either DTS or AAC sounds the way I described in the first post. In addition to the not changing flash bang volume, if I set SMPlayer to use pulse audio (instead of ALSA), the quality changes and one would think I'm using cheap headphones, instead of a powerful audio system with subwoofer.
Ever since I opened this topic I updated SMPlayer to the latest possible version for my distro and for the moment there seems to be some improvement, though not 100% as I would like. Now the sudden changes in the action scenes volume appear to happen only if I set SMPlayer's sound volume at levels higher than 50%. If I keep it at 50% or lower, it's perfect.
 

rado84

Active Member
A month later topic update: the problem was solved by installing SMPlayer 19.1.0. The previous versions must have had a bug or something bc now the sound levels in almost all movies are normal. Except for movies with AAC codec but these are rare, so it's not a big deal.
 

Members online


Top