• We had to restore from a backup today after a failed software update. Backup was from 0000 EDT and restored it at 0800 EDT so we lost about 8hrs. Today is 07/20/2024. More info here.

Latitude 3400 speaker no audio

sudo apt install firmware-sof-signed
[sudo] password for squarsquid:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package firmware-sof-signed


Weird. It counted the percentage as if installing, but then it popped up with the above.
 


Another forum recommended this, but it can't seem to find it.

sudo apt update && sudo apt install firmware-sof-signed
Hit:1 http://us.archive.ubuntu.com/ubuntu focal InRelease
Hit:2 http://ppa.launchpad.net/zorinos/apps/ubuntu focal InRelease
Get:3 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Hit:4 http://us.archive.ubuntu.com/ubuntu focal-updates InRelease
Hit:5 http://us.archive.ubuntu.com/ubuntu focal-backports InRelease
Hit:6 https://packages.zorinos.com/stable focal InRelease
Hit:7 http://ppa.launchpad.net/zorinos/drivers/ubuntu focal InRelease
Hit:8 https://packages.zorinos.com/patches focal InRelease
Hit:9 https://packages.zorinos.com/apps focal InRelease
Hit:10 https://packages.zorinos.com/drivers focal InRelease
Hit:11 http://ppa.launchpad.net/zorinos/patches/ubuntu focal InRelease
Hit:12 http://ppa.launchpad.net/zorinos/stable/ubuntu focal InRelease
Fetched 114 kB in 2s (66.0 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
102 packages can be upgraded. Run 'apt list --upgradable' to see them.
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package firmware-sof-signed
 
dmesg | grep -i sof
[ 0.509012] pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti <[email protected]>
[ 0.592555] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[ 0.592557] software IO TLB: mapped [mem 0x00000000818bb000-0x00000000858bb000] (64MB)
[ 0.853238] integrity: Loaded X.509 cert 'Microsoft Windows Production PCA 2011: a92902398e16c49778cd90f99e4f9ae17c55af53'
[ 0.853250] integrity: Loaded X.509 cert 'Microsoft Corporation UEFI CA 2011: 13adbf4309bd82709c8cd54f316ed522988a1bd4'
[ 0.853866] blacklist: Revoked X.509 cert 'Microsoft Windows PCA 2010: d14fa98a0708cef4241898e500fff3d6791d37bc'
[ 63.651627] ISO 9660 Extensions: Microsoft Joliet Level 3
[ 63.701544] ISO 9660 Extensions: Microsoft Joliet Level 3


I ran this one too.
 
sudo apt install firmware-sof-signed
[sudo] password for squarsquid:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package firmware-sof-signed


Weird. It counted the percentage as if installing, but then it popped up with the above.
It's definitely a package in ubuntu, see here: https://packages.ubuntu.com/search?...all&arch=any&keywords=firmware&searchon=names
You may need to adjust your sources.list to access the repo where it resides. It's non-free-firmware I believe.
 
now the SOF says this:

dmesg | grep -i sof
[ 0.521426] pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti <[email protected]>
[ 0.604992] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[ 0.604994] software IO TLB: mapped [mem 0x0000000081697000-0x0000000085697000] (64MB)
[ 0.872345] integrity: Loaded X.509 cert 'Microsoft Windows Production PCA 2011: a92902398e16c49778cd90f99e4f9ae17c55af53'
[ 0.872357] integrity: Loaded X.509 cert 'Microsoft Corporation UEFI CA 2011: 13adbf4309bd82709c8cd54f316ed522988a1bd4'
[ 0.872978] blacklist: Revoked X.509 cert 'Microsoft Windows PCA 2010: d14fa98a0708cef4241898e500fff3d6791d37bc'
 
aplay -l
** List of PLAYBACK Hardware Devices **
card 0: PCH [HDA Intel PCH], device 0: ALC3204 Analog [ALC3204 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
Subdevices: 1/1
Subdevice #0: subdevice #0
 
No. Just Linux. It seems like I’ve tried everything. I almost want to figure out how to reinstall windows just to see if the sound works with that lol
 
No. Just Linux. It seems like I’ve tried everything. I almost want to figure out how to reinstall windows just to see if the sound works with that lol
Very frustrating. I'm wondering if you could have a look in the pavucontrol app and check under the "Configuration" tab to see if you can change anything to direct the sound to the speakers.
 
yeah under configuration it real only had stereo vs duplex and then then 20+ outputs for HDMI, which works. Headphones work. Mic works. Tried switching OS to Zorin and run the same protocols, but nothing changes. I guess I'm going to just change paths and focus on getting my airpod pros to use as headphones. I hear it's a pain, but at this point I don't hear many options. Thanks for trying. If you have any pointers about bluetooth audio let me know. I come from an Apple environment, but it got water logged and I am definitely not going to windows, lol
 
This is not a solution I'm proposing, since something on your machine really needs to be made to work as intended, though I'm stumped at the moment on it, but, in the olden days on a desktop machine, I would run a cable from the headphone output to a set of stereo amplified speakers. That output had less power than a "line" output but the amplified speakers had enough volume to make it work. That was when cd players had headphone jacks and there was an internal cable from the sound card on the motherboard to the cd player. Long gone now.
 
This is not a solution I'm proposing, since something on your machine really needs to be made to work as intended, though I'm stumped at the moment on it, but, in the olden days on a desktop machine, I would run a cable from the headphone output to a set of stereo amplified speakers. That output had less power than a "line" output but the amplified speakers had enough volume to make it work. That was when cd players had headphone jacks and there was an internal cable from the sound card on the motherboard to the cd player. Long gone now.
It was a laptop my work provided that I never used and they never asked for, so I really can’t even attest to whether it had sound when windows was on it. I assume it did as it has a camera and mic. This weekend I might try the long process of putting windows back on it just to see.
 
G'day @tekayo and welcome to linux.org :)

Just on a chance, I have two questions for you. I presume you are using the GNOME aka Desktop version of Ubuntu, if not let me know which.

1. Under Settings - Sound you should be able to get a popup window such as below

aLLz68E.png

Where my cursor is, at Output Device, so you have anything there, and if so, what happens when you use the Test option?

2. BIOS - on Dells, usually available by pressing F2 continuously at the startup logo - I still use Dell, but a year or 3 ago my sound would go on the blink with symptoms similar to you.

I would go into the BIOS and click through Settings - General - System Information, go to the pane at right and scroll to the end, and where it had Audio Controller = , it would have "None" or similar.

I would then reset to Factory Settings or BIOS defaults and reboot and go back to BIOS and find my Realtek there.

HTH

Chris Turner
wizardfromoz
 
Hi Chris and thanks for the help. When I do a sound test, nothing happens. I am way beyond that. Headphones work. Mic works. If I plug into HDMI, that sound works. I tried going into Dell Bios, but the choices you presented were not available. This is the closest I could find.
 

Attachments

  • 2DCCC206-BC26-4170-B3C4-F5F33D809E1E.jpeg
    2DCCC206-BC26-4170-B3C4-F5F33D809E1E.jpeg
    3.4 MB · Views: 178
OK, thanks, I am out of ideas, then. :confused:

If I find anything useful, I will come back.

Good luck.
 

Members online


Top