Jack stopped working after install of libjack-dev


New Member
Oct 6, 2020
Reaction score
I had jack working ok with qjackctl on my Linux Mint (19.3), but I had to install libjack-dev to compile a program. After the install qjackctl was removed from /usr/bin
So I installed qjackctl again, but now if I want to start jack, it gives an error: Could not connect to JACK server as client
Any ideas?

Have you interrogated the logs yet?

As you have Linux Mint (debian) then
sudo tail -f /var/log/syslog
will tail the respective syslog live - then when you try and start qjackctl look for 'qjackctl' entries with approx timestamps of the fails (start up errors)
to stop the tail.
Somehow, after a reboot the error messages in qjackctl are gone, but jack is not working (no sound in Reaper). The strange thing is, when jack is started, it stalls my vidoes untill I stop jack. Something is till very wrong here. Can I somehow re-install jack?
I think you may have installed the wrong version of libjack-dev.

libJack-dev is for jack V1 and uses V1 of jackd and libjack.
So installing that may have uninstalled jack V2 - which I would imagine is what would have been installed before and is therefore what you need to be using.

So perhaps try uninstalling any jack V1 packages and make sure you have jackd2, libjack-jackd2-0 and libjack-jackd2-dev installed.
So perhaps try uninstalling any jack V1 packages and make sure you have jackd2, libjack-jackd2-0 and libjack-jackd2-dev installed.
Apparently I had jackd2 already installed. But when I install qjackctl again, will it not also install jackd?
sudo apt-cache showpkg packagename
will tell you the dependencies
on second thoughts (if you dont have loads of personal configurations and projects under jack) then simply
sudo apt-get purge jack*
will remove all jack and all dependencies and remove all user settings and conf files.

sudo apt-get install qjackctl
to re-install

Dont perform the above if you have loads of projects and customised settings
Since seeing a few JACK and DAW related posts recently - I finally tried installing ardour and jack and a few other bits on my new laptop. I used to have a home recording set up like this on my old laptop. Thought it was about time to put it on my current one.....

And when I tried starting JACK - I got errors relating to JACK being unable to start and unable to connect as a client too.

What fixed it for me was going into the qjackctl settings and changing the driver from ALSA to NET. Then I restarted the JACK server in qjackctl and it started properly.

Then I stopped JACK and changed the driver back to ALSA, restarted JACK and it worked properly again.

Regarding video’s - I did manage to reproduce this problem myself.
Stopping JACK restored the audio. And starting JACK again caused the video to be silent.

I didn’t bother trying to fix this behaviour. Generally speaking - if I’m using JACK - I’m using it to record via a DAW, so I don’t want, or need to be wasting valuable CPU/RAM resources playing videos in the browser. And I don’t want any extra noise from the video, because I’m trying to hear what I’m recording.

But AFAIK, when JACK’s running, it takes ownership/control over the audio devices. So any audio needs to be routed through JACK

So I‘d imagine to get the browser audio working when JACK’s running - you’d probably have to set up a route for audio from the browser to the speaker output in JACKs settings. Assuming that JACK is able to pick the browser up as an audio source.... IDK!

But if you install JACK’s Pulseaudio plugin - that should allow JACK to detect the browser as an audio source.... I think?!
Last edited:

Members online