Solved In MX Linux I can't go back one page via alt+left arrow

Solved issue


New Member
Jan 31, 2023
Reaction score
Hello all,
I'm new to MX Linux and can't find a solution to this problem: When I press alt+left arrow in Firefox the window is getting pushed to the left side, instead of the browser going back one page. How can I change that?

Welcome to the forums.

With which desktop environment did you install MX Linux?

If it's XFCE then visit Settings Manager, Window Manager (not Tweaks), select Keyboard Shortcuts tab and then look for an entry that assigns ALT+LEFT ARROW. Press "Clear" button near the bottom of the dialog to suppress that assignment.

In MATE you go to Control Center, then Keyboard Shortcuts. The rest should be straightforward. :)

In KDE there is System Settings, then Keyboard Shortcuts. I don't remember well now since I'm typing this from Manjaro MATE LOL. There is a section for KWin, the window manager used in Plasma. Look for ALT+LEFT ARROW assignment, likely under "Workspaces" section.
Hi there,
Have you tried pressing ALT+CTRL+DEL to check out which programs you are running? Simply close the Firefox browser using the right key on your mouse.
Once reopened Firefox can be easily manipulated in the viewing screen by simply hovering over the parimiter (sorry can’t spell), until a double arrow appears, drag the browser window to the desired size and minimise and reopen. The Firefox browser window should then be the in full view on your screen.
Kind regards.
I think what the OP wants to do is to visit the page that they were on, after going "one level too deep".

For example accessing this sub-form and opening this topic. Then going back to the list of topics for "other distributions" with a keystroke combination, which the OP wants to be ALT+LEFT ARROW.

EDIT: Even though the topic really isn't MX-Linux specific, it's about the function of a specific web browser.

EDIT #2: LOL need to pay better attention to where I wander into...
Thanks for your answer Wendy. I'm pretty sure I'm under XFCE and already looked for a Window Manager, but it's not there under Settings.
But maybe it's not XFCE. I tried "ls /usr/bin/*-session" and "echo $XDG_CURRENT_DESKTOP" to get the information, but it didn't spill out anything. But I have a Xfce terminal application, maybe that's telling something.
I'm going to show you screens from ArcoLinux which has XFCE but the concept of the desktop environment is the same. Or it should be, unless the organizers of MX-Linux tried their best to hide it.

Settings Manager:

Window Manager/Keyboard tab:
I'm sorry, but I just found out, that I'm on Fluxbox. And now I found the solution: ~/.fluxbox/keys and there I commented out the key bindings for Alt/Alt-LogoKey + arrow keys.
Thank you so much for your efforts anyway!
Last edited:
The only Fluxbox I came into contact with was GParted distro, and I was scared away from Slax. LOL.

Therefore I could only offer a search result from DDG:

Sadly the one who wrote this document might have been given to showing off. I guess in the dot-config file you look for ALT+LEFT ARROW, open it in an ordinary text editor and do case-insensitive search for "alt" and "arrow". (Looking at that documentation might have to search instead for "mod1" or "left" instead.) Then wherever it is just erase it, exit the editor, log out your user and log back in again.

One of the members here should have more experience than me with Fluxbox.

Members online