How to fix "Problem: conflicting requests..." on dnf install on Centos?

senmx

New Member
Joined
Jun 5, 2020
Messages
2
Reaction score
0
Credits
16
Code:
[[email protected] boot]# dnf -y install --enablerepo=elrepo-kernel kernel-ml kernel-ml-devel
Repository centosplus is listed more than once in the configuration
Repository extras is listed more than once in the configuration
CentOS-8 - Base - 163.com                                                                                                                                                                                    0.0  B/s |   0  B     00:00
CentOS-8 - Updates - 163.com                                                                                                                                                                                 0.0  B/s |   0  B     00:00
Failed to synchronize cache for repo 'base', ignoring this repo.
Failed to synchronize cache for repo 'updates', ignoring this repo.
Last metadata expiration check: 1:24:23 ago on Thu 04 Jun 2020 08:51:43 AM CST.
Error:
 Problem: conflicting requests
  - package kernel-ml-5.7.0-1.el8.elrepo.x86_64 requires kernel-ml-core-uname-r = 5.7.0-1.el8.elrepo.x86_64, but none of the providers can be installed
  - package kernel-ml-5.6.15-1.el8.elrepo.x86_64 requires kernel-ml-core-uname-r = 5.6.15-1.el8.elrepo.x86_64, but none of the providers can be installed
  - package kernel-ml-core-5.7.0-1.el8.elrepo.x86_64 requires systemd-udev >= 203-2, but none of the providers can be installed
  - package kernel-ml-core-5.6.15-1.el8.elrepo.x86_64 requires systemd-udev >= 203-2, but none of the providers can be installed
  - package systemd-udev-239-18.el8_1.5.x86_64 obsoletes systemd < 229-5 provided by systemd-219-73.el7_8.6.x86_64
  - package systemd-python-219-73.el7_8.6.x86_64 requires systemd = 219-73.el7_8.6, but none of the providers can be installed
  - problem with installed package systemd-python-219-73.el7_8.6.x86_64

This also not work: dnf install kernel-ml-core-5.7.0-1.el8.elrepo.x86_64
Code:
[[email protected] etc]# dnf install  kernel-ml-core-5.7.0-1.el8.elrepo.x86_64
Repository centosplus is listed more than once in the configuration
Repository extras is listed more than once in the configuration
Extra Packages for Enterprise Linux 8 - x86_64                                                                                                                                                               0.0  B/s |   0  B     00:00
Extra Packages for Enterprise Linux 8 - x86_64                                                                                                                                                                16 MB/s | 6.8 MB     00:00
Oracle Linux / RHEL / CentOS-8 / x86_64 - VirtualBox                                                                                                                                                         0.0  B/s |   0  B     00:00
ELRepo.org Community Enterprise Linux Repository - el8                                                                                                                                                       0.0  B/s |   0  B     00:00
CentOS-8 - Base                                                                                                                                                                                              0.0  B/s |   0  B     00:00
Extra Packages for Enterprise Linux Modular 8 - x86_64                                                                                                                                                       0.0  B/s |   0  B     00:00
CentOS-8 - Base - 163.com                                                                                                                                                                                    0.0  B/s |   0  B     00:00
CentOS-8 - Updates - 163.com                                                                                                                                                                                 0.0  B/s |   0  B     00:00
CentOS-8 - AppStream                                                                                                                                                                                         0.0  B/s |   0  B     00:00
CentOS-8 - Extras                                                                                                                                                                                            0.0  B/s |   0  B     00:00
Failed to synchronize cache for repo 'base', ignoring this repo.
Failed to synchronize cache for repo 'updates', ignoring this repo.
No match for argument: kernel-ml-core-5.7.0-1.el8.elrepo.x86_64
Error: Unable to find a match: kernel-ml-core-5.7.0-1.el8.elrepo.x86_64
 


dos2unix

Well-Known Member
Joined
May 3, 2019
Messages
1,445
Reaction score
1,051
Credits
8,919
It simply means the requirements for these packages don't exist... anywhere in any of the repos.
I will say, not many I know who use CentOS have had much luck with elrepo.

If you really want to run a 5.6.x kernel on a redhat based Linux, your best bet is probably Fedora.
 
OP
senmx

senmx

New Member
Joined
Jun 5, 2020
Messages
2
Reaction score
0
Credits
16
It simply means the requirements for these packages don't exist... anywhere in any of the repos.
I will say, not many I know who use CentOS have had much luck with elrepo.

If you really want to run a 5.6.x kernel on a redhat based Linux, your best bet is probably Fedora.
Thank you very much, changed to archlinux....
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top