Horrible visual issue on Debian

ThrwWy

New Member
Joined
Apr 8, 2024
Messages
5
Reaction score
0
Credits
38
enter image description hereI've recently installed Debian on a fresh system with a new SSD but it has stopped being usable, now I can only reach the login screen which is 50% white. The screen flickers to fully white when I move the mouse and on login the screen goes fully black (no signal to the monitor). I can access the terminal otherwise have no control.

I am using an old Radeon card- an RX 460- but also have a Nvidia GTX 970 in there.
 


Try the following to make sure all the AMD stuff is installed


Reboot and see what happens
20240408_090229.jpg

I think all those are installed ok.
 
Some thoughts.

What is the system saying the driver is? Run:
Code:
lspci -nnkd ::300
or
Code:
lspci -nnk |grep -A3 -i vga

In post #3 it is not clear that firmware-amd-graphics is installed since it's not visible in the pic, though it may be loaded as you say "all those installed" in relation to post #2.

Some options to investigate are:

1. What happens if you add the kernel option: nomodeset?

If unclear about how to add the option (parameter), see the first answer here:

In your case just add the word: nomodeset, after a space on the linux line. If there are quotation marks, put the option inside the closing quote. This added kernel option only lasts for this boot.

2. Another option is to disable hardware acceleration and glamor acceleration, individually or together.
Those can be disabled with a code snippet like the the following code in a file named something like:
50-accels.conf.
Code:
Section "Device"
    Identifier "Card0"
    Driver     "amdgpu"
    Option "Accel" "off"
#   Option "AccelMethod" "none"
EndSection
Note that there is a commenting out (the # sign) of the second option because it's best to try one at a time before trying both together. Importantly the driver for the card should be the driver from the result of the lspci commands above. I've only guessed it to be amdgpu.

This code snippet can be placed in /usr/share/X11/xorg.conf.d/, after which you either reboot or restart X.

For some details on the accelerations, see: man amdgpu. Note that all of this is reversible in case it doesn't work and just puts you back to the start again.

You might like to also investigate the TearFree option mentioned on the man page.
 
Last edited:
Is that a Wayland or X11 session, if the latter try switching to a Wayland session?
 
Currently I don't see GRUB when I reboot, I'm not sure why. I added nomodeset to GRUB_CMDLINE_LINUX_DEFAULT and GRUB_CMDLINE_LINUX and can't see a difference.
 
Is that a Wayland or X11 session, if the latter try switching to a Wayland session?
I went into /etc/gdm3/daemon.conf and uncommented WaylandEnable=false, this fixed the issue with the login screen. So I think I have an issue with Wayland, but I am still getting a blank screen after login, whichever window manager I select. Edit: I can use Plasma (X11) ok
 
Last edited:
I went into /etc/gdm3/daemon.conf and uncommented WaylandEnable=false, this fixed the issue with the login screen. So I think I have an issue with Wayland, but I am still getting a blank screen after login, whichever window manager I select. Edit: I can use Plasma (X11) ok
What you configured now was how to setup native Wayland for GDM, I'm talking about just the login session. When you have the GDM login screen, you can select your username. Then at the bottom right you should be able to choose between an X11 and Wayland session.
 


Top