Dual Boot With Windows

MikeD

New Member
I have a Dell Studio XPS 435T / 9000 with a 1TB hard drive, old style BIOS.
Windows 8.1 is installed. Linux Pop OS is installed in a 400 GB partition behind the Windows partition. I would like to have the grub boot menu come up with the choice to boot Windows or Linux when the machine boots. I think the answer is to create a Linux boot partition in front of the windows partition. I have not been able to create any space in the front of the Windows partition to accomplish this. Does anyone have an answer to this problem ? Thanks ahead of time for taking time to read this post.
 


TechnoJunky

Well-Known Member
You don't have to position the the partition with Grub on it in any specific location. It could be at the beginning of the drive, middle or end. What matters is that the boot record is updated to point to it. So you say you have Pop OS installed. How do you boot to it if you don't have the grub menu at boot time?
 

TechnoJunky

Well-Known Member
I got that Mike could boot to either one, but maybe I'm wrong. Mike please explain more. Can you boot to both and if so, how do you do so without Grub? Did you just install Pop OS and now it just automatically boots to it without an option for Windows?
 

MikeD

New Member
I can boot to either Windows or Linux.
To boot Linux I must go to Bios Boot Options menu.
Choose the Linux partition.
Grub boot menu appears with choice to boot Windows or Linux.
Wait for countdown (or make choice) and Linux boots.
If I boot normally (without going to the BIOS menu), Windows boots automatically.
No grub menu, no choices....
 

TechnoJunky

Well-Known Member
I'm confused more now. You say in the original message "I would like to have the grub boot menu come up with the choice to boot Windows or Linux when the machine boots.". Then in this last message you say "To boot Linux I must go to Bios....Grub boot menu appears with choice to boot Windows or Linux.". Why is this setting not what you want?
 

TechnoJunky

Well-Known Member
ok, re-reading your message. Sounds like it's always a manual step to boot to Linux, never remembers the setting. How did Pop OS get on your computer? Did you install it? If you did, when you were installing, did you tell it to update the boot record on SDA? How old is this computer?
 

TechnoJunky

Well-Known Member
Also, when you say you're going into the Bios, are you really going into it or are you just getting a boot menu by pressing F12? I have a Dell laptop that I bought a couple years ago and in the Bios, I have an option to choose what OS to boot to as the default. I dual boot as well, but by choosing Neon as the default, it always boots to Grub, even though Grub is on my Linux partition in the middle of the drive.
 

MikeD

New Member
Correct, I do have to take the manual step of interrupting the bios to boot Linux. I installed Linux from a thumb drive. I don't remember an option to "update the boot record on SDA". My computer was brand new in 2010.. I know, it's ancient, but it runs great...
 

TechnoJunky

Well-Known Member
I'm going to suggest using the link below to Grub-Repair. I've used it a couple times myself. I'd suggest downloading a copy of Ubuntu onto a pen drive, boot to it, then follow the instructions. I don't know much about Pop OS, you may not be able to add PPAs to it. But this should then fix your boot record to tell it to go to Grub every time.
 

MikeD

New Member
Thanks TechnoJunky..
I followed the instructions in the link given. After running the boot repair program an error was generated. In part it said "Boot files are far from the start of disk. Your bios may not detect them. You may want to re-try after creating a /boot partition (Ext4, >200Mb start of the disk)".
The computer still boots to Windows automatically, (unless you go through the bios boot options menu). So, looks like I am back to my original assumption that I need to create a Linux boot partition in front of the Windows partition.
 


Members online


Latest posts

Top