Purchase Linux CDs / DVDs / Flash Drives at OSDisc.com

Welcome to Our Community

While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd, 2017 please sign up again. Thanks!

  1. Follow us on twitter - we shoot all of our new original content out as well as random messages. https://twitter.com/linuxdotorg
    Dismiss Notice

Dual boot issues...

Discussion in 'General Computing' started by jbar2016, Feb 9, 2019 at 11:07 AM.

  1. jbar2016

    jbar2016 New Member

    Joined:
    Mar 27, 2018
    Messages:
    15
    Likes Received:
    8
    I am trying to get windows 10 and linux mint to dual boot...

    I installed windows 10, then setup a dual boot with a 55/45 drive setup. Linux successfully does it's thing, and all seems well in the beginning. Linux bring up the dual boot screen in grub and both windows and linux boot great.

    I run into my issue after i boot windows 10, when i am done on win10 i restart the pc and wait for grub but windows boot manager has taken control of my pc and will not let grub boot.


    (Log in to hide this advertisement)


    I did look around and found a few solutions that failed to work, i disabled fast startup within windows, i then reset my bios to allow grub to load, and then disabled quick boot in bios, but that did not work.

    Is this a windows 10 issue, my pc originally had windows 7 on it and was upgraded to 10 sometime in the past.

    This is a 2nd gen core i5 hp desktop, same results on a 2nd gen core ie hp desktop
     
  2. jbar2016

    jbar2016 New Member

    Joined:
    Mar 27, 2018
    Messages:
    15
    Likes Received:
    8
    I believe i have found a solution.

    The fix i found was on itsfoss.com, i have only tested twice and could still revert, but so far it is working.

    Within windows
    Use command prompt with admin privileges

    Use:
    bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi
     
    wizardfromoz likes this.
  3. Bayou Bengal

    Bayou Bengal Active Member

    Joined:
    Sep 14, 2017
    Messages:
    154
    Likes Received:
    161
    Hi jbar! Watch this video, it's the way I dual boot with Windows 7 and a Windows 10 machine. It shows how to separate Grub and Windows MBR so they can't interfere with each other (this is real important when microcrap sends out those mandatory updates for windoze 10). The big problem with Windoze 10 is it doesn't completely shutdown when you reboot. That's how microcrap can claim faster boot times. If you follow this method it will solve the issue, but your Grub and MBR are already coexisting on the same Windoze boot partition. You may need to uninstall your Linux and then reinstall it.

    Good luck!

     
    wizardfromoz likes this.
  4. wizardfromoz

    wizardfromoz Super Moderator
    Staff Member Gold Supporter

    Joined:
    Apr 30, 2017
    Messages:
    2,294
    Likes Received:
    1,995
    G'day @jbar2016 , you're getting to be a good troubleshooter :)

    The issue you describe in #1 can be problematic with Windows 10 in a dualboot situation, whereby certain updates on Windows may run, which feature some modification to their kernel, that then overrides the Linux Kerne's control over the bootloading management.

    The fix you found sounds familiar, but if the process repeats in future, then we can look at longer-term solutions.

    BB's (@Bayou Bengal 's) input is also good value (as I would expect :D), and is certainly a viable option. Although the author of the vid talks up even more of a storm than I do :D:D

    Windows Fast Boot and Hibernation are the culprits in what BB is saying, so unless you feel a need for them, switch them off.

    Cheers

    Wizard
     

Share This Page