Canon Printer Drivers MB-2720

JBW

New Member
Credits
0
Has anyone had any success in installing a Canon Maxify MB-2720 multifunction printer with Ubuntu 10.04? Canon does not support Linux for this item. Any help welcomed!
 


atanere

Well-Known Member
Credits
0
Has anyone had any success in installing a Canon Maxify MB-2720 multifunction printer with Ubuntu 10.04? Canon does not support Linux for this item. Any help welcomed!
Hi @JBW, and welcome to the site! It looks like Canon does provide a driver for your printer (the Debian Package Archive to use with Ubuntu):

https://www.usa.canon.com/internet/...-office-printers/mb2720?tab=drivers_downloads

But... Ubuntu 10.04.... really? That is long since past end-of-life unless you mistyped the version. You may need to get current with Ubuntu to achieve proper updates and support for anything. I think the latest Long Term Support (LTS) is 16.04.4 --- but a new LTS version is coming out in April, version 18.04. If you are using 10.04, I'm not even sure if you can upgrade that.... you may need to do a clean install from scratch.

Cheers
 

JBW

New Member
Credits
0
Hi @JBW, and welcome to the site! It looks like Canon does provide a driver for your printer (the Debian Package Archive to use with Ubuntu):

https://www.usa.canon.com/internet/...-office-printers/mb2720?tab=drivers_downloads

But... Ubuntu 10.04.... really? That is long since past end-of-life unless you mistyped the version. You may need to get current with Ubuntu to achieve proper updates and support for anything. I think the latest Long Term Support (LTS) is 16.04.4 --- but a new LTS version is coming out in April, version 18.04. If you are using 10.04, I'm not even sure if you can upgrade that.... you may need to do a clean install from scratch.

Cheers
Hi @JBW, and welcome to the site! It looks like Canon does provide a driver for your printer (the Debian Package Archive to use with Ubuntu):

https://www.usa.canon.com/internet/...-office-printers/mb2720?tab=drivers_downloads

But... Ubuntu 10.04.... really? That is long since past end-of-life unless you mistyped the version. You may need to get current with Ubuntu to achieve proper updates and support for anything. I think the latest Long Term Support (LTS) is 16.04.4 --- but a new LTS version is coming out in April, version 18.04. If you are using 10.04, I'm not even sure if you can upgrade that.... you may need to do a clean install from scratch.

Cheers
My bad! You are right. My version is 16.04LTS, and up to date! Thanks for the link, I'll check it out. Canon rep I spoke to told me they didn't support Linux. This is good news.
 


Members online


Latest posts

Top